aboutsummaryrefslogtreecommitdiff
path: root/gnu/packages
diff options
context:
space:
mode:
authorDanny Milosavljevic <dannym@friendly-machines.com>2024-08-27 00:18:07 +0200
committerDanny Milosavljevic <dannym@friendly-machines.com>2024-08-27 00:18:07 +0200
commit7876575bbf92a113bde9d5e89a64baaa09e690c4 (patch)
treed745b80b9bad7a0d7d40879f6a99f9119f1b0160 /gnu/packages
parent78183b0c60edeb46a020329d9af0ad3b31cd0313 (diff)
downloadguix-7876575bbf92a113bde9d5e89a64baaa09e690c4.tar
guix-7876575bbf92a113bde9d5e89a64baaa09e690c4.tar.gz
gnu: Add emacs-comment-tags.
* gnu/packages/emacs-xyz.scm (emacs-comment-tags): New variable. Change-Id: I33986a415384523129a6a717cfa4b21091982a0c
Diffstat (limited to 'gnu/packages')
-rw-r--r--gnu/packages/emacs-xyz.scm23
1 files changed, 23 insertions, 0 deletions
diff --git a/gnu/packages/emacs-xyz.scm b/gnu/packages/emacs-xyz.scm
index 864e349208..127c2bfe53 100644
--- a/gnu/packages/emacs-xyz.scm
+++ b/gnu/packages/emacs-xyz.scm
@@ -8083,6 +8083,29 @@ colors random but consistent between same tags, colors are generated from the
hash of the tag names.")
(license license:gpl3+))))
+(define-public emacs-comment-tags
+ ;; Upstream didn't tag a working version.
+ (let ((commit "7d914097f0a03484af71e621db533737fc692f58")
+ (revision "1"))
+ (package
+ (name "emacs-comment-tags")
+ (version (git-version "0.1" revision commit))
+ (source (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/vincekd/comment-tags.git")
+ (commit commit)))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32
+ "0s86a7078arck9z4gzkp2hnxyklprl0zh5hsw7nkyyscjydly80i"))))
+ (build-system emacs-build-system)
+ (synopsis "Minor mode to show comments which have tags like TODO")
+ (description "This package provides a minor mode to show all lines that
+have a comment with a tag, for example listing them right next to each other.")
+ (home-page "https://github.com/vincekd/comment-tags")
+ (license license:gpl3+))))
+
(define-public emacs-org-rich-yank
(package
(name "emacs-org-rich-yank")