aboutsummaryrefslogtreecommitdiff
path: root/gnu/packages
diff options
context:
space:
mode:
authorSharlatan Hellseher <sharlatanus@gmail.com>2024-07-25 21:26:19 +0100
committerSharlatan Hellseher <sharlatanus@gmail.com>2024-07-25 21:26:19 +0100
commit734bf6bf02494e75808404c63b4c4f6384835f8a (patch)
treeb92c63521f248fba3c3c3859f0a77330c69da7b2 /gnu/packages
parentefdef61831e543bb63d0fc4abbc4b93d5ac8097e (diff)
downloadguix-734bf6bf02494e75808404c63b4c4f6384835f8a.tar
guix-734bf6bf02494e75808404c63b4c4f6384835f8a.tar.gz
gnu: go-github-com-hjson-hjson-go: Rename variable.
* gnu/packages/golang-web.scm (go-github-com-hjson-hjson-go): Rename variable to go-github-com-hjson-hjson-go-v4 to reflect go.mod import path. Apply new package style. * gnu/packages/networking.scm (yggdrasil) [propagated-inputs]: Remove go-github-com-hjson-hjson-go, add go-github-com-hjson-hjson-go-v4. * gnu/packages/uucp.scm (nncp) [propagated-inputs]: Remove go-github-com-hjson-hjson-go, add go-github-com-hjson-hjson-go-v4. Change-Id: I9e99f208feaf535d9946e11dff09a81fc4a01a7a
Diffstat (limited to 'gnu/packages')
-rw-r--r--gnu/packages/golang-web.scm14
-rw-r--r--gnu/packages/networking.scm3
-rw-r--r--gnu/packages/uucp.scm2
3 files changed, 10 insertions, 9 deletions
diff --git a/gnu/packages/golang-web.scm b/gnu/packages/golang-web.scm
index 629af677d9..e697fd716f 100644
--- a/gnu/packages/golang-web.scm
+++ b/gnu/packages/golang-web.scm
@@ -1379,9 +1379,9 @@ the Go standard library, but returns a client that does not share any state
with other clients.")
(license license:mpl2.0)))
-(define-public go-github-com-hjson-hjson-go
+(define-public go-github-com-hjson-hjson-go-v4
(package
- (name "go-github-com-hjson-hjson-go")
+ (name "go-github-com-hjson-hjson-go-v4")
(version "4.4.0")
(source
(origin
@@ -1394,12 +1394,14 @@ with other clients.")
(base32 "1d4b2hpqsnzbmfhgxq15hd19rjr5hydjmpblrh5yzfgx9z3cz2by"))))
(build-system go-build-system)
(arguments
- '(#:import-path "github.com/hjson/hjson-go"))
+ (list
+ #:import-path "github.com/hjson/hjson-go/v4"))
(home-page "https://hjson.org/")
(synopsis "Human JSON implementation for Go")
- (description "Hjson is a syntax extension to JSON. It is intended to be
-used like a user interface for humans, to read and edit before passing the
-JSON data to the machine.")
+ (description
+ "Hjson is a syntax extension to JSON. It is intended to be used like a
+user interface for humans, to read and edit before passing the JSON data to
+the machine.")
(license license:expat)))
(define-public go-github-com-jackpal-gateway
diff --git a/gnu/packages/networking.scm b/gnu/packages/networking.scm
index c1c609cef9..efd2864c30 100644
--- a/gnu/packages/networking.scm
+++ b/gnu/packages/networking.scm
@@ -4658,14 +4658,13 @@ QUIC protocol.")
go-github-com-bits-and-blooms-bitset
go-github-com-bits-and-blooms-bloom
go-github-com-quic-go-quic-go
- go-github-com-hjson-hjson-go
+ go-github-com-hjson-hjson-go-v4
go-github-com-olekukonko-tablewriter
go-github-com-mitchellh-mapstructure
go-github-com-mattn-go-runewidth
go-github-com-mattn-go-isatty
go-github-com-mattn-go-colorable
go-github-com-kardianos-minwinsvc
- go-github-com-hjson-hjson-go
go-github-com-hashicorp-go-syslog
go-github-com-gologme-log
go-github-com-fatih-color
diff --git a/gnu/packages/uucp.scm b/gnu/packages/uucp.scm
index d8eb17111d..34de6bdec9 100644
--- a/gnu/packages/uucp.scm
+++ b/gnu/packages/uucp.scm
@@ -149,7 +149,7 @@ between computers.")
go-github-com-dustin-go-humanize
go-github-com-flynn-noise
go-github-com-gorhill-cronexpr
- go-github-com-hjson-hjson-go
+ go-github-com-hjson-hjson-go-v4
go-github-com-klauspost-compress
go-golang-org-x-crypto
go-golang-org-x-net