aboutsummaryrefslogtreecommitdiff
path: root/gnu/packages
diff options
context:
space:
mode:
authorjgart <jgart@dismail.de>2024-10-07 15:46:26 -0500
committerjgart <jgart@dismail.de>2024-10-10 22:08:31 -0500
commit701bced65e578cb97743c24e7744ee0862ef252d (patch)
tree91902910f78603ef1de2ea3a3647cba47212cc0d /gnu/packages
parent01db401dc82179f83b38dcc5b393c16db7cdb701 (diff)
downloadguix-701bced65e578cb97743c24e7744ee0862ef252d.tar
guix-701bced65e578cb97743c24e7744ee0862ef252d.tar.gz
gnu: todoman: Update to 4.4.0.
* gnu/packages/task-management.scm (todoman): Update to 4.4.0. [build-system]: Use pyproject-build-system. [arguments]: Remove not needed patch-tests phase and remove unused arguments to check phase. [native-inputs]: Remove python-setuptools-scm. Add python-pytz, python-hypothesis, and python-pytest-runner. Indent by one space instead of two. [propagated-inputs]: Indent by one space instead of two. Change-Id: I07cf40cecda4e9fea149204a6d30438b15233ef9
Diffstat (limited to 'gnu/packages')
-rw-r--r--gnu/packages/task-management.scm48
1 files changed, 23 insertions, 25 deletions
diff --git a/gnu/packages/task-management.scm b/gnu/packages/task-management.scm
index d472a65174..30eaef16a6 100644
--- a/gnu/packages/task-management.scm
+++ b/gnu/packages/task-management.scm
@@ -439,24 +439,20 @@ on arbitrary tasks. All the time data is saved in files residing in the
(define-public todoman
(package
(name "todoman")
- (version "4.1.0")
+ (version "4.4.0")
(source
- (origin
- (method url-fetch)
- (uri (pypi-uri "todoman" version))
- (sha256
- (base32 "1j2h5cv8wnmw41fpz1ggsgi599qhk184cas9kgd92glj3m4alg6f"))))
- (build-system python-build-system)
+ (origin
+ (method url-fetch)
+ (uri (pypi-uri "todoman" version))
+ (sha256
+ (base32 "1dlxmw919jvjxycf315vzs4f5q64gdjrp3988y8jkyivqywfwyqb"))))
+ (build-system pyproject-build-system)
(arguments
(list
#:phases
#~(modify-phases %standard-phases
- (add-after 'unpack 'patch-tests
- (lambda _
- (substitute* '("tests/test_cli.py" "tests/test_formatter.py")
- (("tests\\.helpers") "helpers"))))
(replace 'check
- (lambda* (#:key inputs outputs tests? #:allow-other-keys)
+ (lambda* (#:key tests? #:allow-other-keys)
(when tests?
(invoke "pytest" "--hypothesis-profile=ci"
"-vv" "tests" "-k"
@@ -466,20 +462,22 @@ on arbitrary tasks. All the time data is saved in files residing in the
;; Unknown failure
"and not test_default_command_args"))))))))
(native-inputs
- (list python-setuptools-scm
- python-pytest
- python-pytest-cov
- python-freezegun))
+ (list python-freezegun
+ python-hypothesis
+ python-pytest
+ python-pytest-cov
+ python-pytest-runner
+ python-pytz))
(propagated-inputs
- (list python-atomicwrites
- python-click
- python-click-log
- python-dateutil
- python-humanize
- python-icalendar
- python-parsedatetime
- python-pyxdg
- python-urwid))
+ (list python-atomicwrites
+ python-click
+ python-click-log
+ python-dateutil
+ python-humanize
+ python-icalendar
+ python-parsedatetime
+ python-pyxdg
+ python-urwid))
(home-page "https://todoman.readthedocs.io/")
(synopsis "CalDav-based todo manager")
(description "Todoman is a simple, standards-based, cli todo (aka: task)