aboutsummaryrefslogtreecommitdiff
path: root/gnu/packages
diff options
context:
space:
mode:
authorVinicius Monego <monego@posteo.net>2024-07-13 09:24:27 -0300
committerVinicius Monego <monego@posteo.net>2024-07-14 10:24:01 -0300
commit67afc0afa3835dd7005a661838731387a5b0518d (patch)
tree69dca1a0317fac7184220580b70df7d92eba5981 /gnu/packages
parent14737ed048566c5bfc20eee55373e3f81871ec13 (diff)
downloadguix-67afc0afa3835dd7005a661838731387a5b0518d.tar
guix-67afc0afa3835dd7005a661838731387a5b0518d.tar.gz
gnu: python-hy: Move to pyproject-build-system.
* gnu/packages/python-xyz.scm (python-hy)[build-system]: Move to pyproject-build-system. [arguments]: Remove custom 'check phase. Use #:test-flags to skip a failing test and enable other previously failing tests. Change-Id: Ic5df4459f192ee79652dc77390d041999e505152
Diffstat (limited to 'gnu/packages')
-rw-r--r--gnu/packages/python-xyz.scm17
1 files changed, 4 insertions, 13 deletions
diff --git a/gnu/packages/python-xyz.scm b/gnu/packages/python-xyz.scm
index 09b9378bc7..b8db6c41da 100644
--- a/gnu/packages/python-xyz.scm
+++ b/gnu/packages/python-xyz.scm
@@ -18414,20 +18414,11 @@ with a new public API, and RPython support.")
(file-name (git-file-name name version))
(sha256
(base32 "0fp5x94hyckjfap2pb1rj551a3q70vrljxark7hj9kdhr7prbggi"))))
- (build-system python-build-system)
+ (build-system pyproject-build-system)
(arguments
- (list
- #:phases
- #~(modify-phases %standard-phases
- (replace 'check
- (lambda* (#:key tests? #:allow-other-keys)
- (when tests?
- (invoke "python" "-m" "pytest" "-k"
- (string-append ; skip some failed tests
- "not test_sys_executable"
- " and not test_circular_macro_require"
- " and not test_macro_require"
- " and not test_requires_pollutes_core"))))))))
+ ;; This test expects the hy executable to be called 'hy', but in Guix
+ ;; it's .hy-real.
+ (list #:test-flags #~(list "-k" "not test_sys_executable")))
(native-inputs
(list python-pytest-next python-wheel))
(propagated-inputs