aboutsummaryrefslogtreecommitdiff
path: root/gnu/packages
diff options
context:
space:
mode:
authorNicolas Goaziou <mail@nicolasgoaziou.fr>2023-08-22 15:45:33 +0200
committerNicolas Goaziou <mail@nicolasgoaziou.fr>2023-08-24 11:10:34 +0200
commit6772083e57b178da4666220df00e95489e8cfbcf (patch)
tree70268ef8bc58d495440bc275cff7e502301c6407 /gnu/packages
parentdb921966285467f6763d8177b8c942a9212ba9c6 (diff)
downloadguix-6772083e57b178da4666220df00e95489e8cfbcf.tar
guix-6772083e57b178da4666220df00e95489e8cfbcf.tar.gz
gnu: Add texlive-hep-paper.
* gnu/packages/tex.scm (texlive-hep-paper): New variable.
Diffstat (limited to 'gnu/packages')
-rw-r--r--gnu/packages/tex.scm25
1 files changed, 25 insertions, 0 deletions
diff --git a/gnu/packages/tex.scm b/gnu/packages/tex.scm
index 6cab37ee26..eee596d996 100644
--- a/gnu/packages/tex.scm
+++ b/gnu/packages/tex.scm
@@ -15982,6 +15982,31 @@ always italic and upright in math and text mode respectively. Some math font
macros are adjusted to give more consistently the naively expected results.")
(license license:lppl1.3c)))
+(define-public texlive-hep-paper
+ (package
+ (name "texlive-hep-paper")
+ (version (number->string %texlive-revision))
+ (source (texlive-origin
+ name version
+ (list "doc/latex/hep-paper/"
+ "source/latex/hep-paper/"
+ "tex/latex/hep-paper/")
+ (base32
+ "05dx8vsyr8ylvfqs3s9krjrqml8qivwlwhga4ghbnd3nkkqkx95a")))
+ (outputs '("out" "doc"))
+ (build-system texlive-build-system)
+ (home-page "https://ctan.org/pkg/hep-paper")
+ (synopsis "Publications in @emph{High Energy Physics}")
+ (description
+ "This package aims to provide a single style file containing most
+configurations and macros necessary to write appealing publications in
+@emph{High Energy Physics}. Instead of reinventing the wheel by introducing
+newly created macros, hep-paper preferably loads third party packages as long
+as they are light-weight enough. For usual publications it suffices to load
+the @code{hep-paper} package, without optional arguments, in addition to the
+@code{article} class.")
+ (license license:lppl1.3c)))
+
(define-public texlive-hep-reference
(package
(name "texlive-hep-reference")