aboutsummaryrefslogtreecommitdiff
path: root/gnu/packages
diff options
context:
space:
mode:
authorSharlatan Hellseher <sharlatanus@gmail.com>2024-10-23 21:10:26 +0100
committerSharlatan Hellseher <sharlatanus@gmail.com>2024-10-24 10:59:58 +0100
commit64ed49873784e5ef9d78b23a52354e3e6f9a63c8 (patch)
tree859f9ed83668bdb2be29d69ff25bd93f13055cc9 /gnu/packages
parent6c72e72ae80ac3ab8b810c0df187df52c1ecbebe (diff)
downloadguix-64ed49873784e5ef9d78b23a52354e3e6f9a63c8.tar
guix-64ed49873784e5ef9d78b23a52354e3e6f9a63c8.tar.gz
gnu: primecount: Update to 7.14.
* gnu/packages/maths.scm (primecount): Update to 7.14. [argumetns]<#configure-flags>: Build man pages, link to existing primesieve package. [inputs]: Add primesieve. [native-inputs]: Add asciidoc. Change-Id: Ia6405274c86c3f996bcaa533cb86226da047fbfa
Diffstat (limited to 'gnu/packages')
-rw-r--r--gnu/packages/maths.scm12
1 files changed, 9 insertions, 3 deletions
diff --git a/gnu/packages/maths.scm b/gnu/packages/maths.scm
index 94187be6b7..50d517f834 100644
--- a/gnu/packages/maths.scm
+++ b/gnu/packages/maths.scm
@@ -3685,7 +3685,7 @@ functions.")
(define-public primecount
(package
(name "primecount")
- (version "7.13")
+ (version "7.14")
(source (origin
(method git-fetch)
(uri (git-reference
@@ -3694,12 +3694,18 @@ functions.")
(file-name (git-file-name name version))
(sha256
(base32
- "0v3zm6mw4fb6a33zi542x94w1nd54rvn7r8dav670jm9dn60jfsn"))))
+ "097p3wfq6ds56275cra678hzg8cp2vd1ccllsi8wczrf0qvq91rp"))))
(build-system cmake-build-system)
(arguments
- (list #:configure-flags #~(list "-DBUILD_SHARED_LIBS=ON"
+ (list #:configure-flags #~(list "-DBUILD_LIBPRIMESIEVE=OFF"
+ "-DBUILD_MANPAGE=ON"
+ "-DBUILD_SHARED_LIBS=ON"
"-DBUILD_STATIC_LIBS=OFF"
"-DBUILD_TESTS=ON")))
+ (native-inputs
+ (list asciidoc))
+ (inputs
+ (list primesieve))
(home-page "https://github.com/kimwalisch/primecount")
(synopsis "Fast prime counting function implementations")
(description "@code{primecount} is a command-line program and C/C++