aboutsummaryrefslogtreecommitdiff
path: root/gnu/packages
diff options
context:
space:
mode:
authorSughosha <sughosha@disroot.org>2024-11-01 17:30:20 +0530
committerZheng Junjie <zhengjunjie@iscas.ac.cn>2024-11-02 21:53:27 +0800
commit64a3a914a083cf2ec4f358b055c0e2a87f911a02 (patch)
tree8ee9bc2f03188ffd4626e8cecec08b789f5506d3 /gnu/packages
parent36641bc7c557e155edb7a5bad29a7334c6dfb639 (diff)
downloadguix-64a3a914a083cf2ec4f358b055c0e2a87f911a02.tar
guix-64a3a914a083cf2ec4f358b055c0e2a87f911a02.tar.gz
gnu: Add kapptemplate.
* gnu/packages/kde.scm (kapptemplate): New variable. Change-Id: I25b930749db5c366496f2b883bbde838aa583383 Signed-off-by: Zheng Junjie <zhengjunjie@iscas.ac.cn>
Diffstat (limited to 'gnu/packages')
-rw-r--r--gnu/packages/kde.scm42
1 files changed, 42 insertions, 0 deletions
diff --git a/gnu/packages/kde.scm b/gnu/packages/kde.scm
index f11332ee67..88ab25de40 100644
--- a/gnu/packages/kde.scm
+++ b/gnu/packages/kde.scm
@@ -413,6 +413,48 @@ it is not reserved to specialists and can be used for small personal
projects.")
(license license:gpl2+)))
+(define-public kapptemplate
+ (package
+ (name "kapptemplate")
+ (version "24.05.2")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (string-append "mirror://kde/stable/release-service/" version
+ "/src/kapptemplate-" version ".tar.xz"))
+ (sha256
+ (base32 "0mgpk6879dprhpxmbdgbb6sz3ik9ycav4sihh20qmsgj09h8qp3g"))))
+ (build-system qt-build-system)
+ (arguments
+ (list #:qtbase qtbase
+ #:configure-flags
+ #~(list "-DBUILD_TESTING=ON")))
+ (native-inputs
+ (list extra-cmake-modules kdoctools))
+ (inputs
+ (list karchive
+ kcompletion
+ kconfigwidgets
+ kcoreaddons
+ ki18n
+ kio))
+ (home-page "https://apps.kde.org/kapptemplate/")
+ (synopsis "Factory for easy creation of KDE/Qt components and programs")
+ (description "KAppTemplate is an application to start development quickly
+using existing templates providing basic repeatedly written code and a proper
+structure. It features:
+
+@itemize
+@item Templates for C++, Ruby, Python and PHP
+@item Categories
+@item Templates for different build-systems and frameworks
+@item Templates especially for KDE-development (plugins for Plasma, QtQuick
+ KTextEditor, KRunner, Akonadi)
+@item New templates using space holders and a simple CMake-command
+@item Integration into KDevelop
+@end itemize")
+ (license license:gpl2+)))
+
(define-public kdevelop
(package
(name "kdevelop")