aboutsummaryrefslogtreecommitdiff
path: root/gnu/packages
diff options
context:
space:
mode:
authorLudovic Courtès <ludo@gnu.org>2015-03-17 11:38:02 +0100
committerLudovic Courtès <ludo@gnu.org>2015-03-17 13:49:18 +0100
commit619936a4c81d524ddcd26a6fca34d51617b4b477 (patch)
tree87fabcf3ae0bd85523b0ddc67589a923a2097019 /gnu/packages
parentdb62afa55ad443cc50bcafe64eb3ba239eae9c11 (diff)
downloadguix-619936a4c81d524ddcd26a6fca34d51617b4b477.tar
guix-619936a4c81d524ddcd26a6fca34d51617b4b477.tar.gz
gnu: Add python2-rsvg.
* gnu/packages/gnome.scm (python2-rsvg): New variable.
Diffstat (limited to 'gnu/packages')
-rw-r--r--gnu/packages/gnome.scm31
1 files changed, 31 insertions, 0 deletions
diff --git a/gnu/packages/gnome.scm b/gnu/packages/gnome.scm
index b547b81f43..3b70e27816 100644
--- a/gnu/packages/gnome.scm
+++ b/gnu/packages/gnome.scm
@@ -1590,3 +1590,34 @@ Extension known as XKB. This library is indended to support XFree86 and other
commercial X servers. It is useful for creating XKB-related software (layout
indicators etc).")
(license license:lgpl2.0+)))
+
+(define-public python2-rsvg
+ ;; XXX: This is actually a subset of gnome-python-desktop.
+ (package
+ (name "python2-rsvg")
+ (version "2.32.0")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (string-append
+ "mirror://gnome/sources/gnome-python-desktop/2.32/gnome-python-desktop-"
+ version ".tar.bz2"))
+ (sha256
+ (base32
+ "1s8f9rns9v7qlwjv9qh9lr8crp88dpzfm45hj47zc3ivpy0dbnq9"))))
+ (build-system gnu-build-system)
+ (native-inputs
+ `(("pkg-config" ,pkg-config)))
+ (inputs
+ `(("python" ,python-2)
+ ("python2-pygtk" ,python2-pygtk)
+ ("librsvg" ,librsvg)))
+ (home-page "http://www.gnome.org")
+ (synopsis "Python bindings to librsvg")
+ (description
+ "This packages provides Python bindings to librsvg, the SVG rendering
+library.")
+
+ ;; This is the license of the rsvg bindings. The license of each module
+ ;; of gnome-python-desktop is given in 'COPYING'.
+ (license license:lgpl2.1+)))