aboutsummaryrefslogtreecommitdiff
path: root/gnu/packages
diff options
context:
space:
mode:
authorRicardo Wurmus <rekado@elephly.net>2024-04-29 10:31:43 +0200
committerRicardo Wurmus <rekado@elephly.net>2024-05-05 22:38:15 +0200
commit5f186e2f7931ce1f777fc0417b707f7469944425 (patch)
treedbce998dd67ce0bd652869368610f1061f857f19 /gnu/packages
parent6f71c4ab0163413c9498be6716bc9b9e1dc5d4c4 (diff)
downloadguix-5f186e2f7931ce1f777fc0417b707f7469944425.tar
guix-5f186e2f7931ce1f777fc0417b707f7469944425.tar.gz
gnu: Add python-pyct.
* gnu/packages/python-xyz.scm (python-pyct): New variable. Change-Id: Ia207d5aa9d66fd2bf3616049c042fbb12e50928d
Diffstat (limited to 'gnu/packages')
-rw-r--r--gnu/packages/python-xyz.scm29
1 files changed, 29 insertions, 0 deletions
diff --git a/gnu/packages/python-xyz.scm b/gnu/packages/python-xyz.scm
index 80ec3c9d0a..c30035952d 100644
--- a/gnu/packages/python-xyz.scm
+++ b/gnu/packages/python-xyz.scm
@@ -9512,6 +9512,35 @@ Python code against some of the style conventions in
@url{http://www.python.org/dev/peps/pep-0008/,PEP 8}.")
(license license:expat)))
+(define-public python-pyct
+ (package
+ (name "python-pyct")
+ (version "0.5.0")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (pypi-uri "pyct" version))
+ (sha256
+ (base32 "1856dbrcpc0nxxhlfh3dqzz7xxn5sdi600q45hsprqyqrg2lm7yx"))))
+ (build-system pyproject-build-system)
+ (arguments
+ (list
+ #:test-flags
+ ;; These tests want to download example data from the internet.
+ '(list "-k" (string-append
+ "not test_examples_with_use_test_data"
+ " and not test_examples_using_test_data_and_force_with_prexisting_content_in_target"
+ " and not test_fetch_data_using_test_data_with_no_file_in_data_copies_from_stubs"
+ " and not test_fetch_data_using_test_data_and_force_with_file_in_data_over_writes"))))
+ (propagated-inputs (list python-param python-pyyaml))
+ (native-inputs (list python-flake8 python-pytest))
+ (home-page "https://github.com/holoviz-dev/pyct")
+ (synopsis "Common packaging tasks")
+ (description
+ "This Python package provides utilities to run common packaging tasks,
+e.g. copy examples, fetch data, etc.")
+ (license license:bsd-3)))
+
(define-public python-multidict
(package
(name "python-multidict")