aboutsummaryrefslogtreecommitdiff
path: root/gnu/packages
diff options
context:
space:
mode:
authorArtyom V. Poptsov <poptsov.artyom@gmail.com>2024-09-11 22:23:11 +0300
committerSharlatan Hellseher <sharlatanus@gmail.com>2024-09-16 21:55:08 +0100
commit58405cbe3abef0a511bba32cf321981766f1b231 (patch)
tree3e2b6d364541cb429b162827a183250f0281ded6 /gnu/packages
parent3bcdb6a92e2ed49a4a0b290288e2bf052eddae57 (diff)
downloadguix-58405cbe3abef0a511bba32cf321981766f1b231.tar
guix-58405cbe3abef0a511bba32cf321981766f1b231.tar.gz
gnu: Add go-github-com-tannerryan-ring.
* gnu/packages/golang-xyz.scm (go-github-com-tannerryan-ring): New variable. Change-Id: I14d280d6af0dd25ee8b2bd1a7565640223fdbe21 Signed-off-by: Sharlatan Hellseher <sharlatanus@gmail.com>
Diffstat (limited to 'gnu/packages')
-rw-r--r--gnu/packages/golang-xyz.scm24
1 files changed, 24 insertions, 0 deletions
diff --git a/gnu/packages/golang-xyz.scm b/gnu/packages/golang-xyz.scm
index c2059b7906..037cef32db 100644
--- a/gnu/packages/golang-xyz.scm
+++ b/gnu/packages/golang-xyz.scm
@@ -6309,6 +6309,30 @@ slices, JSON and other data.")
storage system.")
(license license:bsd-2)))
+(define-public go-github-com-tannerryan-ring
+ (package
+ (name "go-github-com-tannerryan-ring")
+ (version "1.1.2")
+ (source
+ (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/tannerryan/ring")
+ (commit (string-append "v" version))))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32 "07q5qcg2wv696nnw3rrgc49mqijapdwp3xsscaxb5867bz79s841"))))
+ (build-system go-build-system)
+ (arguments
+ (list
+ #:import-path "github.com/tannerryan/ring"))
+ (home-page "https://github.com/tannerryan/ring")
+ (synopsis "High performance bloom filter")
+ (description
+ "@code{ring} provides a high performance and thread safe Go implementation of a
+@url{https://en.wikipedia.org/wiki/Bloom_filter, bloom filter}.")
+ (license license:bsd-2)))
+
(define-public go-github-com-teambition-rrule-go
(package
(name "go-github-com-teambition-rrule-go")