aboutsummaryrefslogtreecommitdiff
path: root/gnu/packages
diff options
context:
space:
mode:
authorRicardo Wurmus <rekado@elephly.net>2024-07-26 07:56:45 +0200
committerLudovic Courtès <ludo@gnu.org>2024-08-31 10:45:44 +0200
commit540f1c8bfea9c6ed08c76c63ebaeb07071a96bec (patch)
treedf8fb854a80a0212bff395e90cbb39932af8aa8a /gnu/packages
parentfc91a71c779318f0e06884548f090f37d370a91b (diff)
downloadguix-540f1c8bfea9c6ed08c76c63ebaeb07071a96bec.tar
guix-540f1c8bfea9c6ed08c76c63ebaeb07071a96bec.tar.gz
gnu: inkscape: Conditionally disable precision tests.
* gnu/packages/inkscape.scm (inkscape/stable)[arguments]: Disable tests on aarch64, ppc64le, and riscv64 that fail due to precision errors. Change-Id: Ie40100ed4adc4d007211c695b34eb4d648345304
Diffstat (limited to 'gnu/packages')
-rw-r--r--gnu/packages/inkscape.scm7
1 files changed, 6 insertions, 1 deletions
diff --git a/gnu/packages/inkscape.scm b/gnu/packages/inkscape.scm
index cb32b7d38f..8d8dac4fa8 100644
--- a/gnu/packages/inkscape.scm
+++ b/gnu/packages/inkscape.scm
@@ -187,7 +187,9 @@ endif()~%~%"
(lambda _
;; https://gitlab.com/inkscape/inkscape/-/issues/3554#note_1035680690
(substitute* "testfiles/CMakeLists.txt"
- (("lpe64-test") "#lpe64-test"))
+ (("lpe64-test") "#lpe64-test")
+ ((" lpe-test") " #lpe-test")
+ (("add_subdirectory\\(lpe_tests\\)") ""))
;; https://gitlab.com/inkscape/inkscape/-/issues/3554#note_1035539888
;; According to upstream, this is a false positive.
(substitute* "testfiles/rendering_tests/CMakeLists.txt"
@@ -197,6 +199,9 @@ endif()~%~%"
;; Allegedly a precision error in the gamma.
(substitute* "testfiles/cli_tests/CMakeLists.txt"
(("add_cli_test\\(export-png-color-mode-gray-8_png" all)
+ (string-append "#" all))
+ ;; These also seem to be failing due to precision errors.
+ (("add_pdfinput_test\\(font-(spacing|style) 1 draw-all" all)
(string-append "#" all))))))
'())
(add-after 'unpack 'set-home