aboutsummaryrefslogtreecommitdiff
path: root/gnu/packages
diff options
context:
space:
mode:
authorgemmaro <gemmaro.dev@gmail.com>2024-08-30 00:14:04 +0900
committerSharlatan Hellseher <sharlatanus@gmail.com>2024-09-23 20:28:16 +0100
commit534b74932d8ca8f866de65b3d01f6dbaf9435733 (patch)
treec0ff194c5211abdf2c9133cde20c09bd4e744206 /gnu/packages
parent98aed3b9f86dc7085d7c335aceccef88a3dda6b3 (diff)
downloadguix-534b74932d8ca8f866de65b3d01f6dbaf9435733.tar
guix-534b74932d8ca8f866de65b3d01f6dbaf9435733.tar.gz
gnu: Add go-zgo-at-termtext.
* gnu/packages/golang-xyz.scm (go-zgo-at-termtext): New variable. Change-Id: I19ec0dc06dda0289cb3aaa43de025fa447da8e6c Signed-off-by: Sharlatan Hellseher <sharlatanus@gmail.com>
Diffstat (limited to 'gnu/packages')
-rw-r--r--gnu/packages/golang-xyz.scm27
1 files changed, 27 insertions, 0 deletions
diff --git a/gnu/packages/golang-xyz.scm b/gnu/packages/golang-xyz.scm
index dc131f0065..1e2a7510d2 100644
--- a/gnu/packages/golang-xyz.scm
+++ b/gnu/packages/golang-xyz.scm
@@ -7373,6 +7373,33 @@ the newest Unicode and having various helper functions removed, so all that
remains is just the @code{runewidth.RuneWidth()} function.")
(license license:expat)))
+(define-public go-zgo-at-termtext
+ (package
+ (name "go-zgo-at-termtext")
+ (version "1.5.0")
+ (source
+ (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/arp242/termtext")
+ (commit (string-append "v" version))))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32 "0czhvcx6crmwfl6555l9hgl6gq21ykwr4bg2dqksc71qmv6b27hh"))))
+ (build-system go-build-system)
+ (arguments
+ (list
+ #:import-path "zgo.at/termtext"))
+ (propagated-inputs
+ (list go-github-com-rivo-uniseg
+ go-zgo-at-runewidth))
+ (home-page "https://github.com/arp242/termtext")
+ (synopsis "Deal with monospace text as interpreted by terminals")
+ (description
+ "Package @samp{termtext} deals with monospace text as interpreted by
+terminals.")
+ (license license:expat)))
+
;;;
;;; Executables:
;;;