aboutsummaryrefslogtreecommitdiff
path: root/gnu/packages
diff options
context:
space:
mode:
authorZheng Junjie <zhengjunjie@iscas.ac.cn>2024-07-05 23:36:24 +0800
committerZheng Junjie <zhengjunjie@iscas.ac.cn>2024-07-18 10:44:59 +0800
commit52a037fdcd9f46865a9b0b6c3227c002d8944c8a (patch)
treec4590d75bbe19d7029c020da6bfbe0840d85b230 /gnu/packages
parentc77f92a69e702430fbb16684fdf38afde2301187 (diff)
downloadguix-52a037fdcd9f46865a9b0b6c3227c002d8944c8a.tar
guix-52a037fdcd9f46865a9b0b6c3227c002d8944c8a.tar.gz
gnu: phonon: Enable qt6.
* gnu/packages/kde-frameworks.scm (phonon): Enable qt6. [arguments]: Remove "-DPHONON_BUILD_QT6=OFF". <#:phases>: Remove patch-installdir phase. [inputs]: Add qtbase and qt5compat. [native-inputs]: Remove qttools-5; add qttools. Change-Id: Ie9421f5d1f8191fe1d600bc71fdb8a318fa92ca1
Diffstat (limited to 'gnu/packages')
-rw-r--r--gnu/packages/kde-frameworks.scm17
1 files changed, 3 insertions, 14 deletions
diff --git a/gnu/packages/kde-frameworks.scm b/gnu/packages/kde-frameworks.scm
index 731a293f05..18c0b8c876 100644
--- a/gnu/packages/kde-frameworks.scm
+++ b/gnu/packages/kde-frameworks.scm
@@ -225,22 +225,11 @@ continuous display of high-volume data.")
"16pk8g5rx00x45gnxrqg160b1l02fds1b7iz6shllbfczghgz1rj"))))
(build-system cmake-build-system)
(native-inputs
- ;; TODO: Add building the super experimental QML support
- (list appstream extra-cmake-modules pkg-config qttools-5))
- (inputs (list glib qtbase-5 pulseaudio))
+ (list appstream extra-cmake-modules pkg-config qttools))
+ (inputs (list qtbase qt5compat glib qtbase-5 pulseaudio))
(arguments
(list #:configure-flags
- #~'("-DCMAKE_CXX_FLAGS=-fPIC"
- "-DPHONON_BUILD_QT6=OFF") ;KDE is still using Qt 5
- #:phases
- #~(modify-phases %standard-phases
- (add-before 'install 'patch-installdir
- (lambda* (#:key inputs outputs #:allow-other-keys)
- (let ((regex (string-append "(INSTALL DESTINATION \")"
- #$(this-package-input "qtbase"))))
- (substitute* "cmake_install.cmake"
- ((regex all dest)
- (string-append dest #$output)))))))))
+ #~(list "-DCMAKE_CXX_FLAGS=-fPIC")))
(home-page "https://community.kde.org/Phonon")
(synopsis "KDE's multimedia library")
(description "KDE's multimedia library.")