aboutsummaryrefslogtreecommitdiff
path: root/gnu/packages
diff options
context:
space:
mode:
authorSharlatan Hellseher <sharlatanus@gmail.com>2024-05-22 10:02:32 +0100
committerSharlatan Hellseher <sharlatanus@gmail.com>2024-05-22 10:12:05 +0100
commit5000c417c04aec03525238e9816d1e8e6a925eb3 (patch)
treee20d0e99480e04279a736dea3a15b88d1a626907 /gnu/packages
parent50bbe668d47bec88c98ea48f0a2b00d29cee527c (diff)
downloadguix-5000c417c04aec03525238e9816d1e8e6a925eb3.tar
guix-5000c417c04aec03525238e9816d1e8e6a925eb3.tar.gz
gnu: python-pymysql: Update to 1.1.1 [fixes CVE-2024-36039].
* gnu/packages/databases.scm (python-pymysql): Update to 1.1.1. [source]: Refresh archive name as seen on <https://pypi.org/project/PyMySQL/#files>. [build-system]: Swap to pyproject-build-system. Change-Id: I20d06f6d1d252f501df001120ee44520e6e5d785
Diffstat (limited to 'gnu/packages')
-rw-r--r--gnu/packages/databases.scm8
1 files changed, 4 insertions, 4 deletions
diff --git a/gnu/packages/databases.scm b/gnu/packages/databases.scm
index f726954844..81cc161347 100644
--- a/gnu/packages/databases.scm
+++ b/gnu/packages/databases.scm
@@ -1616,14 +1616,14 @@ CSV, DB3, iXF, SQLite, MS-SQL or MySQL to PostgreSQL.")
(define-public python-pymysql
(package
(name "python-pymysql")
- (version "1.0.2")
+ (version "1.1.1")
(source
(origin
(method url-fetch)
- (uri (pypi-uri "PyMySQL" version))
+ (uri (pypi-uri "pymysql" version))
(sha256
- (base32 "0dmdszskfri11b9m6n3lag31vzi10aqxz9gc583md3gka2ijfsc1"))))
- (build-system python-build-system)
+ (base32 "1l2cj0ps96g3bblvhdszgyjv9bi405bxrx0bqq1p8h9bmwd629z1"))))
+ (build-system pyproject-build-system)
(inputs
(list python-cryptography))
(arguments