aboutsummaryrefslogtreecommitdiff
path: root/gnu/packages
diff options
context:
space:
mode:
authorTrevor Richards <trev@trevdev.ca>2022-09-19 21:38:57 -0700
committerGuillaume Le Vaillant <glv@posteo.net>2022-09-20 09:15:44 +0200
commit4248fe076e006eb493320b23b4ddb9ebca36adbd (patch)
tree7127ae784d9cec5c6183f4b682a78f6d80b65f18 /gnu/packages
parente58bafcca4f44e058c7e88de73aa6311be7a3b37 (diff)
downloadguix-4248fe076e006eb493320b23b4ddb9ebca36adbd.tar
guix-4248fe076e006eb493320b23b4ddb9ebca36adbd.tar.gz
gnu: Add sbcl-stumpwm-pamixer.
* gnu/packages/wm.scm (sbcl-stumpwm-pamixer): New variable. Signed-off-by: Guillaume Le Vaillant <glv@posteo.net>
Diffstat (limited to 'gnu/packages')
-rw-r--r--gnu/packages/wm.scm35
1 files changed, 35 insertions, 0 deletions
diff --git a/gnu/packages/wm.scm b/gnu/packages/wm.scm
index f329020eb4..09ee12c8f0 100644
--- a/gnu/packages/wm.scm
+++ b/gnu/packages/wm.scm
@@ -1987,6 +1987,41 @@ productive, customizable lisp based systems.")
(description "This package provides a StumpWM interactive shell.")
(license (list license:gpl2+ license:gpl3+ license:bsd-2))))
+(define-public sbcl-stumpwm-pamixer
+ (let ((commit "aa820533c80ea1af5a0e107cea25eaf34e69dc24")
+ (revision "1"))
+ (package
+ (name "sbcl-stumpwm-pamixer")
+ (version (git-version "0.1.1" revision commit))
+ (source (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/Junker/stumpwm-pamixer")
+ (commit commit)))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32
+ "0djcrr16bx40l7b60d4j507vk5l42fdgmjpgrnk86z1ba8wlqim8"))))
+ (inputs (list pamixer `(,stumpwm "lib")))
+ (build-system asdf-build-system/sbcl)
+ (arguments
+ (list #:asd-systems ''("pamixer")
+ #:phases
+ #~(modify-phases %standard-phases
+ (add-after 'unpack 'patch-pamixer
+ (lambda _
+ (substitute* "pamixer.lisp"
+ (("\"pamixer \"")
+ (string-append "\""
+ #$(this-package-input "pamixer")
+ "/bin/pamixer \""))))))))
+ (home-page "https://github.com/Junker/stumpwm-pamixer")
+ (synopsis "StumpWM Pamixer Module")
+ (description
+ "This package provides a minimalistic Pulseaudio volume and microphone
+control module for StumpWM.")
+ (license license:gpl3))))
+
(define-public sbcl-stumpwm+slynk
(deprecated-package "sbcl-stumpwm-with-slynk" stumpwm+slynk))