aboutsummaryrefslogtreecommitdiff
path: root/gnu/packages
diff options
context:
space:
mode:
authorHartmut Goebel <h.goebel@crazy-compilers.com>2021-08-27 15:09:14 +0200
committerHartmut Goebel <h.goebel@crazy-compilers.com>2021-09-21 21:00:27 +0200
commit402278a23402bb13241e0f1c69d3285fe4c9f046 (patch)
tree9c5f8c3f74b848c3a99c1bf67a5b65474e6b4070 /gnu/packages
parent2c4e00225b05f2e0b0b5102c3dc78a45374ca669 (diff)
downloadguix-402278a23402bb13241e0f1c69d3285fe4c9f046.tar
guix-402278a23402bb13241e0f1c69d3285fe4c9f046.tar.gz
gnu: Add trytond-attendance.
* gnu/packages/tryton.scm (trytond-attendance): New variable.
Diffstat (limited to 'gnu/packages')
-rw-r--r--gnu/packages/tryton.scm26
1 files changed, 26 insertions, 0 deletions
diff --git a/gnu/packages/tryton.scm b/gnu/packages/tryton.scm
index 3df4094492..71afda0774 100644
--- a/gnu/packages/tryton.scm
+++ b/gnu/packages/tryton.scm
@@ -1384,6 +1384,32 @@ analytic accounts on purchase line.")
analytic accounts on sale line.")
(license license:gpl3+)))
+(define-public trytond-attendance
+ (package
+ (name "trytond-attendance")
+ (version "6.0.0")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (pypi-uri "trytond_attendance" version))
+ (sha256
+ (base32 "1kwbxblpwjw9sv9axfp29vqgdkwkzf0c0vw8qx1fx8mfwv1hba5c"))))
+ (build-system python-build-system)
+ (arguments (tryton-arguments "attendance"))
+ (native-inputs
+ `(,@%standard-trytond-native-inputs
+ ("trytond-timesheet" ,trytond-timesheet)))
+ (propagated-inputs
+ `(("trytond" ,trytond)
+ ("trytond-company" ,trytond-company)))
+ (home-page "https://docs.tryton.org/projects/modules-attendance")
+ (synopsis "Tryton module for recording employee attendance")
+ (description "The @emph{Attendance} Tryton module allows you to track the
+entry and exit time of employees. The module also comes with a sheet that
+shows for each employee the total duration per day in the company and the
+detail of the time of entrance and exit")
+ (license license:gpl3+)))
+
(define-public trytond-company
(package
(name "trytond-company")