aboutsummaryrefslogtreecommitdiff
path: root/gnu/packages
diff options
context:
space:
mode:
authorAndreas Enge <andreas@enge.fr>2024-10-28 11:54:33 +0100
committerAndreas Enge <andreas@enge.fr>2024-10-28 11:54:33 +0100
commit4009d1de954d694cb11af391d4113d29c5c1379d (patch)
tree9c5eeda013b3d67c72add65c6cc3ef80e17f82ff /gnu/packages
parent351fdf69f737d09d24499d6c1ff70a2325fff0fa (diff)
downloadguix-4009d1de954d694cb11af391d4113d29c5c1379d.tar
guix-4009d1de954d694cb11af391d4113d29c5c1379d.tar.gz
gnu: owl: Correct package.
This is a follow-up to commit 3566cabecc0337f64b8a3e2ef276a93d99f440c7 which contains a preliminary version of the commit. * gnu/packages/scheme.scm (owl): Improve some fields. [native-inputs]: Drop pandoc. Change-Id: Iba99892b58ffa1c5267e3f7d80912fb1a964e2ed
Diffstat (limited to 'gnu/packages')
-rw-r--r--gnu/packages/scheme.scm23
1 files changed, 10 insertions, 13 deletions
diff --git a/gnu/packages/scheme.scm b/gnu/packages/scheme.scm
index c38d4256af..490a09aa1c 100644
--- a/gnu/packages/scheme.scm
+++ b/gnu/packages/scheme.scm
@@ -1289,24 +1289,21 @@ Gerbil code within Emacs.")))
(build-system gnu-build-system)
(arguments
(list
+ #:make-flags #~(list (string-append "CC=" #$(cc-for-target))
+ (string-append "PREFIX=" #$output))
#:make-flags #~`(,(string-append "PREFIX=" #$output))
#:phases #~(modify-phases %standard-phases
- (delete 'configure)
+ (delete 'configure) ; no configure script
(add-after 'patch-source-shebangs 'patch-ol-shebangs
(lambda _
- (map (lambda (f)
- (substitute* f
- (("/usr") #$output)))
- (list "bin/feather"
- "tests/hashbang.scm"
- "tests/theorem-rand.scm")))))
+ (lambda _
+ (substitute* (list "bin/feather"
+ "tests/hashbang.scm"
+ "tests/theorem-rand.scm")
+ (("/usr") #$output))))))
#:test-target "test"))
- (native-inputs
- (append (if (supported-package? pandoc)
- (list pandoc)
- '())
- (list which)))
- (home-page "https://haltp.org/owl")
+ (native-inputs (list which))
+ (home-page "https://haltp.org/posts/owl.html")
(synopsis "Functional Scheme dialect")
(description
"Owl Lisp is a simple programming language. It is intended to provide a