aboutsummaryrefslogtreecommitdiff
path: root/gnu/packages
diff options
context:
space:
mode:
authorNicolas Goaziou <mail@nicolasgoaziou.fr>2023-05-14 11:11:24 +0200
committerNicolas Goaziou <mail@nicolasgoaziou.fr>2023-07-18 18:10:59 +0200
commit3c3bb270da36e495c8d3b7e672b330aa1810a485 (patch)
treea843093a628ae0bcf1b9f819fe4fc8831c67f718 /gnu/packages
parent89b54d1ea8f56bed39fe4d2480825d01da8efcde (diff)
downloadguix-3c3bb270da36e495c8d3b7e672b330aa1810a485.tar
guix-3c3bb270da36e495c8d3b7e672b330aa1810a485.tar.gz
gnu: texlive-latex-varwidth -> texlive-varwidth.
* gnu/packages/tex.scm (texlive-varwidth): New variable. (texlive-latex-varwidth): Deprecate variable. (texlive-adjustbox): Use new name. * gnu/packages/maths.scm (hypre)[native-inputs]: Use new name. Re-order alphabetically. * gnu/packages/sphinx.scm (python-sphinx)[propagated-inputs]: Use new name. Re-order alphabetically.
Diffstat (limited to 'gnu/packages')
-rw-r--r--gnu/packages/maths.scm28
-rw-r--r--gnu/packages/sphinx.scm16
-rw-r--r--gnu/packages/tex.scm65
3 files changed, 42 insertions, 67 deletions
diff --git a/gnu/packages/maths.scm b/gnu/packages/maths.scm
index a61d790de0..a6a015eca0 100644
--- a/gnu/packages/maths.scm
+++ b/gnu/packages/maths.scm
@@ -5784,42 +5784,42 @@ set.")
texlive-capt-of
texlive-caption
texlive-cm
+ texlive-cmap
+ texlive-colortbl
texlive-courier
texlive-enumitem
texlive-etoc
texlive-etoolbox
texlive-fancyhdr
texlive-fancyvrb
- texlive-helvetic
- texlive-jknappen
- texlive-sectsty
- texlive-tex-gyre
- texlive-wasy
- texlive-xcolor
- texlive-xypic
- texlive-listofitems
- texlive-cmap
- texlive-colortbl
texlive-float
texlive-fncychap
texlive-framed
texlive-geometry
texlive-hanging
+ texlive-helvetic
texlive-hyperref
+ texlive-jknappen
+ texlive-listofitems
texlive-multirow
texlive-natbib
texlive-latex-needspace
texlive-newunicodechar
texlive-parskip
+ texlive-sectsty
texlive-stackengine
texlive-tabulary
- texlive-tocloft
- texlive-upquote
- texlive-latex-varwidth
+ texlive-tex-gyre
texlive-titlesec
+ texlive-tocloft
texlive-ulem
+ texlive-upquote
+ texlive-varwidth
+ texlive-wasy
texlive-wasysym
- texlive-wrapfig))))
+ texlive-wrapfig
+ texlive-xcolor
+ texlive-xypic))))
(inputs
(list openblas lapack))
(arguments
diff --git a/gnu/packages/sphinx.scm b/gnu/packages/sphinx.scm
index 69054efb50..c2d744ed00 100644
--- a/gnu/packages/sphinx.scm
+++ b/gnu/packages/sphinx.scm
@@ -109,28 +109,28 @@
texlive-amsmath
texlive-capt-of
texlive-carlisle ;remreset
- texlive-etoolbox
- texlive-ltxcmds
- texlive-hyperref
- texlive-latex-base ;alltt, atbegshi, makeidx, textcomp
texlive-cmap
+ texlive-etoolbox
texlive-fancyhdr
texlive-fancyvrb
texlive-float
texlive-fncychap
texlive-framed
texlive-geometry
- texlive-graphics ;graphicx, color
+ texlive-graphics ;graphicx, color
+ texlive-hyperref
texlive-kvoptions
+ texlive-latex-base ;alltt, atbegshi, makeidx, textcomp
+ texlive-ltxcmds
texlive-latex-needspace
+ texlive-oberdiek ;hypcap
texlive-parskip
texlive-latex-preview
texlive-tabulary
texlive-titlesec
- texlive-tools ;multicol, longtable
+ texlive-tools ;multicol, longtable
texlive-upquote
- texlive-latex-varwidth
- texlive-oberdiek ;hypcap
+ texlive-varwidth
texlive-wrapfig
texlive-xcolor))
(native-inputs
diff --git a/gnu/packages/tex.scm b/gnu/packages/tex.scm
index e445a93ea5..fe955867d2 100644
--- a/gnu/packages/tex.scm
+++ b/gnu/packages/tex.scm
@@ -5757,7 +5757,7 @@ user may consider the @code{dnaseq} as a rather more powerful alternative.")
texlive-graphics
texlive-listings
texlive-refcount
- texlive-latex-varwidth))
+ texlive-varwidth))
(home-page "https://ctan.org/pkg/showexpl")
(synopsis "Typesetting LaTeX source code")
(description
@@ -8289,54 +8289,29 @@ Association for Computing Machinery (ACM).")
(define-deprecated-package texlive-latex-acmart texlive-acmart)
-(define-public texlive-latex-varwidth
+(define-public texlive-varwidth
(package
- (name "texlive-latex-varwidth")
+ (name "texlive-varwidth")
(version (number->string %texlive-revision))
- (source (origin
- (method svn-fetch)
- (uri (svn-reference
- (url (string-append "svn://www.tug.org/texlive/tags/"
- %texlive-tag "/Master/texmf-dist/"
- "/tex/latex/varwidth"))
- (revision %texlive-revision)))
- (file-name (string-append name "-" version "-checkout"))
- (sha256
- (base32
- "1bmz9ap0ffyg7qry2xi7lki06qx4809w028xvk88cl66h7p46g52"))))
- (build-system trivial-build-system)
- (arguments
- `(#:modules ((guix build utils))
- #:builder
- (begin
- (use-modules (guix build utils))
- (let ((target (string-append (assoc-ref %outputs "out")
- "/share/texmf-dist/tex/latex/varwidth")))
- (mkdir-p target)
- (copy-recursively (assoc-ref %build-inputs "source") target)
- #t))))
- (home-page "https://www.ctan.org/pkg/varwidth")
- (synopsis "Variable-width minipage")
+ (source (texlive-origin
+ name version
+ (list "doc/latex/varwidth/" "tex/latex/varwidth/")
+ (base32
+ "0jcrv4klcjpl17ml0zyqfvkrq6qwn2imxv8syqs5m6qk0fk7hg6l")))
+ (outputs '("out" "doc"))
+ (build-system texlive-build-system)
+ (propagated-inputs
+ (list texlive-bookmark
+ texlive-hyperref))
+ (home-page "https://ctan.org/pkg/varwidth")
+ (synopsis "Variable-width @code{minipage}")
(description
- "The @code{varwidth} environment is superficially similar to
-@code{minipage}, but the specified width is just a maximum value — the box may
-get a narrower “natural” width.")
+ "The @code{varwidth} environment is superficially similar to @code{minipage},
+but the specified width is just a maximum value -- the box may get a narrower
+natural width.")
(license license:lppl)))
-(define-public texlive-varwidth
- (package
- (inherit (simple-texlive-package
- "texlive-varwidth"
- (list "doc/latex/varwidth/" "tex/latex/varwidth/")
- (base32 "0jcrv4klcjpl17ml0zyqfvkrq6qwn2imxv8syqs5m6qk0fk7hg6l")
- #:trivial? #t))
- (home-page "https://ctan.org/macros/latex/contrib/varwidth")
- (synopsis "Variable-width minipage LaTeX environment")
- (description
- "The varwidth environment is superficially similar to minipage, but the
-specified width is just a maximum value --- the box may get a narrower natural
-width.")
- (license license:lppl)))
+(define-deprecated-package texlive-latex-varwidth texlive-varwidth)
(define-public texlive-wasy
(package
@@ -11481,7 +11456,7 @@ the list of graphics file extensions recognised by package graphics.")
texlive-ifoddpage
texlive-pgf
texlive-storebox
- texlive-latex-varwidth
+ texlive-varwidth
texlive-xkeyval))
(home-page "https://www.ctan.org/pkg/adjustbox")
(synopsis "Graphics package-alike macros for “general” boxes")