aboutsummaryrefslogtreecommitdiff
path: root/gnu/packages
diff options
context:
space:
mode:
authorTobias Geerinckx-Rice <me@tobias.gr>2024-07-07 02:00:00 +0200
committerTobias Geerinckx-Rice <me@tobias.gr>2024-07-07 02:00:00 +0200
commit3b5533f9bdac4a929c3d93e628ee2ae279013685 (patch)
tree59018052ac71efcc6ec7c7dea29ccef4b7268f43 /gnu/packages
parentf40234e225dcb6bfc51c05cf51fd01841e0f5dbd (diff)
downloadguix-3b5533f9bdac4a929c3d93e628ee2ae279013685.tar
guix-3b5533f9bdac4a929c3d93e628ee2ae279013685.tar.gz
gnu: znc: Hash passwords with Argon2id.
* gnu/packages/messaging.scm (znc)[inputs]: Add argon2. Change-Id: Iee64e2b6efb2f2e33fba2c641e8ef22e5785ecde
Diffstat (limited to 'gnu/packages')
-rw-r--r--gnu/packages/messaging.scm4
1 files changed, 3 insertions, 1 deletions
diff --git a/gnu/packages/messaging.scm b/gnu/packages/messaging.scm
index 04200933ab..0278653faf 100644
--- a/gnu/packages/messaging.scm
+++ b/gnu/packages/messaging.scm
@@ -117,6 +117,7 @@
#:use-module (gnu packages ncurses)
#:use-module (gnu packages networking)
#:use-module (gnu packages nss)
+ #:use-module (gnu packages password-utils)
#:use-module (gnu packages pcre)
#:use-module (gnu packages perl)
#:use-module (gnu packages photo)
@@ -1122,7 +1123,8 @@ control of your private keys, no previous conversation is compromised.")
("pkg-config" ,pkg-config)))
(inputs
;; FIXME: Package cctz and remove the bundled copy from the source tarball.
- (list cyrus-sasl
+ (list argon2
+ cyrus-sasl
icu4c
openssl
perl