aboutsummaryrefslogtreecommitdiff
path: root/gnu/packages
diff options
context:
space:
mode:
authorSharlatan Hellseher <sharlatanus@gmail.com>2024-10-02 11:31:49 +0100
committerSharlatan Hellseher <sharlatanus@gmail.com>2024-10-30 19:32:18 +0000
commit393be171becb8cb26aac0189e00e36e0c202fb2b (patch)
tree85d8d3d97c8c83e9cd9e6894bfd9200dcf6c6ea1 /gnu/packages
parentdebee8afe9be2bb22b5c46db19939abd95c50ef1 (diff)
downloadguix-393be171becb8cb26aac0189e00e36e0c202fb2b.tar
guix-393be171becb8cb26aac0189e00e36e0c202fb2b.tar.gz
gnu: Add python-coolest.
* gnu/packages/astronomy.scm (python-coolest): New variable. Change-Id: I464c17087c17dd76bac759c0aafe1d5c2f247cff
Diffstat (limited to 'gnu/packages')
-rw-r--r--gnu/packages/astronomy.scm41
1 files changed, 41 insertions, 0 deletions
diff --git a/gnu/packages/astronomy.scm b/gnu/packages/astronomy.scm
index 4621ab33ac..a9c0cc7186 100644
--- a/gnu/packages/astronomy.scm
+++ b/gnu/packages/astronomy.scm
@@ -1647,6 +1647,47 @@ simulated Astronomical data in Python.")
mining in astronomy.")
(license license:bsd-2)))
+(define-public python-coolest
+ (package
+ (name "python-coolest")
+ (version "0.1.9")
+ (source
+ (origin
+ (method git-fetch) ; no tests in the PyPI tarball
+ (uri (git-reference
+ (url "https://github.com/aymgal/COOLEST")
+ (commit (string-append "v" version))))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32 "0mfkgfp6f0ay6kndh7vk8l0g2ijr32k55x3pmj15lp9kd8k3ln4r"))))
+ (build-system pyproject-build-system)
+ (arguments
+ (list
+ #:test-flags
+ ;; Cycle with python-lenstronomy.
+ #~(list "--ignore=test/api/profiles/light_test.py"
+ "--ignore=test/api/profiles/mass_test.py")))
+ (native-inputs
+ (list python-pytest
+ python-scikit-image))
+ (propagated-inputs
+ (list python-astropy
+ python-getdist
+ python-jsonpickle
+ python-numpy
+ python-pandas
+ python-scipy))
+ (home-page "https://github.com/aymgal/COOLEST")
+ (synopsis "Strong Gravitational Lensing Analyses")
+ (description
+ "The COde-independent Organized LEns STandard (COOLEST) defines a set of
+conventions to be shared across the strong lensing community, in order to
+consistently store, share and improve lens modeling analyses. In short, this
+project provides tools to manipulate lens models as a single, human-readable
+JSON template file alongside Python routines for visualizing and comparing
+lens models possibly obtained from different modeling codes.")
+ (license license:gpl3)))
+
(define-public python-extinction
(package
(name "python-extinction")