aboutsummaryrefslogtreecommitdiff
path: root/gnu/packages
diff options
context:
space:
mode:
authorSharlatan Hellseher <sharlatanus@gmail.com>2024-07-28 22:40:03 +0100
committerSharlatan Hellseher <sharlatanus@gmail.com>2024-07-28 22:40:03 +0100
commit35438093a48b2cc1ce600f5a24b38ca1363df29e (patch)
tree332caad6b3b78c7ccdaa850a36d40eea58d69409 /gnu/packages
parentb09861ec7c249ad30b7aec9ef4407439040dabfa (diff)
downloadguix-35438093a48b2cc1ce600f5a24b38ca1363df29e.tar
guix-35438093a48b2cc1ce600f5a24b38ca1363df29e.tar.gz
gnu: go-github-com-emersion-go-msgauth: Move to golang-web.
* gnu/packages/golang.scm (go-github-com-emersion-go-msgauth): Move from here ... * gnu/packages/golang-web.scm: ... to here. Change-Id: Iec9f8d3f488668c188a96dae53046ad0075781ff
Diffstat (limited to 'gnu/packages')
-rw-r--r--gnu/packages/golang-web.scm32
-rw-r--r--gnu/packages/golang.scm30
2 files changed, 32 insertions, 30 deletions
diff --git a/gnu/packages/golang-web.scm b/gnu/packages/golang-web.scm
index f65629c8b6..02c1262b0d 100644
--- a/gnu/packages/golang-web.scm
+++ b/gnu/packages/golang-web.scm
@@ -897,6 +897,38 @@ Multipurpose Internet Mail Extensions in Go.")
for Go.")
(license license:bsd-2)))
+(define-public go-github-com-emersion-go-msgauth
+ (package
+ (name "go-github-com-emersion-go-msgauth")
+ (version "0.6.8")
+ (source
+ (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/emersion/go-msgauth")
+ (commit (string-append "v" version))))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32 "0az83i6jmk3bjglgdqw5zsvhh8698rav0mcg4dy8kr0cgq0lj5zs"))))
+ (build-system go-build-system)
+ (arguments
+ (list
+ #:import-path "github.com/emersion/go-msgauth"
+ #:tests? #f ; Source-only package.
+ #:phases
+ #~(modify-phases %standard-phases
+ ;; Source-only package.
+ (delete 'build))))
+ (propagated-inputs
+ (list go-golang-org-x-crypto
+ go-github-com-emersion-go-milter
+ go-github-com-emersion-go-message))
+ (home-page "https://github.com/emersion/go-msgauth")
+ (synopsis "Email authentication for Go")
+ (description
+ "This package provides a Go library for authenticating emails.")
+ (license license:expat)))
+
(define-public go-github-com-emicklei-go-restful
(package
(name "go-github-com-emicklei-go-restful")
diff --git a/gnu/packages/golang.scm b/gnu/packages/golang.scm
index b437ab994c..4d99ca56f0 100644
--- a/gnu/packages/golang.scm
+++ b/gnu/packages/golang.scm
@@ -5643,36 +5643,6 @@ defined by RFC 5321.")
(description "This package provides a SASL library written in Go.")
(license license:expat))))
-(define-public go-github-com-emersion-go-msgauth
- (package
- (name "go-github-com-emersion-go-msgauth")
- (version "0.6.8")
- (source (origin
- (method git-fetch)
- (uri (git-reference
- (url "https://github.com/emersion/go-msgauth")
- (commit (string-append "v" version))))
- (file-name (git-file-name name version))
- (sha256
- (base32
- "0az83i6jmk3bjglgdqw5zsvhh8698rav0mcg4dy8kr0cgq0lj5zs"))))
- (build-system go-build-system)
- (arguments
- (list #:import-path "github.com/emersion/go-msgauth"
- #:tests? #f ; Source-only package.
- #:phases
- #~(modify-phases %standard-phases
- ;; Source-only package.
- (delete 'build))))
- (propagated-inputs (list go-golang-org-x-crypto
- go-github-com-emersion-go-milter
- go-github-com-emersion-go-message))
- (home-page "https://github.com/emersion/go-msgauth")
- (synopsis "Email authentication for Go")
- (description
- "This package provides a Go library for authenticating emails.")
- (license license:expat)))
-
(define-public go-github-com-google-uuid
(package
(name "go-github-com-google-uuid")