aboutsummaryrefslogtreecommitdiff
path: root/gnu/packages
diff options
context:
space:
mode:
authorLudovic Courtès <ludovic.courtes@inria.fr>2024-10-15 11:24:08 +0200
committerLudovic Courtès <ludo@gnu.org>2024-10-25 11:55:35 +0200
commit30e469cc9cffcb6541205392ebbc121465b72416 (patch)
treeb03c1c50f9bd9d3c0fa0e089ce47d6dfe18c0c88 /gnu/packages
parent2394a7f5fbf60dd6adc0a870366adb57166b6d8b (diff)
downloadguix-30e469cc9cffcb6541205392ebbc121465b72416.tar
guix-30e469cc9cffcb6541205392ebbc121465b72416.tar.gz
gnu: openmpi@5: Remove reference to GCC and other build tools.
This removes GCC from the direct references of openmpi@5. * gnu/packages/mpi.scm (openmpi-5)[arguments]: Replace arguments entirely instead of using ‘substitute-keyword-arguments’. Reintroduce ‘remove-absolute’ phase. Remove ‘find-opensm-headers’ and ‘remove-logs’ phases, which are no longer needed. Change-Id: Ia3b25230488ca13310cd5bb2ae45f6990e906fa5
Diffstat (limited to 'gnu/packages')
-rw-r--r--gnu/packages/mpi.scm71
1 files changed, 40 insertions, 31 deletions
diff --git a/gnu/packages/mpi.scm b/gnu/packages/mpi.scm
index 5cf9485b5e..bc1fd797d6 100644
--- a/gnu/packages/mpi.scm
+++ b/gnu/packages/mpi.scm
@@ -339,37 +339,46 @@ software vendors, application developers and computer science researchers.")
(outputs '("out" "debug"))
(arguments
- (substitute-keyword-arguments (package-arguments openmpi)
- ((#:configure-flags _)
- #~(list "--enable-mpi-ext=affinity" ;cr doesn't work
- "--with-sge"
-
- #$@(if (package? (this-package-input "valgrind"))
- #~("--enable-memchecker"
- "--with-valgrind")
- #~("--without-valgrind"))
-
- "--with-hwloc=external"
- "--with-libevent"
-
- ;; This replaces --enable-mpirun-prefix-by-default wich is deprecated
- ;; since 5.x.
- "--enable-prte-prefix-by-default"
-
- ;; Enable support for the 'Process Management Interface for Exascale'
- ;; (PMIx) used e.g. by Slurm for the management communication and
- ;; coordination of MPI processes.
- (string-append "--with-pmix=" #$(this-package-input "openpmix"))
- (string-append "--with-prrte=" #$(this-package-input "prrte"))
-
- ;; Since 5.x, Infiniband support is provided by ucx.
- ;; See https://docs.open-mpi.org/en/main/release-notes/networks.html#miscellaneous-network-notes
- (string-append "--with-ucx=" #$(this-package-input "ucx"))))
-
- ((#:phases phases)
- #~(modify-phases #$phases
- (delete 'remove-absolute)
- (delete 'scrub-timestamps)))))))
+ (list #:configure-flags
+ #~(list "--enable-mpi-ext=affinity" ;cr doesn't work
+ "--with-sge"
+
+ #$@(if (package? (this-package-input "valgrind"))
+ #~("--enable-memchecker"
+ "--with-valgrind")
+ #~("--without-valgrind"))
+
+ "--with-hwloc=external"
+ "--with-libevent"
+
+ ;; This replaces --enable-mpirun-prefix-by-default wich is deprecated
+ ;; since 5.x.
+ "--enable-prte-prefix-by-default"
+
+ ;; Enable support for the 'Process Management Interface for Exascale'
+ ;; (PMIx) used e.g. by Slurm for the management communication and
+ ;; coordination of MPI processes.
+ (string-append "--with-pmix=" #$(this-package-input "openpmix"))
+ (string-append "--with-prrte=" #$(this-package-input "prrte"))
+
+ ;; Since 5.x, Infiniband support is provided by ucx.
+ ;; See https://docs.open-mpi.org/en/main/release-notes/networks.html#miscellaneous-network-notes
+ (string-append "--with-ucx=" #$(this-package-input "ucx")))
+
+ #:phases
+ #~(modify-phases %standard-phases
+ (add-before 'build 'remove-absolute
+ (lambda _
+ ;; Remove compiler absolute file names (OPAL_FC_ABSOLUTE
+ ;; etc.) to reduce the closure size. See
+ ;; <https://lists.gnu.org/archive/html/guix-devel/2017-07/msg00388.html>
+ ;; and
+ ;; <https://www.mail-archive.com/users@lists.open-mpi.org//msg31397.html>.
+ (substitute* '("oshmem/tools/oshmem_info/param.c"
+ "ompi/tools/ompi_info/param.c")
+ (("_ABSOLUTE") "")))))
+
+ #:disallowed-references (list (canonical-package gcc))))))
(define-public openmpi-c++
(package/inherit openmpi