aboutsummaryrefslogtreecommitdiff
path: root/gnu/packages
diff options
context:
space:
mode:
authorLuis Guilherme Coelho <lgcoelho@disroot.org>2023-12-27 17:14:43 +0000
committerSharlatan Hellseher <sharlatanus@gmail.com>2024-11-03 23:33:38 +0000
commit2ef5e0cd8900898cef055a49d659870be977ff07 (patch)
tree9db32d1b8295fb2e188d318664e817922ab29aa5 /gnu/packages
parent4e6df8040e539e4635420eef1a2a26af209b614d (diff)
downloadguix-2ef5e0cd8900898cef055a49d659870be977ff07.tar
guix-2ef5e0cd8900898cef055a49d659870be977ff07.tar.gz
gnu: Add newsraft.
* gnu/packages/syndication.scm (newsraft): New variable. Change-Id: Iea8d28df6f41d668818fded83a9ca77b77291484 Co-authored-by: Sharlatan Hellseher <sharlatanus@gmail.com> Signed-off-by: Sharlatan Hellseher <sharlatanus@gmail.com>
Diffstat (limited to 'gnu/packages')
-rw-r--r--gnu/packages/syndication.scm50
1 files changed, 50 insertions, 0 deletions
diff --git a/gnu/packages/syndication.scm b/gnu/packages/syndication.scm
index ed284be26b..b058469f8e 100644
--- a/gnu/packages/syndication.scm
+++ b/gnu/packages/syndication.scm
@@ -6,6 +6,7 @@
;;; Copyright © 2022 Luis Felipe López Acevedo <luis.felipe.la@protonmail.com>
;;; Copyright © 2022 Liliana Marie Prikler <liliana.prikler@gmail.com>
;;; Copyright © 2023 Maxim Cournoyer <maxim.cournoyer@gmail.com>
+;;; Copyright © 2024 Luis Guilherme Coelho <lgcoelho@disroot.org>
;;;
;;; This file is part of GNU Guix.
;;;
@@ -51,6 +52,7 @@
#:use-module (gnu packages gstreamer)
#:use-module (gnu packages gtk)
#:use-module (gnu packages kde-frameworks)
+ #:use-module (gnu packages man)
#:use-module (gnu packages ncurses)
#:use-module (gnu packages pkg-config)
#:use-module (gnu packages pretty-print)
@@ -337,6 +339,54 @@ file system, and many more features.")
(license (list license:gpl2+ ; filter/*
license:expat)))) ; everything else
+(define-public newsraft
+ (package
+ (name "newsraft")
+ (version "0.27")
+ (source
+ (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://codeberg.org/newsraft/newsraft")
+ (commit (string-append name "-" version))))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32 "170dwv6v9755mdy4w91r4mk6r5d713rxi71hppqws3bsh2g4bmrj"))))
+ (build-system gnu-build-system)
+ (arguments
+ (list
+ #:make-flags
+ #~(list (string-append "CC=" #$(cc-for-target))
+ (string-append "PREFIX=" #$output)
+ "CFLAGS=-DCURL_WRITEFUNC_ERROR=0xFFFFFFFF")
+ #:phases
+ #~(modify-phases %standard-phases
+ (delete 'configure)))) ; no configure
+ (native-inputs
+ (list pkg-config scdoc))
+ (inputs
+ (list curl expat gumbo-parser ncurses sqlite yajl))
+ (home-page "https://codeberg.org/grisha/newsraft")
+ (synopsis "Feed reader for termnial")
+ (description
+ "Newsraft is a feed reader with ncurses user interface. It is greatly
+inspired by Newsboat and tries to be its lightweight counterpart.
+
+Features:
+@itemize
+@item parallel downloads
+@item section-based feeds grouping
+@item opening links in any program
+@item viewing news from all feeds with explore mode
+@item automatic updates for feeds and sections
+@item per-feed settings and key bindings
+@item assigning multiple actions to key bindings
+@item processing feeds from command output
+@item text searching by news titles and content
+@item interactive news content viewing
+@end itemize")
+ (license license:isc)))
+
(define-public liferea
(package
(name "liferea")