aboutsummaryrefslogtreecommitdiff
path: root/gnu/packages
diff options
context:
space:
mode:
authorThanos Apollo <public@thanosapollo.org>2024-08-17 01:21:10 +0300
committerNicolas Goaziou <mail@nicolasgoaziou.fr>2024-08-21 10:26:09 +0200
commit2db3b5d6b86f86c9c4486af7ddba39167aa5c073 (patch)
treef817b887c589d19a4ce636c4c9408f6cd828f88e /gnu/packages
parent04b6450c883171fdd7e9e2b984b02edf68b65d8f (diff)
downloadguix-2db3b5d6b86f86c9c4486af7ddba39167aa5c073.tar
guix-2db3b5d6b86f86c9c4486af7ddba39167aa5c073.tar.gz
gnu: hunspell: Add Greek dictionary.
* gnu/packages/hunspell.scm (hunspell-dict-el): New variable. Change-Id: I5b534862030a60e09f2c4a741a723fc2467b20ba Signed-off-by: Nicolas Goaziou <mail@nicolasgoaziou.fr>
Diffstat (limited to 'gnu/packages')
-rw-r--r--gnu/packages/hunspell.scm35
1 files changed, 35 insertions, 0 deletions
diff --git a/gnu/packages/hunspell.scm b/gnu/packages/hunspell.scm
index 4e043f5073..e228a844bf 100644
--- a/gnu/packages/hunspell.scm
+++ b/gnu/packages/hunspell.scm
@@ -266,6 +266,41 @@ spell-checking library.")
(home-page "https://magyarispell.sourceforge.net/")
(license (list license:gpl2 license:gpl3)))))
+(define-public hunspell-dict-el
+ (let ((commit "8e799911aede4e2c340d1b5a67a07f8e22ab9c8e"))
+ (package
+ (name "hunspell-dict-el")
+ (version "0.1")
+ (source
+ (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://git.thanosapollo.org/hunspell-dict-el")
+ (commit commit)))
+ (sha256
+ (base32 "0z9nyfy50c0bjvvm42xwd3npjpp07a9slm3gfgvxanyqm7djrmb1"))))
+ (build-system gnu-build-system)
+ (arguments
+ `(#:phases
+ (modify-phases %standard-phases
+ (delete 'build)
+ (delete 'configure)
+ (replace 'install
+ (lambda* (#:key outputs #:allow-other-keys)
+ (let* ((out (assoc-ref outputs "out"))
+ (share (string-append out "/share/hunspell/")))
+ (install-file "el_GR.aff" share)
+ (install-file "el_GR.dic" share)
+ #t))))
+ #:tests? #f))
+ (native-inputs
+ (list hunspell ispell perl))
+ (synopsis "Hunspell Greek/Hellenic dictionary")
+ (description "This package provides a dictionary for the Hunspell
+spell-checking library.")
+ (home-page "https://git.thanosapollo.org/hunspell-dict-el/")
+ (license (list license:gpl2 license:gpl3)))))
+
(define* (hunspell-dictionary dict-name full-name #:key synopsis home-page license)
(package
(name (string-append