aboutsummaryrefslogtreecommitdiff
path: root/gnu/packages
diff options
context:
space:
mode:
authorSharlatan Hellseher <sharlatanus@gmail.com>2024-07-21 11:26:47 +0100
committerSharlatan Hellseher <sharlatanus@gmail.com>2024-07-25 21:01:00 +0100
commit294d3fde530b96a3871fa6b7a6821f09d9798010 (patch)
tree7f1f946d3943de605cfcd2bae87a55b930e7fd53 /gnu/packages
parentacdc473e0fb2a1c849328f7f69a56823cc0a0056 (diff)
downloadguix-294d3fde530b96a3871fa6b7a6821f09d9798010.tar
guix-294d3fde530b96a3871fa6b7a6821f09d9798010.tar.gz
gnu: go-github-com-burntsushi-toml: Enable all tests.
* gnu/packages/golang-xyz.scm (go-github-com-burntsushi-toml) [arguments]: <#:phases>: Use custom 'check phase. Change-Id: Ie0b76af157c7b8b7ddd18c934e79f895712cb365
Diffstat (limited to 'gnu/packages')
-rw-r--r--gnu/packages/golang-xyz.scm11
1 files changed, 10 insertions, 1 deletions
diff --git a/gnu/packages/golang-xyz.scm b/gnu/packages/golang-xyz.scm
index bbcc3583a5..320b44565b 100644
--- a/gnu/packages/golang-xyz.scm
+++ b/gnu/packages/golang-xyz.scm
@@ -1062,7 +1062,16 @@ indicator to any terminal application.")
(base32 "1vk0s7pcn80hkx0lcyws509gqs42c8y1rppv05zxiqj0yn2zrjnx"))))
(build-system go-build-system)
(arguments
- '(#:import-path "github.com/BurntSushi/toml"))
+ (list
+ #:import-path "github.com/BurntSushi/toml"
+ #:phases
+ #~(modify-phases %standard-phases
+ ;; XXX: Replace when go-build-system supports nested path.
+ (replace 'check
+ (lambda* (#:key import-path tests? #:allow-other-keys)
+ (when tests?
+ (with-directory-excursion (string-append "src/" import-path)
+ (invoke "go" "test" "-v" "./..."))))))))
(home-page "https://github.com/BurntSushi/toml")
(synopsis "Toml parser and encoder for Go")
(description