aboutsummaryrefslogtreecommitdiff
path: root/gnu/packages
diff options
context:
space:
mode:
authorSharlatan Hellseher <sharlatanus@gmail.com>2024-08-14 23:21:05 +0100
committerSharlatan Hellseher <sharlatanus@gmail.com>2024-08-14 23:34:41 +0100
commit2444a52d7ca62bf3abff3090ec912b159c18467a (patch)
tree7394ed23ba960a36828cf8e6fa07b38d320be938 /gnu/packages
parent662b7604b437355df51a505606804c1daa67efbf (diff)
downloadguix-2444a52d7ca62bf3abff3090ec912b159c18467a.tar
guix-2444a52d7ca62bf3abff3090ec912b159c18467a.tar.gz
gnu: go-github-com-go-playground-locales: Move to golang-xyz.
* gnu/packages/golang.scm (go-github-com-go-playground-locales): Move from here ... * gnu/packages/golang-xyz.scm: ... to here. Change-Id: I96ba608d2463911c184cedc9cfc7cb7556b1bbd9
Diffstat (limited to 'gnu/packages')
-rw-r--r--gnu/packages/golang-xyz.scm36
-rw-r--r--gnu/packages/golang.scm36
2 files changed, 36 insertions, 36 deletions
diff --git a/gnu/packages/golang-xyz.scm b/gnu/packages/golang-xyz.scm
index e1aeacd67c..5dae9d0d92 100644
--- a/gnu/packages/golang-xyz.scm
+++ b/gnu/packages/golang-xyz.scm
@@ -2458,6 +2458,42 @@ interfaces to back that API. Packages in the Go ecosystem can depend on it,
while callers can implement logging with whatever backend is appropriate.")
(license license:asl2.0)))
+(define-public go-github-com-go-playground-locales
+ (package
+ (name "go-github-com-go-playground-locales")
+ (version "0.14.1")
+ (home-page "https://github.com/go-playground/locales")
+ (source
+ (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url home-page)
+ (commit (string-append "v" version))))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32 "117nss5gv7rfzr7z40rkpwfr273wv6ahrd3ycqdarxvaxh0ldhh4"))))
+ (build-system go-build-system)
+ (arguments
+ (list #:import-path "github.com/go-playground/locales"))
+ (propagated-inputs
+ (list go-golang-org-x-text))
+ (synopsis "Set of locales generated from the CLDR Unicode Project")
+ (description
+ "This package provides a set of locales generated from the
+@uref{http://cldr.unicode.org/, Unicode CLDR Project} which can be used
+independently or within an internalization (i18n) package. Its currently
+implemented features include
+
+@itemize
+@item Rules generated from the CLDR data, v31.0.3
+@item Contains Cardinal, Ordinal and Range Plural Rules
+@item Contains Month, Weekday and Timezone translations built in
+@item Contains Date & Time formatting functions
+@item Contains Number, Currency, Accounting and Percent formatting functions
+@item Supports the \"Gregorian\" calendar only
+@end itemize")
+ (license license:expat)))
+
(define-public go-github-com-go-task-slim-sprig
(let ((commit "afa1e2071829e4db655eb448d6c7c16eb0bc5766")
(revision "0"))
diff --git a/gnu/packages/golang.scm b/gnu/packages/golang.scm
index c11b282875..a923fe6612 100644
--- a/gnu/packages/golang.scm
+++ b/gnu/packages/golang.scm
@@ -2713,42 +2713,6 @@ way of specifying command line options.")
(home-page "https://github.com/jessevdk/go-flags")
(license license:bsd-3)))
-(define-public go-github-com-go-playground-locales
- (package
- (name "go-github-com-go-playground-locales")
- (version "0.14.1")
- (home-page "https://github.com/go-playground/locales")
- (source
- (origin
- (method git-fetch)
- (uri (git-reference
- (url home-page)
- (commit (string-append "v" version))))
- (file-name (git-file-name name version))
- (sha256
- (base32 "117nss5gv7rfzr7z40rkpwfr273wv6ahrd3ycqdarxvaxh0ldhh4"))))
- (build-system go-build-system)
- (arguments
- '(#:import-path "github.com/go-playground/locales"))
- (propagated-inputs
- (list go-golang-org-x-text))
- (synopsis "Set of locales generated from the CLDR Unicode Project")
- (description
- "This package provides a set of locales generated from the
-@uref{http://cldr.unicode.org/, Unicode CLDR Project} which can be used
-independently or within an internalization (i18n) package. Its currently
-implemented features include
-
-@itemize
-@item Rules generated from the CLDR data, v31.0.3
-@item Contains Cardinal, Ordinal and Range Plural Rules
-@item Contains Month, Weekday and Timezone translations built in
-@item Contains Date & Time formatting functions
-@item Contains Number, Currency, Accounting and Percent formatting functions
-@item Supports the \"Gregorian\" calendar only
-@end itemize")
- (license license:expat)))
-
(define-public go-github-com-go-playground-universal-translator
(package
(name "go-github-com-go-playground-universal-translator")