aboutsummaryrefslogtreecommitdiff
path: root/gnu/packages
diff options
context:
space:
mode:
authorVinicius Monego <monego@posteo.net>2023-08-06 11:30:36 -0300
committerVinicius Monego <monego@posteo.net>2023-09-02 11:17:02 -0300
commit19617735df2b1af3b169d8153ae543ad3e0fc1a1 (patch)
treec43e55cac6931a072fe2a29993937733b859bc2a /gnu/packages
parentef85f624788b266f2e435e7a8d93b7fb76a9be42 (diff)
downloadguix-19617735df2b1af3b169d8153ae543ad3e0fc1a1.tar
guix-19617735df2b1af3b169d8153ae543ad3e0fc1a1.tar.gz
gnu: python-parsel: Update to 1.8.1.
* gnu/packages/python-web.scm (python-parsel): Update to 1.8.1. [build-system]: Use pyproject-build-system. [propagated-inputs]: Add python-jmespath, python-typing-extensions. Remove python-six. [native-inputs]: Add python-psutil. Remove python-pytest-runner.
Diffstat (limited to 'gnu/packages')
-rw-r--r--gnu/packages/python-web.scm11
1 files changed, 6 insertions, 5 deletions
diff --git a/gnu/packages/python-web.scm b/gnu/packages/python-web.scm
index c8ec32d268..2da3012173 100644
--- a/gnu/packages/python-web.scm
+++ b/gnu/packages/python-web.scm
@@ -8039,21 +8039,22 @@ by asyncio.")
(define-public python-parsel
(package
(name "python-parsel")
- (version "1.6.0")
+ (version "1.8.1")
(source
(origin
(method url-fetch)
(uri (pypi-uri "parsel" version))
(sha256
- (base32 "0yawf9r3r863lwxj0n89i7h3n8xjbsl5b7n6xg76r68scl5yzvvh"))))
- (build-system python-build-system)
+ (base32 "0f8yh30y3961a7kqwcnp4j3s7044ilakykiavc0skwdkr5l8xwmg"))))
+ (build-system pyproject-build-system)
(propagated-inputs
(list python-cssselect
+ python-jmespath
python-lxml
- python-six
+ python-typing-extensions
python-w3lib))
(native-inputs
- (list python-pytest python-pytest-runner))
+ (list python-psutil python-pytest))
(home-page "https://github.com/scrapy/parsel")
(synopsis "Extract data from HTML and XML using XPath and CSS selectors")
(description "Parsel is a library to extract and remove data from