aboutsummaryrefslogtreecommitdiff
path: root/gnu/packages
diff options
context:
space:
mode:
authorSharlatan Hellseher <sharlatanus@gmail.com>2024-07-28 22:07:18 +0100
committerSharlatan Hellseher <sharlatanus@gmail.com>2024-07-28 22:07:18 +0100
commit190e98f8fb50d5f98b27e6ca075b216e253b685a (patch)
treec401796aaca368e872be8156b63ad5b290d5188c /gnu/packages
parent38e174e3503657075e013b04f38c80ada1a5989f (diff)
downloadguix-190e98f8fb50d5f98b27e6ca075b216e253b685a.tar
guix-190e98f8fb50d5f98b27e6ca075b216e253b685a.tar.gz
gnu: go-github-com-arran4-golang-ical: Update to 0.3.1.
* gnu/packages/golang.scm (go-github-com-arran4-golang-ical): Update to 0.3.1. [propagated-inputs]: Remove go-gopkg-in-yaml-v3, go-gopkg-in-check-v1, go-github-com-stretchr-testify, go-github-com-niemeyer-pretty, go-github-com-kr-text, and go-github-com-davecgh-go-spew. [native-inputs]: Add go-github-com-google-go-cmp and go-github-com-stretchr-testify. Change-Id: I9a41eb87c75136e397278d01d7b0d7b846adfba7
Diffstat (limited to 'gnu/packages')
-rw-r--r--gnu/packages/golang.scm15
1 files changed, 6 insertions, 9 deletions
diff --git a/gnu/packages/golang.scm b/gnu/packages/golang.scm
index 9197f377fc..e50b3f3101 100644
--- a/gnu/packages/golang.scm
+++ b/gnu/packages/golang.scm
@@ -8859,25 +8859,22 @@ terminal.")
(define-public go-github-com-arran4-golang-ical
(package
(name "go-github-com-arran4-golang-ical")
- (version "0.0.0-20220517104411-fd89fefb0182")
+ (version "0.3.1")
(source (origin
(method git-fetch)
(uri (git-reference
(url "https://github.com/arran4/golang-ical")
- (commit (go-version->git-ref version))))
+ (commit (string-append "v" version))))
(file-name (git-file-name name version))
(sha256
(base32
- "0bxs0b5yg26liiifc0cc41l307r0wc93hp8iygv8dgpc60yzncaw"))))
+ "0gcn5afds1dnq3wrl4ndi4wqqwmrnvh9pdqhyv77d3cqakn82vj3"))))
(build-system go-build-system)
(arguments
(list #:import-path "github.com/arran4/golang-ical"))
- (propagated-inputs (list go-gopkg-in-yaml-v3
- go-gopkg-in-check-v1
- go-github-com-stretchr-testify
- go-github-com-niemeyer-pretty
- go-github-com-kr-text
- go-github-com-davecgh-go-spew))
+ (native-inputs
+ (list go-github-com-google-go-cmp
+ go-github-com-stretchr-testify))
(home-page "https://github.com/arran4/golang-ical")
(synopsis "Handle iCalenders in Go")
(description