aboutsummaryrefslogtreecommitdiff
path: root/gnu/packages
diff options
context:
space:
mode:
authorEfraim Flashner <efraim@flashner.co.il>2023-08-02 20:03:10 +0300
committerEfraim Flashner <efraim@flashner.co.il>2023-08-14 19:38:19 +0300
commit17ed4c79ba7be76a4e642c9751796f461ff286ae (patch)
tree22b809bbb9e5d01a2d1221c63ff4e6e4589d1422 /gnu/packages
parent8047d08b0f62fb58d696a175a6d955d1ba9918cc (diff)
downloadguix-17ed4c79ba7be76a4e642c9751796f461ff286ae.tar
guix-17ed4c79ba7be76a4e642c9751796f461ff286ae.tar.gz
gnu: Add rust-sysinfo-0.27.
* gnu/packages/crates-io.scm (rust-sysinfo-0.27): New variable. (rust-sysinfo-0.15): Inherit from rust-sysinfo-0.27.
Diffstat (limited to 'gnu/packages')
-rw-r--r--gnu/packages/crates-io.scm47
1 files changed, 39 insertions, 8 deletions
diff --git a/gnu/packages/crates-io.scm b/gnu/packages/crates-io.scm
index e648b695f2..bf8c21abe9 100644
--- a/gnu/packages/crates-io.scm
+++ b/gnu/packages/crates-io.scm
@@ -65456,8 +65456,46 @@ no_std compatible by default, only relying on alloc.")
("rust-errno" ,rust-errno-0.2)
("rust-libc" ,rust-libc-0.2))))))
+(define-public rust-sysinfo-0.27
+ (package
+ (name "rust-sysinfo")
+ (version "0.27.8")
+ (source (origin
+ (method url-fetch)
+ (uri (crate-uri "sysinfo" version))
+ (file-name (string-append name "-" version ".tar.gz"))
+ (sha256
+ (base32
+ "0cqy39g76298pqfr8jv30j6cxl9bpnd7c2smfxl5s2na1w2yj0m9"))))
+ (build-system cargo-build-system)
+ (arguments
+ `(#:cargo-test-flags
+ (list "--release" "--"
+ ;; These files aren't available in the build environment.
+ "--skip=test::check_system_info"
+ "--skip=test::check_uid_gid"
+ "--skip=test_networks"
+ "--skip=test_wait_non_child"
+ "--skip=test_process_disk_usage")
+ #:cargo-inputs
+ (("rust-cfg-if" ,rust-cfg-if-1)
+ ("rust-core-foundation-sys" ,rust-core-foundation-sys-0.8)
+ ("rust-libc" ,rust-libc-0.2)
+ ("rust-ntapi" ,rust-ntapi-0.4)
+ ("rust-once-cell" ,rust-once-cell-1)
+ ("rust-rayon" ,rust-rayon-1)
+ ("rust-winapi" ,rust-winapi-0.3))
+ #:cargo-development-inputs (("rust-tempfile" ,rust-tempfile-3))))
+ (home-page "https://github.com/GuillaumeGomez/sysinfo")
+ (synopsis "System handler to interact with processes")
+ (description
+ "This package is a library to get system information such as processes,
+processors, disks, components and networks.")
+ (license license:expat)))
+
(define-public rust-sysinfo-0.15
(package
+ (inherit rust-sysinfo-0.27)
(name "rust-sysinfo")
(version "0.15.11")
(source (origin
@@ -65467,7 +65505,6 @@ no_std compatible by default, only relying on alloc.")
(sha256
(base32
"0n713rhayp28z8j4pviqcg4blcp1yfvniwa1ipinp75hyv7lq0nx"))))
- (build-system cargo-build-system)
(arguments
`(#:skip-build? #t
#:cargo-inputs (("rust-cc" ,rust-cc-1)
@@ -65478,13 +65515,7 @@ no_std compatible by default, only relying on alloc.")
("rust-ntapi" ,rust-ntapi-0.3)
("rust-once-cell" ,rust-once-cell-1)
("rust-rayon" ,rust-rayon-1)
- ("rust-winapi" ,rust-winapi-0.3))))
- (home-page "https://github.com/GuillaumeGomez/sysinfo")
- (synopsis "System handler to interact with processes")
- (description
- "This package is a library to get system information such as processes,
-processors, disks, components and networks.")
- (license license:expat)))
+ ("rust-winapi" ,rust-winapi-0.3))))))
(define-public rust-sysinfo-0.23
(package