aboutsummaryrefslogtreecommitdiff
path: root/gnu/packages
diff options
context:
space:
mode:
authorSharlatan Hellseher <sharlatanus@gmail.com>2024-07-24 22:20:08 +0100
committerSharlatan Hellseher <sharlatanus@gmail.com>2024-07-25 21:01:00 +0100
commit1664dfa7b78f9d8e6cf891399b3b90350cc558b1 (patch)
tree432f1dac87804eda2f6776d825a4eaa9ca48e777 /gnu/packages
parent265345083d73301a5bb8da62d69a5ffac3510ccc (diff)
downloadguix-1664dfa7b78f9d8e6cf891399b3b90350cc558b1.tar
guix-1664dfa7b78f9d8e6cf891399b3b90350cc558b1.tar.gz
gnu: go-github-com-aws-aws-sdk-go: Enable all tests.
* gnu/packages/golang-web.scm (go-github-com-aws-aws-sdk-go): Enable all tests. [arguments]: <#:phases>: Add 'disable-failing-tests and use custom 'check phases. Change-Id: I732a4f0c1da8e431dd751aaa4a451f0b1a6656cb
Diffstat (limited to 'gnu/packages')
-rw-r--r--gnu/packages/golang-web.scm17
1 files changed, 16 insertions, 1 deletions
diff --git a/gnu/packages/golang-web.scm b/gnu/packages/golang-web.scm
index 8fa7b39b4c..237823e26e 100644
--- a/gnu/packages/golang-web.scm
+++ b/gnu/packages/golang-web.scm
@@ -243,7 +243,22 @@ connections from a single physical connection.")
(build-system go-build-system)
(arguments
(list
- #:import-path "github.com/aws/aws-sdk-go"))
+ #:import-path "github.com/aws/aws-sdk-go"
+ #:phases
+ #~(modify-phases %standard-phases
+ (add-after 'unpack 'disable-failing-tests
+ (lambda* (#:key tests? import-path #:allow-other-keys)
+ (with-directory-excursion (string-append "src/" import-path)
+ (substitute* (find-files "." "\\_test.go$")
+ (("TestProcessProviderTimeout")
+ "OffTestProcessProviderTimeout")))))
+ ;; XXX: Workaround for go-build-system's lack of Go modules
+ ;; support.
+ (replace 'check
+ (lambda* (#:key tests? import-path #:allow-other-keys)
+ (when tests?
+ (with-directory-excursion (string-append "src/" import-path)
+ (invoke "go" "test" "-v" "./..."))))))))
(propagated-inputs
(list go-github-com-jmespath-go-jmespath))
(home-page "https://github.com/aws/aws-sdk-go")