aboutsummaryrefslogtreecommitdiff
path: root/gnu/packages
diff options
context:
space:
mode:
authorVinicius Monego <monego@posteo.net>2024-05-13 20:52:15 +0000
committerSharlatan Hellseher <sharlatanus@gmail.com>2024-10-24 10:59:59 +0100
commit15033a1e63e3c6a987a2bd4c75663dcb08623109 (patch)
tree3ffbaad085eb641b6eb9cb7339c0acc9a02c25c1 /gnu/packages
parentadd8d159e8ebd788a3f8dfd141ef1cb627800aec (diff)
downloadguix-15033a1e63e3c6a987a2bd4c75663dcb08623109.tar
guix-15033a1e63e3c6a987a2bd4c75663dcb08623109.tar.gz
gnu: Add python-pplpy.
* gnu/packages/sagemath.scm (python-pplpy): New variable. Change-Id: I24d436a03462fd7eb176d34a15683a88814238ea Signed-off-by: Sharlatan Hellseher <sharlatanus@gmail.com>
Diffstat (limited to 'gnu/packages')
-rw-r--r--gnu/packages/sagemath.scm22
1 files changed, 22 insertions, 0 deletions
diff --git a/gnu/packages/sagemath.scm b/gnu/packages/sagemath.scm
index 8d5d04ee93..02201a9343 100644
--- a/gnu/packages/sagemath.scm
+++ b/gnu/packages/sagemath.scm
@@ -33,8 +33,10 @@
#:use-module (gnu packages autotools)
#:use-module (gnu packages bdw-gc)
#:use-module (gnu packages boost)
+ #:use-module (gnu packages check)
#:use-module (gnu packages compression)
#:use-module (gnu packages image)
+ #:use-module (gnu packages maths)
#:use-module (gnu packages lisp)
#:use-module (gnu packages multiprecision)
#:use-module (gnu packages pkg-config)
@@ -227,6 +229,26 @@ coefficients of which are modular integers.")
(license (list license:gpl2 license:gpl3)) ; dual licensed
(home-page "https://gitlab.com/sagemath/zn_poly")))
+(define-public python-pplpy
+ (package
+ (name "python-pplpy")
+ (version "0.8.10")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (pypi-uri "pplpy" version))
+ (sha256
+ (base32 "1zggfj09zkfcabcsasq27vwbhdmkig4yn380gi6wykcih9n22anl"))))
+ (build-system pyproject-build-system)
+ (native-inputs (list python-cython-3 python-pytest))
+ (inputs (list gmp mpc mpfr pari-gp ppl))
+ (propagated-inputs (list python-cysignals python-gmpy2))
+ (home-page "https://github.com/sagemath/pplpy")
+ (synopsis "Python PPL wrapper")
+ (description "This Python package provides a wrapper to the C++ Parma
+Polyhedra Library (PPL).")
+ (license license:gpl3+)))
+
(define-public brial
(package
(name "brial")