aboutsummaryrefslogtreecommitdiff
path: root/gnu/packages
diff options
context:
space:
mode:
authorAshish SHUKLA <ashish.is@lostca.se>2024-09-25 16:12:08 +0200
committerZheng Junjie <zhengjunjie@iscas.ac.cn>2024-09-29 23:02:39 +0800
commit10fcdd9100a6c1fa7efcd61558dfcfa0c6b3ad67 (patch)
treeda73db66e9d118d2f3ff2ff3f87e58d605a58e43 /gnu/packages
parent168d955c955c578536ba038644f7b6d3c6a5cfe4 (diff)
downloadguix-10fcdd9100a6c1fa7efcd61558dfcfa0c6b3ad67.tar
guix-10fcdd9100a6c1fa7efcd61558dfcfa0c6b3ad67.tar.gz
gnu: mold: Update to 2.34.0.
* gnu/packages/mold.scm (mold): Update to 2.34.0. [arguments](phases)<force-system-xxhash>: Update path. <fix-compiler-name-in-test>: Update path. <skip-tbb-lto-test>: Update path. <disable-rpath-test>: Update path. Change-Id: I21e8cdd057fb13b508299a1b0fd9b48f803959bd Signed-off-by: Zheng Junjie <zhengjunjie@iscas.ac.cn>
Diffstat (limited to 'gnu/packages')
-rw-r--r--gnu/packages/mold.scm12
1 files changed, 6 insertions, 6 deletions
diff --git a/gnu/packages/mold.scm b/gnu/packages/mold.scm
index 322214893c..d2534de6a1 100644
--- a/gnu/packages/mold.scm
+++ b/gnu/packages/mold.scm
@@ -35,7 +35,7 @@
(define-public mold
(package
(name "mold")
- (version "2.33.0")
+ (version "2.34.0")
(source
(origin
(method git-fetch)
@@ -44,7 +44,7 @@
(commit (string-append "v" version))))
(file-name (git-file-name name version))
(sha256
- (base32 "0wsb0aiqia3jfc9k3h2d446y0mzmaq6rz9xkjf9125npdygm7kpb"))
+ (base32 "0n8ygaxsda9ybc1jc7ap7grbziah403wjm2hmmcxzahm52v6czs0"))
(modules '((guix build utils)))
(snippet
#~(begin
@@ -62,25 +62,25 @@
#~(modify-phases %standard-phases
(add-before 'configure 'force-system-xxhash
(lambda _
- (substitute* "common/common.h"
+ (substitute* "lib/common.h"
(("#include \"../third-party/xxhash/xxhash.h\"")
"#include <xxhash.h>"))))
(add-before 'configure 'fix-compiler-name-in-test
(lambda _
- (substitute* "test/elf/common.inc"
+ (substitute* "test/common.inc"
(("CC=\"\\$\\{TEST_CC:-cc\\}\"") "CC=gcc")
(("CXX=\"\\$\\{TEST_CXX:-c\\+\\+\\}\"")
"CXX=g++"))))
(add-before 'configure 'skip-tbb-lto-test
(lambda _
;; This test needs tbb 2021.9.0 or newer
- (delete-file "test/elf/lto-version-script.sh")))
+ (delete-file "test/lto-version-script.sh")))
(add-before 'configure 'disable-rpath-test
(lambda _
;; This test fails because mold expect the RUNPATH as-is,
;; but compiler in Guix will insert the path of gcc-lib and
;; glibc into the output binary.
- (delete-file "test/elf/rpath.sh"))))))
+ (delete-file "test/rpath.sh"))))))
(inputs (list mimalloc tbb xxhash zlib `(,zstd "lib")))
(home-page "https://github.com/rui314/mold")
(synopsis "Fast linker")