aboutsummaryrefslogtreecommitdiff
path: root/gnu/packages
diff options
context:
space:
mode:
authorMark H Weaver <mhw@netris.org>2018-05-31 00:27:03 -0400
committerMark H Weaver <mhw@netris.org>2018-05-31 00:27:03 -0400
commit0d6f84aab1c2f4cd8ce1b68215a7a77426dc6cd5 (patch)
tree714784ba10d8b4f9f33393d285d148024ba5dea8 /gnu/packages
parent03d90319622a9fd9df1cf69cf123ed550e870276 (diff)
parent88a3465e4a467be92729fc37d8bda0155bbf5c52 (diff)
downloadguix-0d6f84aab1c2f4cd8ce1b68215a7a77426dc6cd5.tar
guix-0d6f84aab1c2f4cd8ce1b68215a7a77426dc6cd5.tar.gz
Merge branch 'master' into core-updates
Diffstat (limited to 'gnu/packages')
-rw-r--r--gnu/packages/calendar.scm25
-rw-r--r--gnu/packages/disk.scm11
-rw-r--r--gnu/packages/dns.scm4
-rw-r--r--gnu/packages/education.scm3
-rw-r--r--gnu/packages/games.scm15
-rw-r--r--gnu/packages/linux.scm61
-rw-r--r--gnu/packages/mail.scm3
-rw-r--r--gnu/packages/networking.scm3
-rw-r--r--gnu/packages/openstack.scm4
-rw-r--r--gnu/packages/perl.scm4
-rw-r--r--gnu/packages/scribus.scm15
-rw-r--r--gnu/packages/search.scm15
-rw-r--r--gnu/packages/skarnet.scm8
-rw-r--r--gnu/packages/statistics.scm7
-rw-r--r--gnu/packages/suckless.scm82
-rw-r--r--gnu/packages/terminals.scm9
-rw-r--r--gnu/packages/video.scm6
-rw-r--r--gnu/packages/web.scm52
18 files changed, 195 insertions, 132 deletions
diff --git a/gnu/packages/calendar.scm b/gnu/packages/calendar.scm
index d1aa9c256b..79cef99826 100644
--- a/gnu/packages/calendar.scm
+++ b/gnu/packages/calendar.scm
@@ -5,6 +5,7 @@
;;; Copyright © 2016, 2017 Efraim Flashner <efraim@flashner.co.il>
;;; Copyright © 2016 Troy Sankey <sankeytms@gmail.com>
;;; Copyright © 2016 Stefan Reichoer <stefan@xsteve.at>
+;;; Copyright © 2018 Tobias Geerinckx-Rice <me@tobias.gr>
;;;
;;; This file is part of GNU Guix.
;;;
@@ -110,24 +111,24 @@ data units.")
(lambda* (#:key inputs outputs #:allow-other-keys)
;; Make installed package available for running the tests
(add-installed-pythonpath inputs outputs)
- (and
- (zero? (system* "make" "--directory=doc/" "man"))
- (install-file
- "doc/build/man/khal.1"
- (string-append (assoc-ref outputs "out") "/share/man/man1")))))
+ (invoke "make" "--directory=doc/" "man")
+ (install-file
+ "doc/build/man/khal.1"
+ (string-append (assoc-ref outputs "out") "/share/man/man1"))
+ #t))
(replace 'check
(lambda* (#:key inputs #:allow-other-keys)
;; The tests require us to choose a timezone.
(setenv "TZ"
(string-append (assoc-ref inputs "tzdata")
"/share/zoneinfo/Zulu"))
- (zero? (system* "py.test" "tests" "-k"
- (string-append
- ;; These tests are known to fail in when not
- ;; running in a TTY:
- ;; https://github.com/pimutils/khal/issues/683
- "not test_printics_read_from_stdin "
- "and not test_import_from_stdin"))))))))
+ (invoke "py.test" "tests" "-k"
+ (string-append
+ ;; These tests are known to fail in when not
+ ;; running in a TTY:
+ ;; https://github.com/pimutils/khal/issues/683
+ "not test_printics_read_from_stdin "
+ "and not test_import_from_stdin")))))))
(native-inputs
`(("python-pytest" ,python-pytest)
("python-pytest-cov" ,python-pytest-cov)
diff --git a/gnu/packages/disk.scm b/gnu/packages/disk.scm
index d7bf726830..f5776ebda8 100644
--- a/gnu/packages/disk.scm
+++ b/gnu/packages/disk.scm
@@ -464,15 +464,15 @@ a card with a smaller capacity than stated.")
(define-public duperemove
(package
(name "duperemove")
- (version "v0.11.beta4")
+ (version "0.11")
(source (origin
(method url-fetch)
(uri (string-append
- "https://github.com/markfasheh/duperemove/archive/"
+ "https://github.com/markfasheh/duperemove/archive/v"
version ".tar.gz"))
(sha256
(base32
- "1h5nk03kflfnzihvn2rvfz1h623x1zpkn9hp29skd7n3f2bc5k7x"))
+ "0rjmmh42yqw9a5j6sp31cqwxk3s97dsi4xz0wpxpllj7bsp3aiw5"))
(file-name (string-append name "-" version ".tar.gz"))))
(build-system gnu-build-system)
(native-inputs
@@ -481,11 +481,10 @@ a card with a smaller capacity than stated.")
`(("glib" ,glib)
("sqlite" ,sqlite)))
(arguments
- `(#:tests? #f ;no test suite
+ `(#:tests? #f ; no test suite
#:phases
(modify-phases %standard-phases
- ;; no configure script
- (delete 'configure))
+ (delete 'configure)) ; no configure script
#:make-flags (list (string-append "PREFIX=" %output)
"CC=gcc")))
(home-page "https://github.com/markfasheh/duperemove")
diff --git a/gnu/packages/dns.scm b/gnu/packages/dns.scm
index 96fbf5a19c..0b8d8be574 100644
--- a/gnu/packages/dns.scm
+++ b/gnu/packages/dns.scm
@@ -492,14 +492,14 @@ Extensions} (DNSSEC).")
(define-public knot
(package
(name "knot")
- (version "2.6.6")
+ (version "2.6.7")
(source (origin
(method url-fetch)
(uri (string-append "https://secure.nic.cz/files/knot-dns/"
name "-" version ".tar.xz"))
(sha256
(base32
- "02h8qdkja4kic3br79svws6r2pq1ijz945238v99d998d2jxh6ci"))
+ "0hr2m664ckjicv3pq2lk16m61pscknywxv2ydnrzfqf10m5h0ahw"))
(modules '((guix build utils)))
(snippet
'(begin
diff --git a/gnu/packages/education.scm b/gnu/packages/education.scm
index 72cd7c61ba..03050ffd0a 100644
--- a/gnu/packages/education.scm
+++ b/gnu/packages/education.scm
@@ -3,6 +3,7 @@
;;; Copyright © 2016, 2017 Ricardo Wurmus <rekado@elephly.net>
;;; Copyright © 2016 Hartmut Goebel <h.goebel@crazy-compilers.com>
;;; Copyright © 2017, 2018 Efraim Flashner <efraim@flashner.co.il>
+;;; Copyright © 2018 Tobias Geerinckx-Rice <me@tobias.gr>
;;; Copyright © 2018 Nicolas Goaziou <mail@nicolasgoaziou.fr>
;;;
;;; This file is part of GNU Guix.
@@ -216,7 +217,7 @@ Currently available boards include:
(substitute* "def/defines.h"
(("\"/usr/") (string-append "\"" out "/")))
;; Recreate Makefile
- (zero? (system* "qmake"))))))))
+ (invoke "qmake")))))))
(inputs
`(("qt4" ,qt-4)
("sqlite" ,sqlite)))
diff --git a/gnu/packages/games.scm b/gnu/packages/games.scm
index 26a77e2404..0df9b9d195 100644
--- a/gnu/packages/games.scm
+++ b/gnu/packages/games.scm
@@ -67,6 +67,7 @@
#:use-module (gnu packages audio)
#:use-module (gnu packages avahi)
#:use-module (gnu packages boost)
+ #:use-module (gnu packages crypto)
#:use-module (gnu packages documentation)
#:use-module (gnu packages docbook)
#:use-module (gnu packages fltk)
@@ -4062,16 +4063,16 @@ fight against their plot and save his fellow rabbits from slavery.")
(define-public 0ad-data
(package
(name "0ad-data")
- (version "0.0.22-alpha")
+ (version "0.0.23-alpha")
(source
(origin
(method url-fetch)
- (uri (string-append "http://releases.wildfiregames.com/0ad-"
+ (uri (string-append "https://releases.wildfiregames.com/0ad-"
version "-unix-data.tar.xz"))
(file-name (string-append name "-" version ".tar.xz"))
(sha256
(base32
- "0vknk9ay9h2p34r7mym2g066f3s3c5d5vmap0ckcs5b86h5cscjc"))
+ "1b6qcvd8yyyxavgdwpcs7asmln3xgnvjkglz6ggvwb956x37ggzx"))
(modules '((guix build utils)))
(snippet
#~(begin
@@ -4115,19 +4116,18 @@ fight against their plot and save his fellow rabbits from slavery.")
(define-public 0ad
(package
(name "0ad")
- (version "0.0.22-alpha")
+ (version "0.0.23-alpha")
(source
(origin
(method url-fetch)
- (uri (string-append "http://releases.wildfiregames.com/0ad-"
+ (uri (string-append "https://releases.wildfiregames.com/0ad-"
version "-unix-build.tar.xz"))
(file-name (string-append name "-" version ".tar.xz"))
(sha256
(base32
- "1cgmr4g5g9wv36v7ylbrvqhsjwgcsdgbqwc8zlqmnayk9zgkdpgx"))
+ "0qz1sg4n5y766qwgi63drrrx6k17kk0rcnn9a4a9crllk2vf78fg"))))
;; A snippet here would cause a build failure because of timestamps
;; reset. See https://bugs.gnu.org/26734.
- ))
(inputs
`(("0ad-data" ,0ad-data)
("curl" ,curl)
@@ -4135,6 +4135,7 @@ fight against their plot and save his fellow rabbits from slavery.")
("gloox" ,gloox)
("icu4c" ,icu4c)
("libpng" ,libpng)
+ ("libsodium" ,libsodium)
("libvorbis" ,libvorbis)
("libxcursor" ,libxcursor)
("libxml2" ,libxml2)
diff --git a/gnu/packages/linux.scm b/gnu/packages/linux.scm
index 0581dbd5bc..4100db5d8a 100644
--- a/gnu/packages/linux.scm
+++ b/gnu/packages/linux.scm
@@ -395,8 +395,8 @@ It has been modified to remove all non-free binary blobs.")
;; supports qemu "virt" machine and possibly a large number of ARM boards.
;; See : https://wiki.debian.org/DebianKernel/ARMMP.
-(define %linux-libre-version "4.16.12")
-(define %linux-libre-hash "1zjq16z5cdcpa4acqdilavjjv2xbqnh3fmn400n9hd5pzyll817m")
+(define %linux-libre-version "4.16.13")
+(define %linux-libre-hash "1frpqxv5ykf87hrmh62b8nxxcpv64a5w7lxw51z4vs82799inmng")
(define-public linux-libre
(make-linux-libre %linux-libre-version
@@ -404,25 +404,52 @@ It has been modified to remove all non-free binary blobs.")
%linux-compatible-systems
#:configuration-file kernel-config))
-(define %linux-libre-4.14-version "4.14.44")
-(define %linux-libre-4.14-hash "0w89y22by17yqk89l1mmhlvz0i4dkp1mjc347nq3zy1llbwiwvnf")
+(define %linux-libre-4.14-version "4.14.46")
+(define %linux-libre-4.14-hash "17imkhqk3m3djdj0m5h4lqs9cfdh9zq1cz83q8ldyald56rbn622")
(define-public linux-libre-4.14
(make-linux-libre %linux-libre-4.14-version
%linux-libre-4.14-hash
'("x86_64-linux" "i686-linux" "armhf-linux")
+ #:patches
+ (list %boot-logo-patch
+ (origin
+ ;; The sole fix in the 4.14.47 release.
+ (method url-fetch)
+ (uri "https://git.kernel.org/pub/scm/linux/kernel/\
+git/stable/linux-stable.git/patch/?id=3e496be2038a100fc53627238fe120dc4c948719")
+ (sha256
+ (base32 "1hk1qd6v97zf8an3zww60zhsah1wwax22b3bpdzmfjhhbndyram9"))))
#:configuration-file kernel-config))
(define-public linux-libre-4.9
- (make-linux-libre "4.9.103"
- "00g58y92pmb6xf9lhjrab2jrjv3naw3857pf9s43dvh6fwlbccbf"
+ (make-linux-libre "4.9.104"
+ "0b6y24vfsjhiv7qq7xqx7h9krc81c49dqh0189nm1lhfwciyir57"
%intel-compatible-systems
+ #:patches
+ (list %boot-logo-patch
+ (origin
+ ;; The sole fix in the 4.9.105 release.
+ (method url-fetch)
+ (uri "https://git.kernel.org/pub/scm/linux/kernel/\
+git/stable/linux-stable.git/patch/?id=98d69fb3b175855cdd4c37d41a4b477a0860b1a0")
+ (sha256
+ (base32 "1r52fr0w94fgw7nfxrysjk0mljlnqwqsnl0cp84c1sly466i79dv"))))
#:configuration-file kernel-config))
(define-public linux-libre-4.4
- (make-linux-libre "4.4.133"
- "05qc9smcvxd68d46l5gjhvihhnidkiymqh4fv4nyagzv555q7na7"
+ (make-linux-libre "4.4.134"
+ "137mklzyv56yhc48l5h5i0h01gm1q40x2a8nk51lwhbjv592xr8x"
%intel-compatible-systems
+ #:patches
+ (list %boot-logo-patch
+ (origin
+ ;; The sole fix in the 4.4.135 release.
+ (method url-fetch)
+ (uri "https://git.kernel.org/pub/scm/linux/kernel/\
+git/stable/linux-stable.git/patch/?id=393e9b3c30d571c2f655aa24b0dee5be9ce249b5")
+ (sha256
+ (base32 "02wk036v525qwqs42ndqqj4mv8xfkpavibfg5ns6hkg2wc5a1jid"))))
#:configuration-file kernel-config))
(define-public linux-libre-4.1
@@ -443,6 +470,15 @@ It has been modified to remove all non-free binary blobs.")
%linux-libre-4.14-hash
'("armhf-linux")
#:defconfig "multi_v7_defconfig"
+ #:patches
+ (list %boot-logo-patch
+ (origin
+ ;; The sole fix in the 4.14.47 release.
+ (method url-fetch)
+ (uri "https://git.kernel.org/pub/scm/linux/kernel/\
+git/stable/linux-stable.git/patch/?id=3e496be2038a100fc53627238fe120dc4c948719")
+ (sha256
+ (base32 "1hk1qd6v97zf8an3zww60zhsah1wwax22b3bpdzmfjhhbndyram9"))))
#:extra-version "arm-generic"))
(define-public linux-libre-arm-omap2plus
@@ -457,6 +493,15 @@ It has been modified to remove all non-free binary blobs.")
%linux-libre-4.14-hash
'("armhf-linux")
#:defconfig "omap2plus_defconfig"
+ #:patches
+ (list %boot-logo-patch
+ (origin
+ ;; The sole fix in the 4.14.47 release.
+ (method url-fetch)
+ (uri "https://git.kernel.org/pub/scm/linux/kernel/\
+git/stable/linux-stable.git/patch/?id=3e496be2038a100fc53627238fe120dc4c948719")
+ (sha256
+ (base32 "1hk1qd6v97zf8an3zww60zhsah1wwax22b3bpdzmfjhhbndyram9"))))
#:extra-version "arm-omap2plus"))
diff --git a/gnu/packages/mail.scm b/gnu/packages/mail.scm
index 49663fdf90..eabdba692a 100644
--- a/gnu/packages/mail.scm
+++ b/gnu/packages/mail.scm
@@ -1369,7 +1369,8 @@ hashing schemes plugin for @code{Dovecot}.")
`(("perl" ,perl)))
(inputs
`(("bdb" ,bdb)
- ("openssl" ,openssl)))
+ ("openssl" ,openssl)
+ ("zlib" ,zlib)))
(home-page "http://isync.sourceforge.net/")
(synopsis "Mailbox synchronization program")
(description
diff --git a/gnu/packages/networking.scm b/gnu/packages/networking.scm
index 43aaf33dd0..3c86c01f61 100644
--- a/gnu/packages/networking.scm
+++ b/gnu/packages/networking.scm
@@ -605,7 +605,8 @@ of the same name.")
#include <QStyleOption>"))
(substitute* "ui/qt/wireless_frame.cpp"
(("#include <QProcess>") "#include <QProcess>
-#include <QAbstractItemView>")))))))
+#include <QAbstractItemView>"))
+ #t)))))
(synopsis "Network traffic analyzer")
(description "Wireshark is a network protocol analyzer, or @dfn{packet
sniffer}, that lets you capture and interactively browse the contents of
diff --git a/gnu/packages/openstack.scm b/gnu/packages/openstack.scm
index 3e9fd375c9..64e05c4b0e 100644
--- a/gnu/packages/openstack.scm
+++ b/gnu/packages/openstack.scm
@@ -680,14 +680,14 @@ and better support for mocking results.")
(define-public python-oslo.utils
(package
(name "python-oslo.utils")
- (version "3.36.0")
+ (version "3.36.2")
(source
(origin
(method url-fetch)
(uri (pypi-uri "oslo.utils" version))
(sha256
(base32
- "0zvm31qdvqywxppqdjwbxxsqaga3dg4slpvbbmqqm9ig4n78mhay"))))
+ "1ipjcgg9z697wmibhcbg5lqpk5gafakdx4qkff3w255zr0mvw04r"))))
(build-system python-build-system)
(propagated-inputs
`(("python-debtcollector" ,python-debtcollector)
diff --git a/gnu/packages/perl.scm b/gnu/packages/perl.scm
index b810037ee1..79add3e6d1 100644
--- a/gnu/packages/perl.scm
+++ b/gnu/packages/perl.scm
@@ -8237,7 +8237,7 @@ generally slower on larger files.")
(define-public perl-text-format
(package
(name "perl-text-format")
- (version "0.60")
+ (version "0.61")
(source (origin
(method url-fetch)
(uri (string-append
@@ -8245,7 +8245,7 @@ generally slower on larger files.")
version ".tar.gz"))
(sha256
(base32
- "1f52jak0a2gwi4qcisp4nfbniq04dmmv5j8zkvzj8ik0f0sk2kv6"))))
+ "0axfyiml3zwawwd127z8rl2lm53z6dlsflzmp80m3j0myn7kp2mv"))))
(build-system perl-build-system)
(native-inputs
`(("perl-module-build" ,perl-module-build)
diff --git a/gnu/packages/scribus.scm b/gnu/packages/scribus.scm
index 6cf382e0bb..09ab97e8b3 100644
--- a/gnu/packages/scribus.scm
+++ b/gnu/packages/scribus.scm
@@ -2,6 +2,7 @@
;;; Copyright © 2015 Ricardo Wurmus <rekado@elephly.net>
;;; Copyright © 2016 Efraim Flashner <efraim@flashner.co.il>
;;; Copyright © 2017 Nicolas Goaziou <mail@nicolasgoaziou.fr>
+;;; Copyright © 2018 Clément Lassieur <clement@lassieur.org>
;;;
;;; This file is part of GNU Guix.
;;;
@@ -86,6 +87,20 @@
'("-DWANT_GRAPHICSMAGICK=1")
#:phases
(modify-phases %standard-phases
+ (add-after 'unpack 'patch-source
+ (lambda _
+ ;; Fix build against Qt 5.11.
+ (substitute* "scribus/plugins/tools/lenseffects/lensdialog.cpp"
+ (("#include <cmath>") "#include <cmath>
+#include <QStyleOptionGraphicsItem>"))
+ (substitute* "scribus/plugins/tools/2geomtools/meshdistortion/meshdistortiondialog.cpp"
+ (("#include <QGraphicsItem>") "#include <QGraphicsItem>
+#include <QStyleOptionGraphicsItem>"))
+ (substitute* "scribus/sclistboxpixmap.h"
+ (("#include <QVariant>") "#include <QVariant>
+#include <QStyleOptionViewItem>
+#include <QAbstractItemDelegate>"))
+ #t))
(add-after 'install 'wrap-program
(lambda* (#:key inputs outputs #:allow-other-keys)
;; Fix "ImportError: No module named _sysconfigdata_nd" where
diff --git a/gnu/packages/search.scm b/gnu/packages/search.scm
index 5c8539d561..e176fd1aa7 100644
--- a/gnu/packages/search.scm
+++ b/gnu/packages/search.scm
@@ -3,6 +3,7 @@
;;; Copyright © 2015, 2016 Eric Bavier <bavier@member.fsf.org>
;;; Copyright © 2017 Thomas Danckaert <post@thomasdanckaert.be>
;;; Copyright © 2017 Ricardo Wurmus <rekado@elephly.net>
+;;; Copyright © 2018 Tobias Geerinckx-Rice <me@tobias.gr>
;;; Copyright © 2018 Adam Massmann <massmannak@gmail.com>
;;;
;;; This file is part of GNU Guix.
@@ -64,13 +65,13 @@
;; getaddrinfo(). This does not work in the build environment,
;; so exclude those tests. See HACKING for the list of targets.
(lambda _
- (zero? (system* "make"
- "check-inmemory"
- "check-remoteprog"
- ;"check-remotetcp"
- "check-multi"
- "check-glass"
- "check-chert")))))))
+ (invoke "make"
+ "check-inmemory"
+ "check-remoteprog"
+ ;"check-remotetcp"
+ "check-multi"
+ "check-glass"
+ "check-chert"))))))
(synopsis "Search Engine Library")
(description
"Xapian is a highly adaptable toolkit which allows developers to easily
diff --git a/gnu/packages/skarnet.scm b/gnu/packages/skarnet.scm
index a0b482a671..21d2eebaa9 100644
--- a/gnu/packages/skarnet.scm
+++ b/gnu/packages/skarnet.scm
@@ -29,7 +29,7 @@
(define-public skalibs
(package
(name "skalibs")
- (version "2.6.3.1")
+ (version "2.6.4.0")
(source
(origin
(method url-fetch)
@@ -37,7 +37,7 @@
version ".tar.gz"))
(sha256
(base32
- "108c4vslsfy57892ybbksscrjd4bx444hzzcq2g5wdg2sh0cl245"))))
+ "1iywavxaw398ifc35xda27cb8hx14viy3kqrzby8fqysx3qp7b1h"))))
(build-system gnu-build-system)
(arguments
'(#:tests? #f ; no tests exist
@@ -218,7 +218,7 @@ clock synchronization.")))
(define-public s6-rc
(package
(name "s6-rc")
- (version "0.4.0.0")
+ (version "0.4.0.1")
(source
(origin
(method url-fetch)
@@ -226,7 +226,7 @@ clock synchronization.")))
version ".tar.gz"))
(sha256
(base32
- "1fkg9635cvrf6gw055y346a3n634dy2xiwbypawi68flfprfgf4n"))))
+ "0p4yczbib626kygr3pdvvay0xwyha92rjnhn79cbx18ywc2n4jsb"))))
(build-system gnu-build-system)
(inputs `(("skalibs" ,skalibs)
("execline" ,execline)
diff --git a/gnu/packages/statistics.scm b/gnu/packages/statistics.scm
index d95b041843..eb21fcd303 100644
--- a/gnu/packages/statistics.scm
+++ b/gnu/packages/statistics.scm
@@ -1603,13 +1603,13 @@ and printing capabilities than traditional data frames.")
(define-public r-dplyr
(package
(name "r-dplyr")
- (version "0.7.4")
+ (version "0.7.5")
(source (origin
(method url-fetch)
(uri (cran-uri "dplyr" version))
(sha256
(base32
- "1hm8ml7yaraag1ak6kvz2mxx6if568c759ix8a1n9d7va03wj7vv"))))
+ "0l6smzdgb8w505gyl8gnwlg988a6cmafh3rssiv00rsrd8qqzg9g"))))
(build-system r-build-system)
(propagated-inputs
`(("r-assertthat" ,r-assertthat)
@@ -1620,7 +1620,8 @@ and printing capabilities than traditional data frames.")
("r-glue" ,r-glue)
("r-pkgconfig" ,r-pkgconfig)
("r-bindrcpp" ,r-bindrcpp)
- ("r-tibble" ,r-tibble)))
+ ("r-tibble" ,r-tibble)
+ ("r-tidyselect" ,r-tidyselect)))
(native-inputs
`(("r-rcpp" ,r-rcpp)
("r-bh" ,r-bh)))
diff --git a/gnu/packages/suckless.scm b/gnu/packages/suckless.scm
index 4cd0773062..ed4ec28534 100644
--- a/gnu/packages/suckless.scm
+++ b/gnu/packages/suckless.scm
@@ -171,7 +171,7 @@ numbers of user-defined menu items efficiently.")
(define-public spoon
(package
(name "spoon")
- (version "0.3")
+ (version "0.6")
(source
(origin
(method url-fetch)
@@ -179,16 +179,16 @@ numbers of user-defined menu items efficiently.")
name "-" version ".tar.gz"))
(sha256
(base32
- "10c5i7ykpy7inzzfiw1dh0srpkljycr3blxhvd8160wsvplbws48"))))
+ "1jpmg9k9f4f3lpz0k3cphqjswlyf8lz2sm8ccifiip93kd4rrdj0"))))
(build-system gnu-build-system)
(arguments
- `(#:tests? #f ; No tests
+ `(#:tests? #f ; no tests
#:make-flags (list "CC=gcc"
(string-append "PREFIX=" %output))))
(inputs
`(("libx11" ,libx11)
("libxkbfile" ,libxkbfile)
- ("alsa-lib" ,alsa-lib)
+ ("alsa-lib" ,alsa-lib) ; tinyalsa (unpackaged) would suffice
("libmpdclient" ,libmpdclient)))
(home-page "https://git.2f30.org/spoon/")
(synopsis "Set dwm status")
@@ -227,7 +227,7 @@ numbers of user-defined menu items efficiently.")
(define-public st
(package
(name "st")
- (version "0.7")
+ (version "0.8.1")
(source
(origin
(method url-fetch)
@@ -235,7 +235,7 @@ numbers of user-defined menu items efficiently.")
version ".tar.gz"))
(sha256
(base32
- "00309qiw20rc89696pk8bdr7ik4r1aarik7jxqk8k66cdj80v1zp"))))
+ "09k94v3n20gg32xy7y68p96x9dq5msl80gknf9gbvlyjp3i0zyy4"))))
(build-system gnu-build-system)
(arguments
'(#:tests? #f ; no tests
@@ -247,14 +247,15 @@ numbers of user-defined menu items efficiently.")
(add-after 'unpack 'inhibit-terminfo-install
(lambda _
(substitute* "Makefile"
- (("\t@tic -s st.info") ""))
+ (("\ttic .*") ""))
#t)))))
(inputs
`(("libx11" ,libx11)
("libxft" ,libxft)
("fontconfig" ,fontconfig)
("freetype" ,freetype)))
- (native-inputs `(("pkg-config" ,pkg-config)))
+ (native-inputs
+ `(("pkg-config" ,pkg-config)))
(home-page "https://st.suckless.org/")
(synopsis "Simple terminal emulator")
(description
@@ -311,19 +312,19 @@ point surf to another URI by setting its XProperties.")
(define-public sent
(package
(name "sent")
- (version "0.2")
+ (version "1")
(source (origin
- (method url-fetch)
+ (method url-fetch/tarbomb)
(uri (string-append "https://dl.suckless.org/tools/sent-"
version ".tar.gz"))
(sha256
(base32
- "0xhh752hwaa26k4q6wvrb9jnpbnylss2aw6z11j7l9rav7wn3fak"))))
+ "0cxysz5lp25mgww73jl0mgip68x7iyvialyzdbriyaff269xxwvv"))))
(build-system gnu-build-system)
(arguments
`(#:phases (modify-phases %standard-phases
- (delete 'configure)) ;no configuration
- #:tests? #f ;no test suite
+ (delete 'configure)) ; no configuration
+ #:tests? #f ; no test suite
#:make-flags (let ((pkg-config (lambda (flag)
(string-append
"$(shell pkg-config " flag " "
@@ -526,31 +527,28 @@ cups server to be installed.")
"Noice is a small curses-based file browser.")
(license license:bsd-2)))
-;;; We want some commits that are more recent than the latest release, 0.2
(define-public human
- (let ((commit "50c80e6ba12823184b6866e06b955dbd2ccdc5d7")
- (revision "1"))
- (package
- (name "human")
- (version (string-append "0.2-" revision "." (string-take commit 7)))
- (source
- (origin
- (method git-fetch)
- (uri (git-reference
- (url "git://git.2f30.org/human.git")
- (commit commit)))
- (file-name (string-append name "-" version "-checkout"))
- (sha256
- (base32
- "18xngm4h9vsyip52zwd79rrp1irzg6rs462lpbp61amf7hj955gn"))))
+ (package
+ (name "human")
+ (version "0.3")
+ (source
+ (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "git://git.2f30.org/human.git")
+ (commit version)))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32
+ "0y0bsmvpwfwb2lwspi6a799y34h1faxc6yfanyw6hygxc8661mga"))))
(build-system gnu-build-system)
(arguments
- `(#:tests? #f ; No tests
+ `(#:tests? #f ; no tests
#:make-flags (list "CC=gcc"
(string-append "PREFIX=" %output))
#:phases
(modify-phases %standard-phases
- (delete 'configure)))) ; No configure script
+ (delete 'configure)))) ; no configure script
(home-page "https://git.2f30.org/human/")
(synopsis "Convert bytes to human readable formats")
(description
@@ -559,7 +557,7 @@ human readable format. By default, it tries to detect the best
factorisation, but you can force its output.
You can adjust the number of decimals with the @code{SCALE}
environment variable.")
- (license license:wtfpl2))))
+ (license license:wtfpl2)))
(define-public fortify-headers
(package
@@ -682,8 +680,8 @@ as -1, to be used instead of U+FFFD.
;; No release tarballs so far.
(define-public lchat
- (let ((revision "2")
- (commit "25d90f4630b45e2b609d2e3daecb32cf5ff065fd"))
+ (let ((revision "3")
+ (commit "f95191970fd59c52a8b09cff32bd8d2135cbfc6b"))
(package
(name "lchat")
(version (string-append "0.0.0-" revision "." (string-take commit 7)))
@@ -696,24 +694,26 @@ as -1, to be used instead of U+FFFD.
(file-name (string-append name "-" version "-checkout"))
(sha256
(base32
- "0dvljyq3m7rxxkqv7rkmijak6vj8i4db3iq2z988bvf76chz268b"))))
+ "07pxzziczhzprmjy61k7nl9i1kxpgnad37qkjf5fn4wf06nqdxpl"))))
(build-system gnu-build-system)
(arguments
- `(#:tests? #f ; No tests
+ `(#:test-target "test"
#:make-flags (list "CC=gcc"
(string-append "PREFIX=" %output))
#:phases
(modify-phases %standard-phases
- (delete 'configure) ; No configure script
+ (delete 'configure) ; no configure script
(add-before 'build 'libbsd
(lambda _
(substitute* "Makefile"
(("-lutf") "-lutf -lbsd"))))
(replace 'install
(lambda* (#:key outputs #:allow-other-keys)
- (let* ((out (assoc-ref outputs "out"))
- (bin (string-append out "/bin")))
+ (let* ((out (assoc-ref outputs "out"))
+ (bin (string-append out "/bin"))
+ (man1 (string-append out "/share/man/man1")))
(install-file "lchat" bin)
+ (install-file "lchat.1" man1)
#t))))))
(inputs
`(("grep" ,grep)
@@ -724,6 +724,6 @@ as -1, to be used instead of U+FFFD.
(synopsis "Line chat is a frontend for the irc client ii from suckless")
(description
"Lchat (line chat) is the little and small brother of cii.
-It is a front end for ii-like chat programs. It uses tail(1) -f to get the
-chat output in background.")
+It is a front end for ii-like chat programs. It uses @code{tail -f} to get the
+chat output in the background.")
(license license:isc))))
diff --git a/gnu/packages/terminals.scm b/gnu/packages/terminals.scm
index 399a633269..f18f88a2ce 100644
--- a/gnu/packages/terminals.scm
+++ b/gnu/packages/terminals.scm
@@ -619,7 +619,7 @@ eye-candy, customizable, and reasonably lightweight.")
(define-public sakura
(package
(name "sakura")
- (version "3.5.0")
+ (version "3.6.0")
(source (origin
(method url-fetch)
(uri (string-append "https://launchpad.net/" name "/trunk/"
@@ -627,14 +627,13 @@ eye-candy, customizable, and reasonably lightweight.")
".tar.bz2"))
(sha256
(base32
- "0fhcn3540iw22l5zg3njh5z8cj0g2n9p6fvagjqa5zc323jfsc7b"))))
+ "1q463qm41ym7jb3kbzjz7b6x549vmgkb70arpkhsf86yxly1y5m1"))))
(build-system cmake-build-system)
(arguments
- ;; no check phase
- '(#:tests? #f))
+ '(#:tests? #f)) ; no check phase
(native-inputs
`(("gettext" ,gettext-minimal)
- ("perl" ,perl) ; for pod2man
+ ("perl" ,perl) ; for pod2man
("pkg-config" ,pkg-config)))
(inputs
`(("libxft" ,libxft)
diff --git a/gnu/packages/video.scm b/gnu/packages/video.scm
index abf317e9ed..2278a3275e 100644
--- a/gnu/packages/video.scm
+++ b/gnu/packages/video.scm
@@ -366,13 +366,13 @@ H.264 (MPEG-4 AVC) video streams.")
(replace 'build
(lambda _
(let ((-j (list "-j" (number->string (parallel-job-count)))))
- (zero? (apply system* "rake" -j)))))
+ (apply invoke "rake" -j))))
(replace 'check
(lambda _
- (zero? (system* "rake" "tests/unit"))))
+ (invoke "rake" "tests/unit")))
(replace 'install
(lambda _
- (zero? (system* "rake" "install")))))))
+ (invoke "rake" "install"))))))
(home-page "https://mkvtoolnix.download")
(synopsis "Tools to create, alter and inspect Matroska files")
(description
diff --git a/gnu/packages/web.scm b/gnu/packages/web.scm
index e03231347a..c5547ec2df 100644
--- a/gnu/packages/web.scm
+++ b/gnu/packages/web.scm
@@ -686,8 +686,8 @@ instances, while JSON's objects will be mapped to @code{QVariantMap}.")
(add-after 'wrap-program 'check
(lambda* (#:key inputs outputs #:allow-other-keys)
(with-directory-excursion "data"
- (zero? (system* (string-append (assoc-ref outputs "out") "/bin/ktImportText")
- "ec.tsv"))))))))
+ (invoke (string-append (assoc-ref outputs "out") "/bin/ktImportText")
+ "ec.tsv")))))))
(inputs
`(("perl" ,perl)))
(home-page "https://github.com/marbl/Krona/wiki")
@@ -851,7 +851,7 @@ UTS#46.")
;; source tree.
(copy-recursively "build/gnuauto" ".")
(setenv "AUTOMAKE" "automake --foreign")
- (zero? (system* "autoreconf" "-vfi")))))))
+ (invoke "autoreconf" "-vfi"))))))
(native-inputs
`(("automake" ,automake)
("autoconf" ,autoconf)
@@ -1232,11 +1232,9 @@ minimum to provide high performance operation.")
(delete 'configure)
(add-after 'unpack 'unpack-libsass-and-set-path
(lambda* (#:key inputs #:allow-other-keys)
- (and (zero? (system* "tar" "xvf" (assoc-ref inputs "libsass")))
- (begin
- (setenv "SASS_LIBSASS_PATH"
- (string-append (getcwd) "/libsass-" ,version))
- #t)))))))
+ (invoke "tar" "xvf" (assoc-ref inputs "libsass"))
+ (setenv "SASS_LIBSASS_PATH"
+ (string-append (getcwd) "/libsass-" ,version)))))))
(inputs
`(("libsass" ,libsass)))
(synopsis "CSS pre-processor")
@@ -4781,7 +4779,7 @@ handling many of the web standards in use today.")
(let* ((out (assoc-ref %outputs "out"))
(man (string-append out "/share/man/man1")))
(with-directory-excursion man
- (zero? (system* "gzip" "elvi.1sr")))))))))
+ (invoke "gzip" "elvi.1sr"))))))))
(inputs
`(("perl" ,perl)
("perl-www-opensearch" ,perl-www-opensearch)
@@ -4886,8 +4884,8 @@ on the fly.")
(lambda* (#:key outputs #:allow-other-keys)
(let* ((out (assoc-ref outputs "out")))
(setenv "CONFIG_SHELL" (which "bash"))
- (zero? (system* "./configure"
- (string-append "--prefix=" out)))))))))
+ (invoke "./configure"
+ (string-append "--prefix=" out))))))))
(home-page "http://www.nocrew.org/software/httptunnel.html")
(synopsis "Tunnel data connections through HTTP requests")
(description "httptunnel creates a bidirectional virtual data connection
@@ -4900,7 +4898,7 @@ tools like SSH (Secure Shell) to reach the outside world.")
(define-public stunnel
(package
(name "stunnel")
- (version "5.45")
+ (version "5.46")
(source
(origin
(method url-fetch)
@@ -4908,7 +4906,7 @@ tools like SSH (Secure Shell) to reach the outside world.")
version ".tar.gz"))
(sha256
(base32
- "1qrfb418skdcm7b3v30ixng1ng907f4rfv54zvgz8jwakf1l90jl"))))
+ "1iw4gap9ysag8iww2ik029scmdllk7jdzcpnnbj7hgbl526b9akn"))))
(build-system gnu-build-system)
(inputs `(("openssl" ,openssl)))
(arguments
@@ -5237,12 +5235,12 @@ command-line arguments or read from stdin.")
(add-installed-pythonpath inputs outputs)
(setenv "PATH" (string-append (assoc-ref outputs "out") "/bin"
":" (getenv "PATH")))
- (zero? (system* "py.test" "-v" "-k"
- (string-append
- ;; These tests attempt to make a connection to
- ;; an external web service.
- "not test_get_item_with_kwargs"
- " and not test_ia"))))))))
+ (invoke "py.test" "-v" "-k"
+ (string-append
+ ;; These tests attempt to make a connection to
+ ;; an external web service.
+ "not test_get_item_with_kwargs"
+ " and not test_ia")))))))
(propagated-inputs
`(("python-requests" ,python-requests)
("python-jsonpatch" ,python-jsonpatch-0.4)
@@ -5303,14 +5301,15 @@ internetarchive python module for programatic access to archive.org.")
(modify-phases %standard-phases
(add-after 'unpack 'get-tests
(lambda _
- (copy-file (assoc-ref %build-inputs "test-clf") "test_clf.py")))
+ (copy-file (assoc-ref %build-inputs "test-clf") "test_clf.py")
+ #t))
(replace 'check
(lambda _
- (zero? (system* "nosetests"
- ;; These tests require internet connection
- "--exclude=test_browse"
- "--exclude=test_command"
- "--exclude=test_search")))))))
+ (invoke "nosetests"
+ ;; These tests require an Internet connection.
+ "--exclude=test_browse"
+ "--exclude=test_command"
+ "--exclude=test_search"))))))
(home-page "https://github.com/ncrocfer/clf")
(synopsis "Search code snippets on @url{https://commandlinefu.com}")
(description "@code{clf} is a command line tool for searching code
@@ -5545,8 +5544,7 @@ named elements: the @code{status}, the @code{headers}, and the @code{body}.")
%build-inputs))
(mkdir-p share-rss-bridge)
(invoke "tar" "xvf" (assoc-ref %build-inputs "source")
- "--strip-components" "1" "-C" share-rss-bridge)
- #t))))
+ "--strip-components" "1" "-C" share-rss-bridge)))))
(home-page "https://github.com/RSS-Bridge/rss-bridge")
(synopsis "Generate Atom feeds for social networking websites")
(description "rss-bridge generates Atom feeds for social networking