aboutsummaryrefslogtreecommitdiff
path: root/gnu/packages
diff options
context:
space:
mode:
authorNicolas Goaziou <mail@nicolasgoaziou.fr>2023-05-14 10:28:34 +0200
committerNicolas Goaziou <mail@nicolasgoaziou.fr>2023-07-18 18:10:55 +0200
commit06bc5b28b0f512b5f1c05e680d9db73334a33c46 (patch)
tree280202d8c42c7c3d07a90b8729459ba660dc8d27 /gnu/packages
parentc81b4d6002d6942ffb24dc824eb47f9b3fe6d79e (diff)
downloadguix-06bc5b28b0f512b5f1c05e680d9db73334a33c46.tar
guix-06bc5b28b0f512b5f1c05e680d9db73334a33c46.tar.gz
gnu: texlive-latex-threeparttable -> texlive-threeparttable.
* gnu/packages/tex.scm (texlive-threeparttable): New variable. (texlive-latex-threeparttable): Deprecate variable. * gnu/packages/cran.scm (r-prereg)[propagated-inputs]: Use new name. Re-order alphabetically.
Diffstat (limited to 'gnu/packages')
-rw-r--r--gnu/packages/cran.scm56
-rw-r--r--gnu/packages/tex.scm39
2 files changed, 42 insertions, 53 deletions
diff --git a/gnu/packages/cran.scm b/gnu/packages/cran.scm
index 2ef6da13f6..c4276ea147 100644
--- a/gnu/packages/cran.scm
+++ b/gnu/packages/cran.scm
@@ -36179,40 +36179,40 @@ package online.")
(name "r-prereg")
(version "0.6.0")
(source
- (origin
- (method url-fetch)
- (uri (cran-uri "prereg" version))
- (sha256
- (base32
- "039nrl5cirsx1ysh214dr6xnn1h6h3f90im6k9dgmzfksxdqigpw"))))
+ (origin
+ (method url-fetch)
+ (uri (cran-uri "prereg" version))
+ (sha256
+ (base32
+ "039nrl5cirsx1ysh214dr6xnn1h6h3f90im6k9dgmzfksxdqigpw"))))
(properties `((upstream-name . "prereg")))
(build-system r-build-system)
(propagated-inputs
- (list r-rmarkdown
- ;; The package provides a custom LaTex template in
- ;; inst/rmd/prereg_form.tex, which depends on these packages:
- texlive-amsmath
- texlive-booktabs
- texlive-etoolbox
- texlive-iftex
- texlive-fancyhdr
- texlive-fancyvrb
- texlive-geometry
- texlive-graphics
- texlive-latex-threeparttable
- texlive-titlesec
- texlive-upquote
- texlive-listings
- texlive-polyglossia
- texlive-titling
- texlive-tools
- texlive-ulem
- (texlive-updmap.cfg (list texlive-amsfonts texlive-lm))))
+ (list r-rmarkdown
+ ;; The package provides a custom LaTex template in
+ ;; inst/rmd/prereg_form.tex, which depends on these packages:
+ texlive-amsmath
+ texlive-booktabs
+ texlive-etoolbox
+ texlive-fancyhdr
+ texlive-fancyvrb
+ texlive-geometry
+ texlive-graphics
+ texlive-iftex
+ texlive-listings
+ texlive-polyglossia
+ texlive-threeparttable
+ texlive-titlesec
+ texlive-titling
+ texlive-tools
+ texlive-ulem
+ texlive-upquote
+ (texlive-updmap.cfg (list texlive-amsfonts texlive-lm))))
(home-page "https://github.com/crsh/prereg")
(synopsis
- "R Markdown Templates to preregister Scientific Studies")
+ "R Markdown Templates to preregister Scientific Studies")
(description
- "This package provides a collection of templates to author
+ "This package provides a collection of templates to author
preregistration documents for scientific studies in PDF format.")
(license license:gpl3)))
diff --git a/gnu/packages/tex.scm b/gnu/packages/tex.scm
index 65bbd125da..7b46971bc8 100644
--- a/gnu/packages/tex.scm
+++ b/gnu/packages/tex.scm
@@ -7683,33 +7683,22 @@ according to the natural width of the widest cell in the column.")
(define-deprecated-package texlive-latex-tabulary texlive-tabulary)
-(define-public texlive-latex-threeparttable
+(define-public texlive-threeparttable
(package
- (name "texlive-latex-threeparttable")
+ (name "texlive-threeparttable")
(version (number->string %texlive-revision))
- (source (origin
- (method svn-fetch)
- (uri (svn-reference
- (url (string-append "svn://www.tug.org/texlive/tags/"
- %texlive-tag "/Master/texmf-dist/"
- "/tex/latex/threeparttable"))
- (revision %texlive-revision)))
- (file-name (string-append name "-" version "-checkout"))
- (sha256
- (base32
- "10vy9k150w2lviw8h22s2mcykff38xci653m5823s2vv44pwbmzq"))))
- (build-system trivial-build-system)
- (arguments
- `(#:modules ((guix build utils))
- #:builder
- (begin
- (use-modules (guix build utils))
- (let ((target (string-append (assoc-ref %outputs "out")
- "/share/texmf-dist/tex/latex/threeparttable")))
- (mkdir-p target)
- (copy-recursively (assoc-ref %build-inputs "source") target)
- #t))))
- (home-page "https://www.ctan.org/pkg/threeparttable")
+ (source (texlive-origin
+ name version
+ (list "doc/latex/threeparttable/"
+ "tex/latex/threeparttable/")
+ (base32
+ "05i50k1y736m52903nz4kf2xl23w6y7rrzyacs4kgd1w6kmjm6f7")))
+ (outputs '("out" "doc"))
+ (build-system texlive-build-system)
+ (propagated-inputs
+ (list texlive-bookmark
+ texlive-hyperref))
+ (home-page "https://ctan.org/pkg/threeparttable")
(synopsis "Tables with captions and notes all the same width")
(description
"This package facilitates tables with titles (captions) and notes. The