aboutsummaryrefslogtreecommitdiff
path: root/gnu/packages
diff options
context:
space:
mode:
authorSharlatan Hellseher <sharlatanus@gmail.com>2024-07-19 22:24:25 +0100
committerSharlatan Hellseher <sharlatanus@gmail.com>2024-07-25 21:00:58 +0100
commit058e0cc75a2cb7dc81386b994084f162e75cb552 (patch)
tree4a908a018e1d466e723576f0355fa0cb5829ba13 /gnu/packages
parentbdff9d26423a62f246882a46c5440c144c54910c (diff)
downloadguix-058e0cc75a2cb7dc81386b994084f162e75cb552.tar
guix-058e0cc75a2cb7dc81386b994084f162e75cb552.tar.gz
gnu: go-github-com-google-go-cmp-cmp: Rename variable.
* gnu/packages/golang.scm (go-github-com-google-go-cmp-cmp): Rename variable to go-github-com-google-go-cmp, which reflects go.mod import path and improves importer performance. (go-github-com-zclconf-go-cty, go-golang-org-x-vuln, go-google-golang-org-protobuf, go-gotest-tools-assert, go-gotest-tools-internal-source, go-gotest-tools-internal-format, gofumpt, gopls, gotestsum): Swap go-github-com-google-go-cmp-cmp to go-github-com-google-go-cmp in inputs, propagated-inputs or native-inputs. * gnu/packages/golang-check.scm (go-github-com-frankban-quicktest, go-github-com-google-go-cmdtest): Likewise. * gnu/packages/golang-web.scm (go-github-com-aws-aws-sdk-go-v2, go-github-com-aws-aws-sdk-go-v2-config, go-github-com-aws-smithy-go, go-github-com-go-jose-go-jose-v3, go-github-com-makeworld-the-better-one-go-gemini, go-golang-org-x-oauth2, go-gopkg-in-square-go-jose-v2): Likewise. * gnu/packages/golang-xyz.scm (go-github-com-goccy-go-yaml): Likewise. * gnu/packages/check.scm (actionlint): Likewise. * gnu/packages/databases.scm (sqls): Likewise. * gnu/packages/ipfs.scm (go-github-com-ipld-go-ipld-prime, go-github-com-whyrusleeping-cbor-gen): Likewise. * gnu/packages/web.scm (go-github-com-itchyny-gojq): Likewise. Change-Id: Ie6eeba936f7da404d70fbbaad34f5b43aec4e05b
Diffstat (limited to 'gnu/packages')
-rw-r--r--gnu/packages/check.scm2
-rw-r--r--gnu/packages/databases.scm2
-rw-r--r--gnu/packages/golang-check.scm4
-rw-r--r--gnu/packages/golang-web.scm12
-rw-r--r--gnu/packages/golang-xyz.scm2
-rw-r--r--gnu/packages/golang.scm24
-rw-r--r--gnu/packages/ipfs.scm4
-rw-r--r--gnu/packages/web.scm2
8 files changed, 26 insertions, 26 deletions
diff --git a/gnu/packages/check.scm b/gnu/packages/check.scm
index 412b94569c..4faa8102fd 100644
--- a/gnu/packages/check.scm
+++ b/gnu/packages/check.scm
@@ -1144,7 +1144,7 @@ but it works for any C/C++ project.")
go-golang-org-x-sync
go-golang-org-x-sync
go-gopkg-in-yaml-v3))
- (native-inputs (list go-github-com-google-go-cmp-cmp))
+ (native-inputs (list go-github-com-google-go-cmp))
(home-page "https://rhysd.github.io/actionlint/")
(synopsis "Static checker for GitHub Actions workflow files")
(description
diff --git a/gnu/packages/databases.scm b/gnu/packages/databases.scm
index 96a59e8024..2532586bc5 100644
--- a/gnu/packages/databases.scm
+++ b/gnu/packages/databases.scm
@@ -5506,7 +5506,7 @@ compatible with SQLite using a graphical user interface.")
#:install-source? #f
#:import-path "github.com/lighttiger2505/sqls"))
(native-inputs
- (list go-github-com-google-go-cmp-cmp
+ (list go-github-com-google-go-cmp
go-github-com-go-sql-driver-mysql
go-github-com-k0kubun-pp
go-github-com-lib-pq
diff --git a/gnu/packages/golang-check.scm b/gnu/packages/golang-check.scm
index 0822338943..4323a6c557 100644
--- a/gnu/packages/golang-check.scm
+++ b/gnu/packages/golang-check.scm
@@ -301,7 +301,7 @@ workloads. This kind of profiling is also known as wall-clock profiling.")
(arguments
'(#:import-path "github.com/frankban/quicktest"))
(propagated-inputs
- (list go-github-com-google-go-cmp-cmp go-github-com-kr-pretty))
+ (list go-github-com-google-go-cmp go-github-com-kr-pretty))
(home-page "https://github.com/frankban/quicktest")
(synopsis "Quick helpers for testing Go applications")
(description
@@ -376,7 +376,7 @@ when comparing complex types like structures and maps.")
(arguments
'(#:import-path "github.com/google/go-cmdtest"))
(propagated-inputs
- (list go-github-com-google-renameio go-github-com-google-go-cmp-cmp))
+ (list go-github-com-google-renameio go-github-com-google-go-cmp))
(home-page "https://github.com/google/go-cmdtest")
(synopsis "Testing for your CLI")
(description
diff --git a/gnu/packages/golang-web.scm b/gnu/packages/golang-web.scm
index a21339adb2..f8862ddd10 100644
--- a/gnu/packages/golang-web.scm
+++ b/gnu/packages/golang-web.scm
@@ -300,7 +300,7 @@ connections from a single physical connection.")
'(#:import-path "github.com/aws/aws-sdk-go-v2"))
(propagated-inputs
(list go-github-com-aws-smithy-go
- go-github-com-google-go-cmp-cmp
+ go-github-com-google-go-cmp
go-github-com-jmespath-go-jmespath))
(home-page "https://github.com/aws/aws-sdk-go-v2")
(synopsis "AWS SDK for Go v2")
@@ -317,7 +317,7 @@ connections from a single physical connection.")
'(#:import-path "github.com/aws/aws-sdk-go-v2/config"
#:unpack-path "github.com/aws/aws-sdk-go-v2"))
(propagated-inputs
- (list go-github-com-google-go-cmp-cmp
+ (list go-github-com-google-go-cmp
go-github-com-aws-smithy-go))))
(define-public go-github-com-aws-aws-sdk-go-v2-feature-s3-manager
@@ -402,7 +402,7 @@ connections from a single physical connection.")
(arguments
'(#:import-path "github.com/aws/smithy-go"))
(propagated-inputs
- (list go-github-com-jmespath-go-jmespath go-github-com-google-go-cmp-cmp))
+ (list go-github-com-jmespath-go-jmespath go-github-com-google-go-cmp))
(home-page "https://github.com/aws/smithy-go")
(synopsis "@url{https://smithy.io/2.0/index.html,Smithy} code generators
for Go")
@@ -812,7 +812,7 @@ decompose request handling into many smaller layers.")
(propagated-inputs
(list go-golang-org-x-crypto))
(native-inputs
- (list go-github-com-google-go-cmp-cmp
+ (list go-github-com-google-go-cmp
go-github-com-stretchr-testify))
(home-page "https://github.com/go-jose/go-jose")
(synopsis "Implementation of JOSE standards (JWE, JWS, JWT) in Go")
@@ -1673,7 +1673,7 @@ router.")
(base32 "196rxfg7w8s3zn87gra1mxh1l8iav6kdmg909gkbnc9cxip65zc0"))))
(build-system go-build-system)
(propagated-inputs
- (list go-github-com-google-go-cmp-cmp
+ (list go-github-com-google-go-cmp
go-golang-org-x-net
go-golang-org-x-text))
(arguments
@@ -3287,7 +3287,7 @@ programming language, which supports draft-04, draft-06 and draft-07.")
(propagated-inputs
(list go-golang-org-x-crypto))
(native-inputs
- (list go-github-com-google-go-cmp-cmp
+ (list go-github-com-google-go-cmp
go-github-com-stretchr-testify))
(home-page "https://gopkg.in/square/go-jose.v2")
(synopsis "Implementation of JOSE standards (JWE, JWS, JWT) in Go")
diff --git a/gnu/packages/golang-xyz.scm b/gnu/packages/golang-xyz.scm
index 6560f43578..ebce00f117 100644
--- a/gnu/packages/golang-xyz.scm
+++ b/gnu/packages/golang-xyz.scm
@@ -2154,7 +2154,7 @@ the library more lightweight.")
(invoke "go" "test" "-v" "./..."))))))))
(native-inputs
(list go-github-com-go-playground-validator-v10
- go-github-com-google-go-cmp-cmp))
+ go-github-com-google-go-cmp))
(propagated-inputs
(list go-github-com-fatih-color
go-golang-org-x-xerrors))
diff --git a/gnu/packages/golang.scm b/gnu/packages/golang.scm
index 6bc9b3a6d5..ac626aee16 100644
--- a/gnu/packages/golang.scm
+++ b/gnu/packages/golang.scm
@@ -3188,7 +3188,7 @@ command-line parsers.")
"./scan/..."))))))))
(propagated-inputs
(list go-github-com-google-go-cmdtest
- go-github-com-google-go-cmp-cmp
+ go-github-com-google-go-cmp
go-golang-org-x-exp
go-golang-org-x-mod
go-golang-org-x-sync
@@ -3240,7 +3240,7 @@ the @url{https://vuln.go.dev,Go Vulnerability Database}.")
(lambda _
(delete-file-recursively "src/golang.org/x/tools"))))))
(native-inputs
- (list go-github-com-google-go-cmp-cmp
+ (list go-github-com-google-go-cmp
go-github-com-jba-printsrc
go-github-com-jba-templatecheck
go-github-com-sergi-go-diff
@@ -5929,9 +5929,9 @@ filters for Go.")
@code{mbox} files.")
(license license:expat)))
-(define-public go-github-com-google-go-cmp-cmp
+(define-public go-github-com-google-go-cmp
(package
- (name "go-github-com-google-go-cmp-cmp")
+ (name "go-github-com-google-go-cmp")
(version "0.6.0")
(source
(origin
@@ -6118,7 +6118,7 @@ create or replace a file or symbolic link.")
(define-public go-gotest-tools-internal-format
(package (inherit (go-gotest-tools-package "internal/format"))
(native-inputs
- (list go-github-com-pkg-errors go-github-com-google-go-cmp-cmp))
+ (list go-github-com-pkg-errors go-github-com-google-go-cmp))
(synopsis "Formats messages for use with gotest-tools")
(description "This package provides a way to format messages for use
with gotest-tools.")))
@@ -6143,7 +6143,7 @@ with gotest-tools.")))
(false-if-exception (search-input-file inputs "/bin/gccgo"))
(apply (assoc-ref %standard-phases 'check) args))))))))
(native-inputs
- (list go-github-com-pkg-errors go-github-com-google-go-cmp-cmp))
+ (list go-github-com-pkg-errors go-github-com-google-go-cmp))
(synopsis "Source code AST formatters for gotest-tools")
(description "This package provides source code AST formatters for
gotest-tools.")))
@@ -6156,7 +6156,7 @@ gotest-tools.")))
#:import-path "gotest.tools/assert"
#:unpack-path "gotest.tools"))
(propagated-inputs
- (list go-github-com-google-go-cmp-cmp
+ (list go-github-com-google-go-cmp
go-github-com-pkg-errors
go-github-com-spf13-pflag
go-golang-org-x-tools))
@@ -6191,14 +6191,14 @@ test when a comparison fails.")
go-github-com-jonboulle-clockwork
go-golang-org-x-crypto
go-gotest-tools-assert
- go-github-com-google-go-cmp-cmp
+ go-github-com-google-go-cmp
;; TODO: This would be better as a propagated-input of
;; go-gotest-tools-assert, but that does not work for
;; some reason.
go-gotest-tools-internal-format
go-gotest-tools-internal-difflib
go-gotest-tools-internal-source
- go-github-com-google-go-cmp-cmp))
+ go-github-com-google-go-cmp))
(synopsis "Go test runner with output optimized for humans")
(description "This package provides a @code{go test} runner with output
optimized for humans, JUnit XML for CI integration, and a summary of the
@@ -6278,7 +6278,7 @@ data serialization format.")
(when tests?
(with-directory-excursion (string-append "src/" import-path)
(invoke "go" "test" "-v" "./..."))))))))
- (propagated-inputs (list go-github-com-google-go-cmp-cmp))
+ (propagated-inputs (list go-github-com-google-go-cmp))
(home-page "https://google.golang.org/protobuf")
(synopsis "Go library for Protocol Buffers")
(description
@@ -7632,7 +7632,7 @@ deleting secrets from the system keyring.")
'(#:unpack-path "github.com/zclconf/go-cty"
#:import-path "github.com/zclconf/go-cty/cty"))
(native-inputs
- (list go-github-com-google-go-cmp-cmp))
+ (list go-github-com-google-go-cmp))
(propagated-inputs
(list go-golang-org-x-text
go-github-com-vmihailenco-msgpack-v4
@@ -8032,7 +8032,7 @@ Gemini clients and servers.")
go-golang-org-x-sync
go-golang-org-x-mod
go-github-com-rogpeppe-go-internal
- go-github-com-google-go-cmp-cmp
+ go-github-com-google-go-cmp
go-github-com-frankban-quicktest))
(home-page "https://mvdan.cc/gofumpt/")
(synopsis "Formats Go files with a stricter ruleset than gofmt")
diff --git a/gnu/packages/ipfs.scm b/gnu/packages/ipfs.scm
index 55c10724c4..887654ec28 100644
--- a/gnu/packages/ipfs.scm
+++ b/gnu/packages/ipfs.scm
@@ -606,7 +606,7 @@ and @code{go-ipld-format} legacy interface.")
go-github-com-warpfork-go-testmark
specification-ipld))
(propagated-inputs
- (list go-github-com-google-go-cmp-cmp
+ (list go-github-com-google-go-cmp
go-github-com-ipfs-go-block-format
go-github-com-ipfs-go-cid
go-github-com-multiformats-go-multicodec
@@ -799,7 +799,7 @@ daemon as described in
#:import-path "github.com/whyrusleeping/cbor-gen"))
(propagated-inputs
(list go-github-com-ipfs-go-cid
- go-github-com-google-go-cmp-cmp
+ go-github-com-google-go-cmp
go-golang-org-x-xerrors))
(home-page "https://github.com/whyrusleeping/cbor-gen")
(synopsis "Codegen for CBOR codecs on the specified types")
diff --git a/gnu/packages/web.scm b/gnu/packages/web.scm
index e406e6e968..eb6699c3a1 100644
--- a/gnu/packages/web.scm
+++ b/gnu/packages/web.scm
@@ -5531,7 +5531,7 @@ time strings.")
(base32 "1dqmnxnipi497nx9x10ifack09w41579svryss5q2w5wxy0pg764"))))
(build-system go-build-system)
(inputs
- (list go-github-com-google-go-cmp-cmp
+ (list go-github-com-google-go-cmp
go-github-com-itchyny-timefmt-go
go-github-com-mattn-go-isatty
go-github-com-mattn-go-runewidth