aboutsummaryrefslogtreecommitdiff
path: root/gnu/packages
diff options
context:
space:
mode:
authorSharlatan Hellseher <sharlatanus@gmail.com>2024-07-25 10:47:42 +0100
committerSharlatan Hellseher <sharlatanus@gmail.com>2024-07-25 21:00:57 +0100
commit04af4f6646ec4949b716240e3a8b8153b2e1cb42 (patch)
tree1aa150f2221dabd9b42ca2f70d4ab72c44cb070b /gnu/packages
parent162f716d74c53ce6b7ea885895bfb884dde5b48d (diff)
downloadguix-04af4f6646ec4949b716240e3a8b8153b2e1cb42.tar
guix-04af4f6646ec4949b716240e3a8b8153b2e1cb42.tar.gz
gnu: go-golang-org-x-oauth2: Move to golang-web.
* gnu/packages/golang.scm (go-golang-org-x-oauth2): Move from here ... * gnu/packages/golang-web.scm: ... to here. Change-Id: I60fd46f5c373ccdb00c78c978a840acfe9f489b1
Diffstat (limited to 'gnu/packages')
-rw-r--r--gnu/packages/golang-web.scm29
-rw-r--r--gnu/packages/golang.scm27
2 files changed, 28 insertions, 28 deletions
diff --git a/gnu/packages/golang-web.scm b/gnu/packages/golang-web.scm
index a9658cfbac..a9213f1be8 100644
--- a/gnu/packages/golang-web.scm
+++ b/gnu/packages/golang-web.scm
@@ -3,9 +3,9 @@
;;; Copyright © 2018 Pierre Neidhardt <mail@ambrevar.xyz>
;;; Copyright © 2018 Pierre-Antoine Rouby <pierre-antoine.rouby@inria.fr>
;;; Copyright © 2019 Vagrant Cascadian <vagrant@debian.org>
+;;; Copyright © 2019, 2020 Martin Becze <mjbecze@riseup.net>
;;; Copyright © 2020 Jack Hill <jackhill@jackhill.us>
;;; Copyright © 2020 Joseph LaFreniere <joseph@lafreniere.xyz>
-;;; Copyright © 2020 Martin Becze <mjbecze@riseup.net>
;;; Copyright © 2020 Nicolas Goaziou <mail@nicolasgoaziou.fr>
;;; Copyright © 2020 Oleg Pykhalov <go.wigust@gmail.com>
;;; Copyright © 2020 Ryan Prior <rprior@protonmail.com>
@@ -3224,6 +3224,33 @@ programming language.")
programming language, which supports draft-04, draft-06 and draft-07.")
(license license:asl2.0))))
+(define-public go-golang-org-x-oauth2
+ (package
+ (name "go-golang-org-x-oauth2")
+ (version "0.21.0")
+ (source
+ (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://go.googlesource.com/oauth2")
+ (commit (string-append "v" version))))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32 "0pzpa9jqrfxxhxi1w7n5ljnvr9qfw42hzavz62fc9i6z9vk2466k"))))
+ (build-system go-build-system)
+ (arguments
+ (list
+ #:import-path "golang.org/x/oauth2"))
+ (propagated-inputs
+ (list go-cloud-google-com-go-compute-metadata
+ go-github-com-google-go-cmp))
+ (home-page "https://go.googlesource.com/oauth2")
+ (synopsis "Client implementation of the OAuth 2.0 spec")
+ (description
+ "This package contains a client implementation for OAuth 2.0
+ spec in Go.")
+ (license license:bsd-3)))
+
;; XXX: This repository has been archived by the owner on Feb 27, 2023. It is
;; now read-only and it is DEPRECATED.
(define-public go-gopkg-in-square-go-jose-v2
diff --git a/gnu/packages/golang.scm b/gnu/packages/golang.scm
index 4426fc4721..60a2b4de40 100644
--- a/gnu/packages/golang.scm
+++ b/gnu/packages/golang.scm
@@ -3262,33 +3262,6 @@ developed by the Go team. It provides IDE features to any LSP-compatible
editor.")
(license license:bsd-3)))
-(define-public go-golang-org-x-oauth2
- (package
- (name "go-golang-org-x-oauth2")
- (version "0.21.0")
- (source
- (origin
- (method git-fetch)
- (uri (git-reference
- (url "https://go.googlesource.com/oauth2")
- (commit (string-append "v" version))))
- (file-name (git-file-name name version))
- (sha256
- (base32 "0pzpa9jqrfxxhxi1w7n5ljnvr9qfw42hzavz62fc9i6z9vk2466k"))))
- (build-system go-build-system)
- (arguments
- (list
- #:import-path "golang.org/x/oauth2"))
- (propagated-inputs
- (list go-cloud-google-com-go-compute-metadata
- go-github-com-google-go-cmp-cmp))
- (home-page "https://go.googlesource.com/oauth2")
- (synopsis "Client implementation of the OAuth 2.0 spec")
- (description
- "This package contains a client implementation for OAuth 2.0
- spec in Go.")
- (license license:bsd-3)))
-
(define-public go-github-com-jpillora-backoff
(let ((commit
"06c7a16c845dc8e0bf575fafeeca0f5462f5eb4d")