aboutsummaryrefslogtreecommitdiff
path: root/gnu/packages/xorg.scm
diff options
context:
space:
mode:
authorZheng Junjie <zhengjunjie@iscas.ac.cn>2023-12-28 22:26:21 +0800
committerMathieu Othacehe <othacehe@gnu.org>2023-12-29 19:48:16 +0100
commitc5c28df899b4c4f114bee9afd58dbde9fbbf3424 (patch)
treeb949f7363360b8bc787ae4490d2e56f58013bb76 /gnu/packages/xorg.scm
parent2911aaa9ae54cf86d2a776c441f3559d4a838f16 (diff)
downloadguix-c5c28df899b4c4f114bee9afd58dbde9fbbf3424.tar
guix-c5c28df899b4c4f114bee9afd58dbde9fbbf3424.tar.gz
gnu: xcb-util-renderutil: Fix cross-compiling to riscv64-linux.
* gnu/packages/xorg.scm (xcb-util-renderutil) [native-inputs]: When cross compiling to riscv64-linux-gnu, add config. [arguments]: When target riscv64-linux-gnu, add update-config-scripts phase. Change-Id: I906a2b7b7691ae53592cfa35ba64fc7e7d735664 Signed-off-by: Mathieu Othacehe <othacehe@gnu.org>
Diffstat (limited to 'gnu/packages/xorg.scm')
-rw-r--r--gnu/packages/xorg.scm22
1 files changed, 20 insertions, 2 deletions
diff --git a/gnu/packages/xorg.scm b/gnu/packages/xorg.scm
index 382075237a..4f85a5de8b 100644
--- a/gnu/packages/xorg.scm
+++ b/gnu/packages/xorg.scm
@@ -5675,11 +5675,29 @@ The XCB util-keysyms module provides the following library:
"0nza1csdvvxbmk8vgv8vpmq7q8h05xrw3cfx9lwxd1hjzd47xsf6"))))
(build-system gnu-build-system)
(arguments
- '(#:configure-flags '("--disable-static")))
+ `(#:configure-flags '("--disable-static")
+ ,@(if (and (%current-target-system)
+ (target-riscv64?))
+ `(#:phases
+ (modify-phases %standard-phases
+ (add-after 'unpack 'update-config-scripts
+ (lambda* (#:key inputs native-inputs #:allow-other-keys)
+ ;; Replace outdated config.guess and config.sub.
+ (for-each (lambda (file)
+ (install-file
+ (search-input-file
+ (or native-inputs inputs)
+ (string-append "/bin/" file)) "."))
+ '("config.guess" "config.sub"))))))
+ '())))
(propagated-inputs
(list libxcb))
(native-inputs
- (list pkg-config))
+ (append (if (and (%current-target-system)
+ (target-riscv64?))
+ (list config)
+ '())
+ (list pkg-config)))
(home-page "https://cgit.freedesktop.org/xcb/util-renderutil/")
(synopsis "Convenience functions for the Render extension")
(description