aboutsummaryrefslogtreecommitdiff
path: root/gnu/packages/xml.scm
diff options
context:
space:
mode:
authorMarius Bakke <marius@gnu.org>2022-06-27 20:41:58 +0200
committerMarius Bakke <marius@gnu.org>2022-06-27 23:48:00 +0200
commite437393b01ca0a049ae5276ffa77363026949d38 (patch)
tree58df14cb37f80f6600c2d0e6fe3a0b5469e82dad /gnu/packages/xml.scm
parente51c78d5605da114389cb992666829b1f3d82da6 (diff)
downloadguix-e437393b01ca0a049ae5276ffa77363026949d38.tar
guix-e437393b01ca0a049ae5276ffa77363026949d38.tar.gz
gnu: python-libxml2: Remove input labels.
* gnu/packages/xml.scm (python-libxml2)[arguments]: Use G-expression. Remove iconv header substitution which is no longer needed. [inputs]: Remove labels.
Diffstat (limited to 'gnu/packages/xml.scm')
-rw-r--r--gnu/packages/xml.scm32
1 files changed, 16 insertions, 16 deletions
diff --git a/gnu/packages/xml.scm b/gnu/packages/xml.scm
index 0e0d714a1c..3868be388f 100644
--- a/gnu/packages/xml.scm
+++ b/gnu/packages/xml.scm
@@ -263,22 +263,22 @@ to output XPath results with a null delimiter.")))
(build-system python-build-system)
(outputs '("out"))
(arguments
- `(;; XXX: Tests are specified in 'Makefile.am', but not in 'setup.py'.
- #:tests? #f
- #:phases
- (modify-phases %standard-phases
- (add-before
- 'build 'configure
- (lambda* (#:key inputs #:allow-other-keys)
- (chdir "python")
- (let ((glibc (assoc-ref inputs ,(if (%current-target-system)
- "cross-libc" "libc")))
- (libxml2 (assoc-ref inputs "libxml2")))
- (substitute* "setup.py"
- ;; For libxml2 headers.
- (("/opt/include")
- (string-append libxml2 "/include")))))))))
- (inputs `(("libxml2" ,libxml2)))
+ (list
+ ;; XXX: Tests are specified in 'Makefile.am', but not in 'setup.py'.
+ #:tests? #f
+ #:phases
+ #~(modify-phases %standard-phases
+ (add-before 'build 'configure
+ (lambda* (#:key inputs #:allow-other-keys)
+ (chdir "python")
+ (let ((libxml2-headers (search-input-directory
+ inputs "include/libxml2")))
+ (substitute* "setup.py"
+ ;; The build system ignores C_INCLUDE_PATH & co, so
+ ;; provide the absolute directory name.
+ (("/opt/include")
+ (dirname libxml2-headers)))))))))
+ (inputs (list libxml2))
(synopsis "Python bindings for the libxml2 library")))
(define-public libxlsxwriter