aboutsummaryrefslogtreecommitdiff
path: root/gnu/packages/xml.scm
diff options
context:
space:
mode:
authorMaxim Cournoyer <maxim.cournoyer@gmail.com>2022-04-29 23:50:41 -0400
committerMaxim Cournoyer <maxim.cournoyer@gmail.com>2022-05-31 14:53:42 -0400
commit709c0244e45ddfd19cfb318ab63a04c220b33eb7 (patch)
treea1faf1bef1c0d791c9a576a17063155422eda3e6 /gnu/packages/xml.scm
parentf162273a2cb730526785ca5edd55b52c82a2ea91 (diff)
downloadguix-709c0244e45ddfd19cfb318ab63a04c220b33eb7.tar
guix-709c0244e45ddfd19cfb318ab63a04c220b33eb7.tar.gz
gnu: xlsx2csv: Update to 0.7.8.
* gnu/packages/xml.scm (xlsx2csv): Update to 0.7.8. [python]: Delete argument.
Diffstat (limited to 'gnu/packages/xml.scm')
-rw-r--r--gnu/packages/xml.scm12
1 files changed, 6 insertions, 6 deletions
diff --git a/gnu/packages/xml.scm b/gnu/packages/xml.scm
index 6dbcf67d8c..a9bf07de96 100644
--- a/gnu/packages/xml.scm
+++ b/gnu/packages/xml.scm
@@ -27,7 +27,7 @@
;;; Copyright © 2020 Brett Gilio <brettg@gnu.org>
;;; Copyright © 2020 Pierre Langlois <pierre.langlois@gmx.com>
;;; Copyright © 2021 Michael Rohleder <mike@rohleder.de>
-;;; Copyright © 2021 Maxim Cournoyer <maxim.cournoyer@gmail.com>
+;;; Copyright © 2021, 2022 Maxim Cournoyer <maxim.cournoyer@gmail.com>
;;; Copyright © 2021 Julien Lepiller <julien@lepiller.eu>
;;; Copyright © 2021 Felix Gruber <felgru@posteo.net>
;;; Copyright © 2021 Guillaume Le Vaillant <glv@posteo.net>
@@ -1421,7 +1421,7 @@ elements to their parents
(define-public xlsx2csv
(package
(name "xlsx2csv")
- (version "0.7.4")
+ (version "0.7.8")
(source
(origin
(method git-fetch)
@@ -1430,17 +1430,17 @@ elements to their parents
(commit version)))
(file-name (git-file-name name version))
(sha256
- (base32 "168dm6p7w6pvgd87yb9hcxv9y0liv6mxgril202nfva68cp8y939"))))
+ (base32 "1p10571295f8zw1lsma8k5z07hrk9aspar0lsz8zpgjl7v35zcq7"))))
(build-system python-build-system)
(arguments
- `(#:python ,python-2 ; use python-2 for the test script
- #:phases
+ `(#:phases
(modify-phases %standard-phases
(replace 'check
(lambda _
(substitute* "test/run"
;; Run tests with `python' only.
- (("^(PYTHON_VERSIONS = ).*" all m) (string-append m "['']")))
+ (("^(PYTHON_VERSIONS = ).*" all m)
+ (string-append m "['']")))
(invoke "test/run"))))))
(home-page "https://github.com/dilshod/xlsx2csv")
(synopsis "XLSX to CSV converter")