aboutsummaryrefslogtreecommitdiff
path: root/gnu/packages/xiph.scm
diff options
context:
space:
mode:
authorZheng Junjie <zhengjunjie@iscas.ac.cn>2024-03-05 01:19:35 +0800
committerLudovic Courtès <ludo@gnu.org>2024-03-06 23:25:51 +0100
commit64d269b983b76553466ac93945d58c7865cf190e (patch)
treebc19352ede6f6a7c6ab5dc0f00a8745d1d1a91b7 /gnu/packages/xiph.scm
parent5980c8a6b16dd589769ad7cd0bab82fcb9c116cb (diff)
downloadguix-64d269b983b76553466ac93945d58c7865cf190e.tar
guix-64d269b983b76553466ac93945d58c7865cf190e.tar.gz
gnu: libtheora: Fix cross-compiling to riscv64-linux.
* gnu/packages/xiph.scm (libtheora): [native-inputs]: When cross compiling to riscv64-linux-gnu, add config. [arguments]: When target riscv64-linux-gnu, add update-config phase. Change-Id: Ie055cd4f6cb9d2a4601b93d1f9db227598349c7c Signed-off-by: Ludovic Courtès <ludo@gnu.org>
Diffstat (limited to 'gnu/packages/xiph.scm')
-rw-r--r--gnu/packages/xiph.scm22
1 files changed, 21 insertions, 1 deletions
diff --git a/gnu/packages/xiph.scm b/gnu/packages/xiph.scm
index 879d8e8d39..f3603c39bb 100644
--- a/gnu/packages/xiph.scm
+++ b/gnu/packages/xiph.scm
@@ -46,6 +46,7 @@
#:use-module (gnu packages xml)
#:use-module ((guix licenses) #:prefix license:)
#:use-module (guix packages)
+ #:use-module (guix utils)
#:use-module (guix download)
#:use-module (guix git-download)
#:use-module (guix build-system gnu)
@@ -117,7 +118,26 @@ polyphonic) audio and music at fixed and variable bitrates from 16 to
(patches (search-patches "libtheora-config-guess.patch"))))
(build-system gnu-build-system)
(arguments
- (list #:configure-flags #~'("--disable-static")))
+ (append
+ (if (and (target-riscv64?)
+ (%current-target-system))
+ (list #:phases
+ #~(modify-phases %standard-phases
+ (add-after 'unpack 'update-config
+ (lambda* (#:key native-inputs inputs #:allow-other-keys)
+ (for-each (lambda (file)
+ (install-file
+ (search-input-file
+ (or native-inputs inputs)
+ (string-append "/bin/" file)) "."))
+ '("config.guess" "config.sub"))))))
+ '())
+ (list #:configure-flags #~'("--disable-static"))))
+ (native-inputs
+ (if (and (target-riscv64?)
+ (%current-target-system))
+ (list config)
+ '()))
(inputs (list libvorbis))
;; The .pc files refer to libogg.
(propagated-inputs (list libogg))