aboutsummaryrefslogtreecommitdiff
path: root/gnu/packages/xdisorg.scm
diff options
context:
space:
mode:
authorArtyom V. Poptsov <poptsov.artyom@gmail.com>2024-09-01 21:55:23 +0300
committerjgart <jgart@dismail.de>2024-09-04 09:03:12 -0500
commit9e89185d581959e796c4f5c52ef09cd83a5d3302 (patch)
tree0fbb4629e6e4e2725289120ddde1b8faf5bc9db9 /gnu/packages/xdisorg.scm
parent5b8d4074f406640f9246b0f92df1143ee3220549 (diff)
downloadguix-9e89185d581959e796c4f5c52ef09cd83a5d3302.tar
guix-9e89185d581959e796c4f5c52ef09cd83a5d3302.tar.gz
gnu: autorandr: Use GEXPs.
* gnu/packages/xdisorg.scm (autorandr): Use GEXPs. Change-Id: I476e29ddff17c0180e8a0eeefe818954364eac71 Signed-off-by: jgart <jgart@dismail.de>
Diffstat (limited to 'gnu/packages/xdisorg.scm')
-rw-r--r--gnu/packages/xdisorg.scm46
1 files changed, 23 insertions, 23 deletions
diff --git a/gnu/packages/xdisorg.scm b/gnu/packages/xdisorg.scm
index 8360f91ad4..c041ab1fc0 100644
--- a/gnu/packages/xdisorg.scm
+++ b/gnu/packages/xdisorg.scm
@@ -298,29 +298,29 @@ program.")
(inputs
(list xrandr libxcb))
(arguments
- `(#:phases
- (modify-phases %standard-phases
- (add-before 'build 'configure
- (lambda* (#:key inputs outputs #:allow-other-keys)
- (let ((xrandr (search-input-file inputs "/bin/xrandr")))
- (substitute* "contrib/etc/xdg/autostart/autorandr.desktop"
- (("/usr") (assoc-ref outputs "out")))
- (substitute* "autorandr.py"
- (("popen\\(\"xrandr") (string-append "popen(\"" xrandr))
- (("\\[\"xrandr") (string-append "[\"" xrandr)))
- (substitute* "contrib/autorandr_launcher/autorandr_launcher.c"
- (("/usr/bin/autorandr")
- (string-append (assoc-ref outputs "out") "/bin/autorandr")))
- (setenv "CC" "gcc"))
- #t))
- (add-after 'install 'install-contrib
- (lambda* (#:key outputs #:allow-other-keys)
- (invoke "make"
- (string-append "DESTDIR=" (assoc-ref outputs "out"))
- "PREFIX="
- "BASH_COMPLETIONS_DIR=etc/bash_completion.d"
- "install"
- "TARGETS=autorandr launcher manpage bash_completion"))))))
+ (list
+ #:phases
+ #~(modify-phases %standard-phases
+ (add-before 'build 'configure
+ (lambda* (#:key inputs outputs #:allow-other-keys)
+ (let ((xrandr (search-input-file inputs "/bin/xrandr")))
+ (substitute* "contrib/etc/xdg/autostart/autorandr.desktop"
+ (("/usr") #$output))
+ (substitute* "autorandr.py"
+ (("popen\\(\"xrandr") (string-append "popen(\"" xrandr))
+ (("\\[\"xrandr") (string-append "[\"" xrandr)))
+ (substitute* "contrib/autorandr_launcher/autorandr_launcher.c"
+ (("/usr/bin/autorandr")
+ (string-append #$output "/bin/autorandr")))
+ (setenv "CC" "gcc"))))
+ (add-after 'install 'install-contrib
+ (lambda* (#:key outputs #:allow-other-keys)
+ (invoke "make"
+ (string-append "DESTDIR=" #$output)
+ "PREFIX="
+ "BASH_COMPLETIONS_DIR=etc/bash_completion.d"
+ "install"
+ "TARGETS=autorandr launcher manpage bash_completion"))))))
(synopsis "Auto-detect connected displays and load appropriate setup")
(description "Autorandr wraps around xrandr to help with X11
multi-screen configuration management. It allows the user to create profiles