aboutsummaryrefslogtreecommitdiff
path: root/gnu/packages/xdisorg.scm
diff options
context:
space:
mode:
authorJosh Holland <josh@inv.alid.pw>2019-10-30 13:08:36 +0000
committerLudovic Courtès <ludo@gnu.org>2019-11-16 17:43:49 +0100
commit264a63d6435fe832169eedda3f03c334ea573001 (patch)
treeb4043046880b74d0a15b07292f71634a1583b463 /gnu/packages/xdisorg.scm
parent2148e68d333f0dbd3c455bc1ced4ffa4361ede3d (diff)
downloadguix-264a63d6435fe832169eedda3f03c334ea573001.tar
guix-264a63d6435fe832169eedda3f03c334ea573001.tar.gz
gnu: Add redshift-wayland
* gnu/packages/xdisorg.scm (redshift-wayland): New variable. Signed-off-by: Ludovic Courtès <ludo@gnu.org>
Diffstat (limited to 'gnu/packages/xdisorg.scm')
-rw-r--r--gnu/packages/xdisorg.scm43
1 files changed, 43 insertions, 0 deletions
diff --git a/gnu/packages/xdisorg.scm b/gnu/packages/xdisorg.scm
index 8c24ff92ec..4376c64108 100644
--- a/gnu/packages/xdisorg.scm
+++ b/gnu/packages/xdisorg.scm
@@ -1108,6 +1108,49 @@ night to daytime temperature to allow your eyes to slowly adapt. At night the
color temperature should be set to match the lamps in your room.")
(license license:gpl3+)))
+(define-public redshift-wayland
+ (let ((commit "7da875d34854a6a34612d5ce4bd8718c32bec804")
+ (revision "1"))
+ (package
+ (name "redshift-wayland")
+ (version (string-append "1.12-"
+ revision "." (string-take commit 7)))
+ (source (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/minus7/redshift.git")
+ (commit commit)))
+ (file-name (string-append name "-" version))
+ (sha256
+ (base32
+ "0nbkcw3avmzjg1jr1g9yfpm80kzisy55idl09b6wvzv2sz27n957"))))
+ (build-system gnu-build-system)
+ (native-inputs
+ `(("autoconf" ,autoconf)
+ ("automake" ,automake)
+ ("libtool" ,libtool)
+ ("pkg-config" ,pkg-config)
+ ("intltool" ,intltool)))
+ (inputs
+ `(("libdrm" ,libdrm)
+ ("libx11" ,libx11)
+ ("libxcb" ,libxcb)
+ ("libxxf86vm" ,libxxf86vm)
+ ("glib" ,glib) ; for Geoclue2 support
+ ("wayland" ,wayland)))
+ (home-page "https://github.com/minus7/redshift")
+ (synopsis "Adjust the color temperature of your screen (with Wayland support)")
+ (description
+ "Redshift adjusts the color temperature according to the position of the
+sun. A different color temperature is set during night and daytime. During
+twilight and early morning, the color temperature transitions smoothly from
+night to daytime temperature to allow your eyes to slowly adapt. At night the
+color temperature should be set to match the lamps in your room.
+
+This is a fork with added support for Wayland using the wlr-gamma-control
+protocol.")
+ (license license:gpl3+))))
+
(define-public xscreensaver
(package
(name "xscreensaver")