aboutsummaryrefslogtreecommitdiff
path: root/gnu/packages/wm.scm
diff options
context:
space:
mode:
authorHilton Chain <hako@ultrarare.space>2024-02-27 23:51:22 +0800
committerHilton Chain <hako@ultrarare.space>2024-03-09 09:32:13 +0800
commit5759e8be03486f780104a400e020992acd2982d1 (patch)
tree68098db2f1a9829ad951738e3077db8b7780966f /gnu/packages/wm.scm
parent0e9c2d2eba5e573e43382611474784c8bf5a4309 (diff)
downloadguix-5759e8be03486f780104a400e020992acd2982d1.tar
guix-5759e8be03486f780104a400e020992acd2982d1.tar.gz
gnu: sway: Update package style.
* gnu/packages/wm.scm (sway)[arguments]: Use gexps. <#:phases>: Adjust to use ‘search-input-file’. Remove trailing #t. Change-Id: I5bd91faf2c79566486437b37cf72964d2c6a85fc
Diffstat (limited to 'gnu/packages/wm.scm')
-rw-r--r--gnu/packages/wm.scm27
1 files changed, 14 insertions, 13 deletions
diff --git a/gnu/packages/wm.scm b/gnu/packages/wm.scm
index 9c0f5e38bd..edbb3096b8 100644
--- a/gnu/packages/wm.scm
+++ b/gnu/packages/wm.scm
@@ -1774,19 +1774,20 @@ modules for building a Wayland compositor.")
(base32 "1n36vgpi4bg2gkiq4fam4khly1z9bjinmjclzq5vfx0z8h7a5bzz"))))
(build-system meson-build-system)
(arguments
- `(;; elogind is propagated by wlroots -> libseat
- ;; and would otherwise shadow basu.
- #:configure-flags '("-Dsd-bus-provider=basu")
- #:phases
- (modify-phases %standard-phases
- (add-before 'configure 'hardcode-paths
- (lambda* (#:key inputs #:allow-other-keys)
- ;; Hardcode path to swaybg.
- (substitute* "sway/config.c"
- (("strdup..swaybg..")
- (string-append "strdup(\"" (assoc-ref inputs "swaybg")
- "/bin/swaybg\")")))
- #t)))))
+ (list
+ ;; elogind is propagated by wlroots -> libseat
+ ;; and would otherwise shadow basu.
+ #:configure-flags
+ #~'("-Dsd-bus-provider=basu")
+ #:phases
+ #~(modify-phases %standard-phases
+ (add-before 'configure 'hardcode-paths
+ (lambda* (#:key inputs #:allow-other-keys)
+ ;; Hardcode path to swaybg.
+ (substitute* "sway/config.c"
+ (("strdup..swaybg..")
+ (format #f "strdup(\"~a\")"
+ (search-input-file inputs "bin/swaybg")))))))))
(inputs (list basu
cairo
gdk-pixbuf