aboutsummaryrefslogtreecommitdiff
path: root/gnu/packages/webkit.scm
diff options
context:
space:
mode:
authorMaxim Cournoyer <maxim.cournoyer@gmail.com>2023-04-14 16:57:37 -0400
committerMaxim Cournoyer <maxim.cournoyer@gmail.com>2023-04-14 17:15:08 -0400
commit3bacd3c76a58ebe70f98be654f09cbd4166093ab (patch)
tree89f687565205971a9925d33400235968a569a069 /gnu/packages/webkit.scm
parentdf3391c0309443ac37f9a9a6b1038a85454b8ee6 (diff)
parent97ed675718b948319e6f6e51f2d577971bea1176 (diff)
downloadguix-3bacd3c76a58ebe70f98be654f09cbd4166093ab.tar
guix-3bacd3c76a58ebe70f98be654f09cbd4166093ab.tar.gz
Merge branch 'master' into core-updates.
Conflicts: gnu/local.mk gnu/packages/build-tools.scm gnu/packages/certs.scm gnu/packages/check.scm gnu/packages/compression.scm gnu/packages/cups.scm gnu/packages/fontutils.scm gnu/packages/gnuzilla.scm gnu/packages/guile.scm gnu/packages/ibus.scm gnu/packages/image-processing.scm gnu/packages/linux.scm gnu/packages/music.scm gnu/packages/nss.scm gnu/packages/pdf.scm gnu/packages/python-xyz.scm gnu/packages/qt.scm gnu/packages/ruby.scm gnu/packages/shells.scm gnu/packages/tex.scm gnu/packages/video.scm gnu/packages/vulkan.scm gnu/packages/web.scm gnu/packages/webkit.scm gnu/packages/wm.scm
Diffstat (limited to 'gnu/packages/webkit.scm')
-rw-r--r--gnu/packages/webkit.scm62
1 files changed, 32 insertions, 30 deletions
diff --git a/gnu/packages/webkit.scm b/gnu/packages/webkit.scm
index 8ef95ce518..815105800b 100644
--- a/gnu/packages/webkit.scm
+++ b/gnu/packages/webkit.scm
@@ -6,7 +6,7 @@
;;; Copyright © 2018–2021 Tobias Geerinckx-Rice <me@tobias.gr>
;;; Copyright © 2018 Pierre Neidhardt <mail@ambrevar.xyz>
;;; Copyright © 2019 Marius Bakke <mbakke@fastmail.com>
-;;; Copyright © 2021, 2022 Maxim Cournoyer <maxim.cournoyer@gmail.com>
+;;; Copyright © 2021, 2022, 2023 Maxim Cournoyer <maxim.cournoyer@gmail.com>
;;; Copyright © 2022, 2023 Efraim Flashner <efraim@flashner.co.il>
;;;
;;; This file is part of GNU Guix.
@@ -36,6 +36,7 @@
#:use-module (gnu packages)
#:use-module (gnu packages base)
#:use-module (gnu packages bison)
+ #:use-module (gnu packages c)
#:use-module (gnu packages compression)
#:use-module (gnu packages docbook)
#:use-module (gnu packages enchant)
@@ -123,20 +124,19 @@ the WPE-flavored port of WebKit.")
engine that uses Wayland for graphics output.")
(license license:bsd-2)))
-(define %webkit-version "2.38.5")
-
(define-public webkitgtk
(package
(name "webkitgtk") ; webkit2gtk4
- (version %webkit-version)
+ (version "2.40.0")
(source (origin
(method url-fetch)
(uri (string-append "https://www.webkitgtk.org/releases/"
name "-" version ".tar.xz"))
(sha256
- (base32 "19y1n05mp370mq4bp2bk0pm3wk49z9a10azjjdcdyx12091hrhj0"))
+ (base32 "14xkgamqlshxqw6fcslvw0yzj4y5mvx66b6bn64rwrl9pyhpwq54"))
(patches (search-patches
- "webkitgtk-adjust-bubblewrap-paths.patch"))))
+ "webkitgtk-adjust-bubblewrap-paths.patch"
+ "webkitgtk-libelogind.patch"))))
(build-system cmake-build-system)
(outputs '("out" "doc" "debug"))
(arguments
@@ -148,18 +148,26 @@ engine that uses Wayland for graphics output.")
;; binaries require 20 GiB of memory to link (even with ld.gold or lld)
;; and produce 4.6 GiB of debug symbols.
#:build-type "Release"
- #:configure-flags #~(list
- "-DPORT=GTK"
- ;; GTKDOC will be removed upstream soon in favor of
- ;; gi-docgen; it is normally disabled because the
- ;; doc is rather expensive to build.
- "-DENABLE_GTKDOC=ON"
- ;; The minibrowser, not built by default, is a good
- ;; tool to validate the good operation of
- ;; webkitgtk.
- "-DENABLE_MINIBROWSER=ON"
- ;; The default lib installation prefix is lib64.
- (string-append "-DLIB_INSTALL_DIR=" #$output "/lib"))
+ #:configure-flags
+ #~(list "-DPORT=GTK"
+ ;; GTKDOC will be removed upstream soon in favor of
+ ;; gi-docgen; it is normally disabled because the
+ ;; doc is rather expensive to build.
+ "-DENABLE_GTKDOC=ON"
+ ;; The minibrowser, not built by default, is a good
+ ;; tool to validate the good operation of
+ ;; webkitgtk.
+ "-DENABLE_MINIBROWSER=ON"
+ ;; The default lib installation prefix is lib64.
+ (string-append "-DLIB_INSTALL_DIR=" #$output "/lib")
+ ;; XXX: WebKitGTK makes use of elogind's systemd-compatible
+ ;; headers, which are under the include/elogind prefix. The WTF
+ ;; component doesn't propagate the Journald header correctly
+ ;; detected (stubs from elogind), hence the following hack (see:
+ ;; https://bugs.webkit.org/show_bug.cgi?id=254495).
+ (string-append "-DCMAKE_CXX_FLAGS=-I"
+ (search-input-directory
+ %build-inputs "include/elogind")))
;; The build may fail with -j1 (see:
;; https://bugs.webkit.org/show_bug.cgi?id=195251).
#:make-flags #~(list "-j" (number->string (max 2 (parallel-job-count))))
@@ -186,13 +194,6 @@ engine that uses Wayland for graphics output.")
(substitute* "Source/cmake/OptionsCommon.cmake"
(("if \\(LD_SUPPORTS_DISABLE_NEW_DTAGS\\)")
"if (FALSE)"))))
- (add-after 'unpack 'help-cmake-find-elogind
- (lambda _
- (substitute* "Source/cmake/FindJournald.cmake"
- ;; Otherwise, CMake would throw an error because it relies on
- ;; the pkg-config search to locate headers.
- (("pkg_check_modules\\(PC_SYSTEMD QUIET libsystemd")
- "pkg_check_modules(PC_SYSTEMD QUIET libelogind"))))
(add-after 'unpack 'embed-absolute-wpebackend-reference
(lambda* (#:key inputs #:allow-other-keys)
(let ((wpebackend-fdo (assoc-ref inputs "wpebackend-fdo")))
@@ -222,7 +223,8 @@ engine that uses Wayland for graphics output.")
pkg-config
python-wrapper
gi-docgen
- ruby))
+ ruby
+ unifdef))
(propagated-inputs
(list gtk+ libsoup))
(inputs
@@ -233,11 +235,11 @@ engine that uses Wayland for graphics output.")
geoclue
gst-plugins-base
gst-plugins-bad-minimal
- gtk+-2
harfbuzz
hyphen
icu4c
lcms
+ libavif
libgcrypt
libgudev
libjpeg-turbo
@@ -290,7 +292,7 @@ propagated by default) such as @code{gst-plugins-good} and
(replace "gtk+" gtk)))
(inputs
(modify-inputs (package-inputs webkitgtk)
- (delete "gtk+-2" "libnotify")))))
+ (delete "libnotify")))))
;;; Required by e.g. emacs-next-pgtk, emacs-xwidgets, and some other GNOME
;;; packages for webkit2gtk-4.0. See also the upstream tracker for libsoup 3:
@@ -309,13 +311,13 @@ propagated by default) such as @code{gst-plugins-good} and
(package
(inherit webkitgtk)
(name "wpewebkit")
- (version %webkit-version)
+ (version "2.40.0")
(source (origin
(inherit (package-source webkitgtk))
(uri (string-append "https://wpewebkit.org/releases/"
name "-" version ".tar.xz"))
(sha256
- (base32 "0q8nmk9l6bqv2bhljm9wv7mvgdl393z7v2m7a0c5avac18yzs07z"))))
+ (base32 "1dl663nbm011sx099x9gdhk3aj119yn5rxp77jmnhdv1l77jpv58"))))
(arguments
(substitute-keyword-arguments (package-arguments webkitgtk)
((#:configure-flags flags)