aboutsummaryrefslogtreecommitdiff
path: root/gnu/packages/web.scm
diff options
context:
space:
mode:
authorPetter <petter@mykolab.ch>2017-10-23 23:16:21 +0200
committerRicardo Wurmus <rekado@elephly.net>2017-10-24 00:06:21 +0200
commit7a04dddd268c1395d5bfc45ab55071b6faf6de79 (patch)
treef534447b9afbe7f9d6a69eb524523237f914f30a /gnu/packages/web.scm
parent0a9bdd95835b1f8a39de44f1c230504234b0fb82 (diff)
downloadguix-7a04dddd268c1395d5bfc45ab55071b6faf6de79.tar
guix-7a04dddd268c1395d5bfc45ab55071b6faf6de79.tar.gz
gnu: Add perl-html-tidy.
* gnu/packages/web.scm (perl-html-tidy): New variable. Co-authored-by: Ricardo Wurmus <rekado@elephly.net>
Diffstat (limited to 'gnu/packages/web.scm')
-rw-r--r--gnu/packages/web.scm38
1 files changed, 38 insertions, 0 deletions
diff --git a/gnu/packages/web.scm b/gnu/packages/web.scm
index 2791eb05cc..9fc47969ae 100644
--- a/gnu/packages/web.scm
+++ b/gnu/packages/web.scm
@@ -5957,3 +5957,41 @@ other program that can interface to it. The Perl module @code{HTML::Tidy} is
based on this library, allowing Perl programmers to easily validate HTML.")
;; See htmldoc/license.html
(license l:bsd-3)))
+
+(define-public perl-html-tidy
+ (package
+ (name "perl-html-tidy")
+ (version "1.60")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (string-append "mirror://cpan/authors/id/P/PE/PETDANCE/HTML-Tidy-"
+ version ".tar.gz"))
+ (sha256
+ (base32
+ "1iyp2fd6j75cn1xvcwl2lxr8qpjxssy2360cyqn6g3kzd1fzdyxw"))))
+ (build-system perl-build-system)
+ (arguments
+ '(#:phases
+ (modify-phases %standard-phases
+ (add-after 'unpack 'fix-tidyp-paths
+ (lambda* (#:key inputs #:allow-other-keys)
+ (substitute* "Makefile.PL"
+ (("^my \\$inc = \"" line)
+ (string-append line
+ "-I" (assoc-ref inputs "tidyp") "/include/tidyp "))
+ (("-L/usr/lib")
+ (string-append
+ "-L" (assoc-ref inputs "tidyp") "/lib")))
+ #t)))))
+ (inputs
+ `(("perl-libwww" ,perl-libwww)
+ ("tidyp" ,tidyp)))
+ (native-inputs
+ `(("perl-test-exception" ,perl-test-exception)))
+ (home-page "http://search.cpan.org/dist/HTML-Tidy/")
+ (synopsis "(X)HTML validation in a Perl object")
+ (description "@code{HTML::Tidy} is an HTML checker in a handy dandy
+object. It's meant as a replacement for @code{HTML::Lint}, which is written
+in Perl but is not nearly as capable as @code{HTML::Tidy}.")
+ (license l:artistic2.0)))