aboutsummaryrefslogtreecommitdiff
path: root/gnu/packages/web-browsers.scm
diff options
context:
space:
mode:
authorLiliana Marie Prikler <liliana.prikler@gmail.com>2023-10-12 08:25:26 +0200
committerLiliana Marie Prikler <liliana.prikler@gmail.com>2023-10-23 00:15:38 +0200
commitee748c1df093dd63da982e2f3cd0e11c6633d3d6 (patch)
treeda525448fc49bff7ee7da9b2ed7e326a7988e36a /gnu/packages/web-browsers.scm
parentb4c907adb4b50418fdcf1d0d44ae2433a3570f1c (diff)
downloadguix-ee748c1df093dd63da982e2f3cd0e11c6633d3d6.tar
guix-ee748c1df093dd63da982e2f3cd0e11c6633d3d6.tar.gz
gnu: Make webkitgtk-next the new webkitgtk.
As of version 2.42.0, the WebKit 6.0 typelib is considered stable. With GNOME itself moving to GTK4 as time marches on, we should reflect the fact that this is the preferred Webkit for future applications. * gnu/packages/webkit.scm (webkitgtk-next): Remove variable. Inline logic… (webkitgtk): … here. Move old value … (webkitgtk-for-gtk3): … here. (webkitgtk-with-libsoup2): Inherit from webkitgtk-for-gtk3. * gnu/packages/geo.scm (gnome-maps): Adjust accordingly. * gnu/packages/gnome.scm (gnome-initial-setup, sushi) (cambalache, devhelp, devhelp-with-libsoup2, gnome-online-accounts) (gnome-online-accounts-3.44, evolution-data-server, evolution-data-server-3.44) (lollypop, evolution, gnome-boxes, geary, komikku): Likewise. * gnu/packages/guile-xyz.scm (guile-gi, nomad): Likewise. * gnu/packages/lisp-xyz.scm (sbcl-cl-webkit): Likewise. * gnu/packages/mail.scm (balsa): Likewise. * gnu/packages/mate.scm (atril): Likewise. * gnu/packages/music.scm (ctrlr): Likewise. * gnu/packages/rednotebook.scm (rednotebook): Likewise. * gnu/packages/syndication.scm (gfeeds): Likewise. * gnu/packages/telegram.scm (telegram-desktop): Likewise. * gnu/packages/vnc.scm (remmina): Likewise. * gnu/packages/web-browsers.scm (nyxt): Likewise.
Diffstat (limited to 'gnu/packages/web-browsers.scm')
-rw-r--r--gnu/packages/web-browsers.scm2
1 files changed, 1 insertions, 1 deletions
diff --git a/gnu/packages/web-browsers.scm b/gnu/packages/web-browsers.scm
index d0b4e9f971..b5a29647bb 100644
--- a/gnu/packages/web-browsers.scm
+++ b/gnu/packages/web-browsers.scm
@@ -711,7 +711,7 @@ driven and does not detract you from your daily work.")
gsettings-desktop-schemas
cl-gobject-introspection
gtk+ ; For the main loop
- webkitgtk ; Required when we use its typelib
+ webkitgtk-for-gtk3 ; Required when we use its typelib
gobject-introspection
pkg-config))
(synopsis "Extensible web-browser in Common Lisp")