aboutsummaryrefslogtreecommitdiff
path: root/gnu/packages/vpn.scm
diff options
context:
space:
mode:
authorMarius Bakke <marius@gnu.org>2022-09-01 23:26:57 +0200
committerMarius Bakke <marius@gnu.org>2022-09-01 23:26:57 +0200
commit58863b93b0d9a191d5cca695fe0a0dfbb067ebba (patch)
tree1ee1aba5905862aaee952689e59dd2d8a9e2fce6 /gnu/packages/vpn.scm
parent2e559a358582fd8f56a035d0fac97be229752dfb (diff)
parent0c518f974e64f23846ae51ea2c68b479202fdca9 (diff)
downloadguix-58863b93b0d9a191d5cca695fe0a0dfbb067ebba.tar
guix-58863b93b0d9a191d5cca695fe0a0dfbb067ebba.tar.gz
Merge branch 'staging' into core-updates
Diffstat (limited to 'gnu/packages/vpn.scm')
-rw-r--r--gnu/packages/vpn.scm28
1 files changed, 28 insertions, 0 deletions
diff --git a/gnu/packages/vpn.scm b/gnu/packages/vpn.scm
index 1ec619b0c2..c5c5939996 100644
--- a/gnu/packages/vpn.scm
+++ b/gnu/packages/vpn.scm
@@ -1197,3 +1197,31 @@ public keys and can roam across IP addresses.")
"xl2tpd is an implementation of the Layer 2 Tunnelling Protocol (RFC 2661).
L2TP allows you to tunnel PPP over UDP.")
(license license:gpl2)))
+
+(define-public vpn-slice
+ (package
+ (name "vpn-slice")
+ (version "0.16.1")
+ (source (origin
+ (method url-fetch)
+ (uri (pypi-uri "vpn-slice" version))
+ (sha256
+ (base32
+ "1anfx4hn2ggm6sbwqmqx68s3l2rjcy4z4l038xqb440jnk8jvl18"))))
+ (build-system python-build-system)
+ (inputs (list python-dnspython python-setproctitle))
+ (home-page "https://github.com/dlenski/vpn-slice")
+ (synopsis "Split tunneling replacement for vpnc-script")
+ (description "vpn-slice is a replacement for @command{vpnc-script} used by
+@code{openconnect} and @code{vpnc}. Instead of trying to copy the behavior of
+standard corporate VPN clients, which normally reroute all your network
+traffic through the VPN, vpn-slice tries to minimize your contact with an
+intrusive VPN. This is also known as a split-tunnel VPN, since it splits your
+traffic between the VPN tunnel and your normal network interfaces.
+
+By default, vpn-slice only routes traffic for specific hosts or subnets
+through the VPN. It automatically looks up named hosts, using the VPN's DNS
+servers, and adds entries for them to your @file{/etc/hosts} (which it cleans
+up after VPN disconnection), however it does not otherwise alter your
+@file{/etc/resolv.conf} at all.")
+ (license license:gpl3+)))