aboutsummaryrefslogtreecommitdiff
path: root/gnu/packages/vim.scm
diff options
context:
space:
mode:
authormason1920 <mason1920@use.startmail.com>2023-10-08 15:57:54 -0400
committerLudovic Courtès <ludo@gnu.org>2023-10-14 22:41:44 +0200
commit63d2241ff950f2c2e9bd371b3ee0c40958946adb (patch)
treef710a57a8d04e8fa0ddbae3b3fec38521c539a9b /gnu/packages/vim.scm
parent504fdfb56fd2ba21eb39c063a0a3f965f13e5b49 (diff)
downloadguix-63d2241ff950f2c2e9bd371b3ee0c40958946adb.tar
guix-63d2241ff950f2c2e9bd371b3ee0c40958946adb.tar.gz
gnu: Add vim-rainbow
* gnu/packages/vim.scm (vim-rainbow): New variable. Signed-off-by: Ludovic Courtès <ludo@gnu.org>
Diffstat (limited to 'gnu/packages/vim.scm')
-rw-r--r--gnu/packages/vim.scm24
1 files changed, 24 insertions, 0 deletions
diff --git a/gnu/packages/vim.scm b/gnu/packages/vim.scm
index 1085db9d44..d2ea9b7ae1 100644
--- a/gnu/packages/vim.scm
+++ b/gnu/packages/vim.scm
@@ -618,6 +618,30 @@ It keeps the same selective contrast relationships and overall feel when
switching between the light and dark background modes.")
(license license:expat))))
+(define-public vim-rainbow
+ (package
+ (name "vim-rainbow")
+ (version "5c8094b56568aeaeda9cc09b3ebc6d2ed95e1ad8")
+ (source
+ (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/mason1920/rainbow")
+ (commit version)))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32 "1jya8wwlkmgs89hndrq6gsaskhk9g0fh62wdib8v9vz2x5g3738z"))))
+ (build-system copy-build-system)
+ (arguments
+ '(#:install-plan '(("opt" "share/vim/vimfiles/pack/rainbow/"))))
+ (home-page "https://github.com/mason1920/rainbow")
+ (synopsis "Rainbow Parentheses Improved")
+ (description
+ "As everyone knows, the most complex codes were composed of a mass of different
+kinds of parentheses (typically: lisp). This plugin will help you read these
+codes by showing different levels of parentheses in different colors.")
+ (license license:asl2.0)))
+
(define-public editorconfig-vim
(package
(name "editorconfig-vim")