aboutsummaryrefslogtreecommitdiff
path: root/gnu/packages/video.scm
diff options
context:
space:
mode:
authorZheng Junjie <zhengjunjie@iscas.ac.cn>2023-12-14 00:57:37 +0800
committerHilton Chain <hako@ultrarare.space>2023-12-22 21:58:01 +0800
commitfbc6683ebba637b5321e7068a9249f7d562cd65a (patch)
tree97623da682311877f9202b94efce8a738632edd5 /gnu/packages/video.scm
parent1784ece7cb61dc72a43cf8e0ad17fdbb266320e6 (diff)
downloadguix-fbc6683ebba637b5321e7068a9249f7d562cd65a.tar
guix-fbc6683ebba637b5321e7068a9249f7d562cd65a.tar.gz
gnu: libplacebo: Update to 6.338.1.
* gnu/packages/video.scm (libplacebo): Update to 6.338.1. [native-inputs]: Add glad. Change-Id: Ie9c35cfd964f110ff95ed486ee1c4f5724c82314 Signed-off-by: Hilton Chain <hako@ultrarare.space>
Diffstat (limited to 'gnu/packages/video.scm')
-rw-r--r--gnu/packages/video.scm7
1 files changed, 4 insertions, 3 deletions
diff --git a/gnu/packages/video.scm b/gnu/packages/video.scm
index b25352fdaa..3d4f280a29 100644
--- a/gnu/packages/video.scm
+++ b/gnu/packages/video.scm
@@ -67,6 +67,7 @@
;;; Copyright © 2023 Dominik Delgado Steuter <dds@disroot.org>
;;; Copyright © 2023 Saku Laesvuori <saku@laesvuori.fi>
;;; Copyright © 2023 Jaeme Sifat <jaeme@runbox.com>
+;;; Copyright © 2023 Zheng Junjie <873216071@qq.com>
;;;
;;; This file is part of GNU Guix.
;;;
@@ -1533,7 +1534,7 @@ libebml is a C++ library to read and write EBML files.")
(define-public libplacebo
(package
(name "libplacebo")
- (version "4.208.0")
+ (version "6.338.1")
(source
(origin
(method git-fetch)
@@ -1542,7 +1543,7 @@ libebml is a C++ library to read and write EBML files.")
(commit (string-append "v" version))))
(file-name (git-file-name name version))
(sha256
- (base32 "161dp5781s74ca3gglaxlmchx7glyshf0wg43w98pl22n1jcm5qk"))))
+ (base32 "1miqk3gfwah01xkf4a6grwq29im0lfh94gp92y7js855gx3v169m"))))
(build-system meson-build-system)
(arguments
`(#:configure-flags
@@ -1551,7 +1552,7 @@ libebml is a C++ library to read and write EBML files.")
(assoc-ref %build-inputs "vulkan-headers")
"/share/vulkan/registry/vk.xml"))))
(native-inputs
- (list python python-mako pkg-config))
+ (list glad python python-mako pkg-config))
(inputs
(list lcms
libepoxy