aboutsummaryrefslogtreecommitdiff
path: root/gnu/packages/video.scm
diff options
context:
space:
mode:
authorMark H Weaver <mhw@netris.org>2018-02-14 03:40:08 -0500
committerMark H Weaver <mhw@netris.org>2018-02-14 03:40:08 -0500
commit932c98326daa26657c970e38583f7904364cdd66 (patch)
treeea4b5f9cc2ee4460a119101d83ecfd0a70a44fb7 /gnu/packages/video.scm
parent870541d6a7617e127f0aa9f729fba4daa729fd91 (diff)
parent75538328c292263a0c13bef3b0058aa291aeec48 (diff)
downloadguix-932c98326daa26657c970e38583f7904364cdd66.tar
guix-932c98326daa26657c970e38583f7904364cdd66.tar.gz
Merge branch 'master' into core-updates
Diffstat (limited to 'gnu/packages/video.scm')
-rw-r--r--gnu/packages/video.scm43
1 files changed, 9 insertions, 34 deletions
diff --git a/gnu/packages/video.scm b/gnu/packages/video.scm
index 35478036d5..d945caee12 100644
--- a/gnu/packages/video.scm
+++ b/gnu/packages/video.scm
@@ -3,7 +3,7 @@
;;; Copyright © 2014, 2015, 2016 David Thompson <davet@gnu.org>
;;; Copyright © 2014, 2015, 2016 Mark H Weaver <mhw@netris.org>
;;; Copyright © 2015 Taylan Ulrich Bayırlı/Kammer <taylanbayirli@gmail.com>
-;;; Copyright © 2015, 2016, 2017 Efraim Flashner <efraim@flashner.co.il>
+;;; Copyright © 2015, 2016, 2017, 2018 Efraim Flashner <efraim@flashner.co.il>
;;; Copyright © 2015 Andy Patterson <ajpatter@uwaterloo.ca>
;;; Copyright © 2015 Ricardo Wurmus <rekado@elephly.net>
;;; Copyright © 2015, 2016, 2017, 2018 Alex Vong <alexvong1995@gmail.com>
@@ -377,7 +377,7 @@ and creating Matroska files from other media files (@code{mkvmerge}).")
(define-public x265
(package
(name "x265")
- (version "2.4")
+ (version "2.6")
(source
(origin
(method url-fetch)
@@ -385,7 +385,7 @@ and creating Matroska files from other media files (@code{mkvmerge}).")
"x265_" version ".tar.gz"))
(sha256
(base32
- "0afp0xlk0fb4q6j4sh3hyvjnjccdp61sn21zg3fyqvwgswcafalw"))
+ "1gyd94jkwdii9308m07nymsbxrmrcl81c0j8i10zhslr2mj07w0v"))
(modules '((guix build utils)))
(snippet
'(delete-file-recursively "source/compat/getopt"))))
@@ -594,14 +594,14 @@ standards (MPEG-2, MPEG-4 ASP/H.263, MPEG-4 AVC/H.264, and VC-1/VMW3).")
(define-public ffmpeg
(package
(name "ffmpeg")
- (version "3.4.1")
+ (version "3.4.2")
(source (origin
(method url-fetch)
(uri (string-append "https://ffmpeg.org/releases/ffmpeg-"
version ".tar.xz"))
(sha256
(base32
- "1h4iz7q10wj04awr2wvmp60n7b09pfwrgwbbw9sgl7klcf52fxss"))))
+ "0h6prjn1ijkzzhkyj8mazp0wpx7m0n9ycadjxagf9czqirbyk4ib"))))
(build-system gnu-build-system)
(inputs
`(("fontconfig" ,fontconfig)
@@ -1367,7 +1367,7 @@ players, like VLC or MPlayer.")
(define-public libdvdread
(package
(name "libdvdread")
- (version "5.0.3")
+ (version "6.0.0")
(source (origin
(method url-fetch)
(uri (string-append "https://download.videolan.org/videolan/"
@@ -1375,7 +1375,7 @@ players, like VLC or MPlayer.")
name "-" version ".tar.bz2"))
(sha256
(base32
- "0ayqiq0psq18rcp6f5pz82sxsq66v0kwv0y55dbrcg68plnxy71j"))))
+ "0dgr23fzcjhb7ck54xkr9zmf4jcq3ph0dz3fbyvla1c6ni9ijfxk"))))
(build-system gnu-build-system)
(arguments
`(#:configure-flags '("--with-libdvdcss=yes")))
@@ -1423,7 +1423,7 @@ MPEG-2 stream containing VOB packets.")
(define-public libdvdnav
(package
(name "libdvdnav")
- (version "5.0.3")
+ (version "6.0.0")
(source (origin
(method url-fetch)
(uri (string-append "https://download.videolan.org/videolan/"
@@ -1431,7 +1431,7 @@ MPEG-2 stream containing VOB packets.")
name "-" version ".tar.bz2"))
(sha256
(base32
- "0v8byv5z598k06rqzdmj7739vc86xq3zf79zfr698dib7lz055sh"))))
+ "062njcksmpgw9yv3737qkf93r2pzhaxi9szqjabpa8d010dp38ph"))))
(build-system gnu-build-system)
(native-inputs
`(("pkg-config" ,pkg-config)))
@@ -1452,31 +1452,6 @@ DVD virtual machine and internal playback states are completely
encapsulated.")
(license license:gpl2+)))
-(define-public libdvdnav-4
- (package
- (inherit libdvdnav)
- (version "4.2.1")
- (source (origin
- (method url-fetch)
- (uri
- (string-append
- "https://download.videolan.org/videolan/libdvdnav/libdvdnav-"
- version ".tar.xz"))
- (sha256
- (base32
- "0wi3gy408c8xj0ism0hckv5jbfh3lg4pmgxv87gbch9jrhp2gjkz"))))
- (native-inputs
- `(("pkg-config" ,pkg-config)
- ("autoconf" ,autoconf)
- ("automake" ,automake)
- ("libtool" ,libtool)))
- (arguments
- '(#:phases
- (modify-phases %standard-phases
- (add-after 'unpack 'autoreconf
- (lambda _
- (zero? (system* "autoreconf" "-vif")))))))))
-
(define-public libdvdcss
(package
(name "libdvdcss")